Forum Programmation.autre Versions minimales requises pour bibliothèques dans les dépendances

Posté par (page perso) .
3
19
fév.
2012

Bonjour,

J'espère ne pas poser de question qui serait super simple à résoudre par google, mais j'avoue que je ne sais pas trop quoi chercher.

Alors voilà mon souci : j'ai commencé un petit projet (un jeu de tarot) en Vala, et je viens, avec une joie indicible, de commencer à mettre tous les fichiers pour les autotools.

Dans le fichier configure.ac (et j'imagine qu'il y a le même genre de choses quand on veut proposer des paquets pour des distribs), il faut préciser les bibliothèques requises, et leurs version, ce qui donne en l'occurrence : 

pkg_modules="gtk+-3.0 >= 3.2.0 gee-1.0 >= 0.6.0 glib-2.0 >= 2.30.0 "

Alors, voilà mon dilemme : quels numéros de version mettre ? Là, j'ai fait un peu au pifomètre (en prenant les numéros de version que j'avais et en mettant le dernier numéro à 0) mais je me demande ce qu'on est censé faire pour que ce soit un peu propre ?

Notamment, je pense qu'il y a deux approches : mettre la version que j'ai, en me disant que «là au moins je suis sûre que ça marche» (mais du coup ça va pas vouloir compiler chez des gens chez qui ça marcherait pourtant), ou mettre des versions plus basses, au risque qu'il y ait des soucis chez des gens ?

Idéalement, je pourrais regarder quand ont été implémentées toutes les fonctions que j'utilise, mais même si j'ai du temps libre, bof, quoi. Est-ce qu'il y aurait des outils qui feraient ça automatiquement ?

  • # faire simple pour demarrer

    Posté par . Évalué à 3.

    deux approches, que tu as bien listé :
    - soit prendre celle de ta machine, en te disant que ca sera le minimum requis, mais ca peut limiter le nombre d'utilisateur potentiels
    - soit prendre le minimum commun avec lequel ca va marcher, mais ca te demande de faire plus de tests.

    pour un lancement de projet, je penses que tu peux prendre les versions de ta machine actuelle, ce sera deja un bon debut.

    • [^] # Re: faire simple pour demarrer

      Posté par (page perso) . Évalué à 3.

      Sur beaucoup de projets de librairies, le changement du numéro majeur est celui qui dénote une mutation des interfaces. En ce renseignant un peu sur les librairies, il doit être raisonnablement possible d'éviter de préciser le second numéro en évitant à la fois des recherches historiques extensives et quelques exclusions inutiles. Quelques essais sur une distribution aux librairies bien « stabilisées » voire une peu anciennes comme CentOS ou Debian stable pourrait également être envisagés.

      Ensuite, comme suggéré par Neox et à condition de se réserver d'anciennes versions des librairies pour tests, l'évolution fera son œuvre et la majorité des utilisateurs potentiel se retrouvera compatible par défaut.

  • # Pas de downgrade sans test

    Posté par (page perso) . Évalué à 4.

    Je pense que le plus simple est de mettre celles que tu as sur ta machine et d'aider les gens à tester s'ils veulent utiliser ton projet avec des versions plus anciennes.

    « Rappelez-vous toujours que si la Gestapo avait les moyens de vous faire parler, les politiciens ont, eux, les moyens de vous faire taire. » Coluche

  • # Merci

    Posté par (page perso) . Évalué à 2.

    Merci pour les réponses, je vais effectivement partir sur les versions que j'ai, tout en essayant de tester sur quelques autres machines, histoire de prendre la plus basse qui marche :)

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.