mcercle - version 1.0

Posté par (page perso) . Édité par Xavier Claude et Florent Zara. Modéré par Florent Zara. Licence CC by-sa
21
3
avr.
2012
Bureautique

mcercle est un logiciel de gestion libre sous licence GPLv3 pour autoentrepreneur, artisans ou PME. Il se veut léger, ergonomique tout en gardant les performances d’un logiciel de gestion professionnel. Il est multiplate-forme s’exécutant sous MS Windows, GNU/Linux et peut-être Mac OS X :-)
mcercle
mcercle est sorti en version 1.0 et est maintenant désormais prêt pour être utilisé par les autoentrepreneurs, les artisans et PME suivront avec la gestion des TVA.

Profitez-en ;-)

Caractéristiques principales

  • Gestion clients : carnet d’adresse, interventions, devis, factures ;
  • Gestion produits : références fournisseurs, gestion du stock avec seuil d’alerte ainsi qu’un classement par catégorie ;
  • Gestion des fournisseurs : nom du contact fournisseur, adresse, téléphone… ;
  • Base de données : sauvegarde des données dans une base de données sécurisée (Firebird).

Caractéristiques techniques

  • # Excellent Logiciel pour les Auto Entrepreneurs

    Posté par (page perso) . Évalué à  -10 .

    Un excellent logiciel que je m'empresse d'aller présenter sur mon blog dédié aux auto-entrepreneurs ! Pour ceux qui sont intéressés par ce statut, je vous invite à venir faire un petit tour d'ailleurs (pub) :)

  • # ça marche pas out of the box

    Posté par . Évalué à  -2 . Dernière modification : le 03/04/12 à 18:01

    Quand on l'installe et le lance il commence par gueuler qu'il n'arrive pas à se connecter à la base et aucune explication de comment on créée/installe la base n'est fournie.

    J'attends la 2.1 pour tester du coup

    Mais c'est bien d'avoir choisi Qt et d'être cross-plateform :-)
    Perso la méthode la plus simple que j'ai trouvé pour fournir une appli Qt aussi sur Mac a consisté à acheter un Mac Mini à 600 euros sans écran souris ni clavier, c'est simple et pas si cher que ça.

    • [^] # Re: ça marche pas out of the box

      Posté par (page perso) . Évalué à  4 .

      Quand on l'installe et le lance il commence par gueuler qu'il n'arrive pas à se connecter à la base et aucune explication de comment on créée/installe la base n'est fournie.

      Comment ca ? dans le message d'erreur il y a un bouton "Détails" merci de m'envoyer un mail avec le contenu du message…
      Sur quel système (MSwindows, GNU/Linux) Firebird est-elle bien installée et configurée dans le cas de Linux?

      • [^] # Re: ça marche pas out of the box

        Posté par . Évalué à  2 .

        Alors:

        Sous Windows (Seven, Pro, 64 bits, SP1, patches à jour).

        Quand je fais un copier/coller de la boîte détail pour l'erreur, le coller donne ça (alors que je sélectionne les détails avant de faire le Ctrl C !)

        ---------------------------
        Erreur
        ---------------------------
        <b>La connexion avec la base de donn&#233;es n&#146;a pas pu &#234;tre &#233;tablie!> </b>
        ---------------------------
        OK   Hide Details...   
        ---------------------------
        
        

        Les détails sont trop long à recopier à la main, et la capture d'écran serait d'une part honteuse d'autre part partielle à cause de l’ascenseur et de la boîte de dialogue non redimensionnable..

        Je n'ai pas l'impression que l'installeur a installé Firebird, mais je n'en sais rien, et aucun message ne me dit quoi faire.

        Pour toutes ces raisons, puisque c'est une version 1.0, je vais attendre la 2.1 pour tester. Désolé.

    • [^] # Re: ça marche pas out of the box

      Posté par . Évalué à  -2 .

      Perso la méthode la plus simple que j'ai trouvé pour fournir une appli Qt aussi sur Mac a >consisté à acheter un Mac Mini à 600 euros sans écran souris ni clavier, c'est simple et >pas si cher que ça.
      Et quand tu auras 50 ans, tu auras ta Rollex bien sur….

      • [^] # Re: ça marche pas out of the box

        Posté par . Évalué à  4 .

        Si je fais du développement sur Rolex, oui.

      • [^] # Re: ça marche pas out of the box

        Posté par . Évalué à  2 .

        Une roLLex avant 50 ans ? Même demain si tu veux, sur tous les bons marchés où les commerçants se mettent à sprinter à la vue de la police :)

        • [^] # Re: ça marche pas out of the box

          Posté par . Évalué à  0 . Dernière modification : le 05/04/12 à 14:18

          Je crois que c'était une allusion à une phrase fort malheureuse d'un patron de pub célèbre (google s'en souvient) probablement destinée à créer une sorte d'analogie fondée sur: acheter un mac pour compiler = être un con de bourge de droite. Je n'ajoute pas sarkozyste parce qu'on approche le point Godwin.

          À noter que je n'apprécie pas d'être obligé d'acheter un mac pour compiler sur mac (pas plus que d'être obligé d'acheter un windows pour compiler sur windows), je faisait juste part de la méthode la plus efficace que j'ai trouvée et jugeait juste que le prix n'était pas rédhibitoire face au marché que représente les utilisateurs de mac incapables de compiler à partir des sources.

    • [^] # Re: ça marche pas out of the box

      Posté par (page perso) . Évalué à  3 .

      La méthode la plus simple, c'est de fournir les sources. Avec les OS libres, compiler une application Qt c'est facile, alors je suppose que sous Mac OS X, ça doit être pareil.

      Newton Adventure est sur Lumière Verte : http://steamcommunity.com/sharedfiles/filedetails/?id=187107465

  • # Paquet Debian

    Posté par . Évalué à  1 .

    Serait-il possible d' inclure dans les sources un répertoire contenant le nécessaire de fabrication d' un paquet deb. Je suis en amd64 et évidemment dpkg refuse le paquet i386.
    Merci

    • [^] # Re: Paquet Debian

      Posté par (page perso) . Évalué à  3 .

      Oui ce serait possible mais je ne maitrise pas le package debian…
      mais il est trés facile de compiler mcercle pour de amd64 à partir des sources.
      tout est dans le fichier "install".

      Packages to build mcercle: build-essential, qt4-dev-tools (>= 4.6), firebird2.5-dev, checkinstall.
      how to:
      $ qmake mcercle.pro
      $ make
      $ checkinstall

  • # BUG dans la V1.0

    Posté par (page perso) . Évalué à  2 .

    un bug c'est glissé à la dernière minute dans la version 1.0…(modif de dernière minute qui ne sert à rien en plus :-X) Dsl! c'est corrigé merci de re-télécharger les binaires avec les corrections.

    Pour ceux qui ont des soucis de connexion avec la base de données firebird sous le win7 64bits, merci de désinstaller la version 64bits de firebird et d'installer la version 32bits à la place!

  • # Web?

    Posté par . Évalué à  1 .

    Je trouve l'initiative excellente. Félicitations!

    À quand une archi "orientée web" pour pouvoir gérer son entreprise via son navigateur favori en itinérance (maison, déplacement, etc…)?

    Encore bravo!

  • # Base de données et versions futures

    Posté par (page perso) . Évalué à  1 .

    Question pour les versions futures:

    Pensez-vous que mcercle devrait avoir une base SQLITE pour être autonome, au détriment de la fonctionnalité de multiconnexion (PC gestion sotck et PC facturation par exemple) ?

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.