• # Y a aussi des paquets...

    Posté par . Évalué à 6.

    ...chez http://battlehorse.homelinux.net/w/Wiki.jsp?page=Xgl

    Et ils marchent très bien. Tout s'installe dans /opt/fdo, et surtout, c'est très facile à désinstaller quand on ne souhaite que faire un petit test ;-)
  • # Chez mouâ, ça marche...

    Posté par (page perso) . Évalué à -10.

  • # Config

    Posté par . Évalué à 1.

    On en a déjà parlé mais pas jusqu'a fournir une réponse complète: quelle config minimale pour que ça soit fluide ?

    Pourrais-je impressionner mes amis windowsiens avec Xgl sur GeForce 1 32Mb (et un prog en dessous de 1Ghz) ? :P

    Vos retours sont les bienvenus !
    • [^] # Re: Config

      Posté par . Évalué à 3.

      J'ai un vieux vieux vieux ordi fixe dont le proc est cadencé à 600mhz et équipé d'une radeon 9200SE à pas cher. J'ai testé dessus dapper (ubuntu instable) + xgl (en suivant http://wiki.ubuntu.com/XglHowto ) sans installer les drivers proprio ati :

      * Et bien étonnament, ca marche. Et plutot pas mal.
      * Ce qui fonctionne : le deplacement "mou" des fenetres, alt+tab, le cube (pas extremement fluide mais quand même), et surtout expose (tres pratique/sympa meme si je lance rarement plus de 2 applis en même temps sur ce poste), les effets sur les menus (inutile mais joli)
      * Ce qui ne fonctionne pas : le zoom (j'ai pas trouvé pour l'activer, ctrl+molette n'ayant aucun effet), la minimisation des fenetres/ouverture depuis la barre des taches est tres lente, parfois on a des petits flash d'écran noir lorsqu'on joue avec le cube.

      J'ai également testé sur mon portable Samsung V20 équipé d'une carte graphique intel : c'est 100% inutilisable, le serveur X affichant une bouillie de pixel avant de lancer compiz, puis un écran tout noir sauf la fenetre active une fois compiz lancé.

      Conclusion : Si t'as de l'ATI ou Nvidia, pourquoi pas, si t'as de l'intel c'est pas demain la veille.
      • [^] # Re: Config

        Posté par . Évalué à 3.

        Salut,

        Pour le zoom, il faut triturer un peu gconf : /apps/compiz/plugins/zoom/screen0/options , les options initiate et terminate devrait t'aider. Par défaut c'est qui est utilisé, il suffit de mettre et ça marche.

        Pour les carte intel, ça dépend des chipset, et le pilote à besoin de pas mal de travail encore pour que ça fonctionne. Cf http://en.opensuse.org/Using_Xgl_on_SUSE_Linux#Intel_.2F_ope(...)

        De même, les petites bogues avec le pilote libre radeon devront être corrigé avec le temps. Ça reste quand même très bien pour un pilote libre !

        Ave.
      • [^] # Re: Config

        Posté par . Évalué à 1.

        Merci !
        C'est quasiment ma config quotidienne : Athlon 600Mhz Avec une GeForce 256 32Mb (qui fut d'ailleurs fort chère à l'époque !), 384Mb de ram (ici c'est la RAM de la carte graphique qui est importante uniquement ?)

        J'utilise les drivers proprio de Nvidia (et oui, désolé) du coup je vais tenter le coup, même si les tutoriaux ci-dessus ne m'insprirent pas forcément confiance (je ne comprends pas la langue surtout en fait)

        Vous ferai un retour si ça fonctionne !
  • # Test....

    Posté par . Évalué à 2.

    Hum... j'ai pas (encore) réussi

    Marche a suivre:
    Télécharger et "aliener" les rpm donnes sur la page de suse.
    Télécharger et décompresser dans /usr/lib le fichier xgl_libs.tgz
    Installez les deb créés.
    apt-get install libsvg libdrm2 libpng3 : le paquet libsvg n'est pas dans etch ?! (bon j'ai tenté sans...)

    Puis exécuter le script donnée en dehors de gdm.
    Résultat: écran gris avec le curseur en croix, rien d'autre.
    Je relance gdm et gnome: l'entrée en session ne fait rien (gnome pas lancé) et je me retrouve donc sous KDE....

    Voilà ou j'en suis (mais j'aimerai bien retrouver gnome !)
    • [^] # Re: Test....

      Posté par . Évalué à 2.

      Bon j'ai pas le xorg quivabien ------> [] (mais j'ai tjrs pas retrouvé gnome...)
    • [^] # Re: Test....

      Posté par . Évalué à 3.

      Salut,

      Le Xgl howto sur ubuntu.com est très simple et fonctionne très bien. Il pollue beaucoup moins le système.

      https://wiki.ubuntu.com/XglHowto

      Ave.
      • [^] # Re: Test....

        Posté par . Évalué à 1.

        Merci, mais c'est pour Ubuntu et Dapper... je suis en Debian (c'est le sujet du journal)

        Je vais également tenter sur Ubuntu. (Debian attendra...)
        Il y a une démarche pour le 64bits ici : http://www.ubuntuforums.org/showthread.php?t=133427
        • [^] # Re: Test....

          Posté par . Évalué à 1.

          Je m'auto-réponds encore, mais je confirme que cette marche à suivre fonctionne parfaitement.

          Xgl est génial à utiliser, le truc du type "expose" de MacOS est réellement pratique.
          De plus, l'interface semble plus réactive. Le alt-tab est pratique et joli.
          Merci les développeurs !
    • [^] # Re: Test....

      Posté par . Évalué à 2.

      youpi, ça marche chez moi :)

      par rapport au site indiqué dans le journal, je crois que la commande qu'il donne a qques erreurs. Essayer cela à la place :

      Xgl :1 -accel glx:pbuffer -accel xv:fbo:1 & sleep 5 ; DISPLAY=:1 gnome-session & sleep 30 ; DISPLAY=:1 compiz --replace gconf decoration wobbly fade minimize cube rotate zoom scale move resize place menu & DISPLAY=:1 gnome-window-decorator

      (il y a :1 après Xgl, et c'est window-decorator et non pas decoration)
      Et si on ajouter l'option switcher en plus, on a l'effet spécial avec alt+tab

      C'est super agréable et très beau, et l'effet 'exposé' façon osx rend très bien (mieux que osx en plus)

      Only wimps use tape backup: real men just upload their important stuff on megaupload, and let the rest of the world ~~mirror~~ link to it

  • # YEAAAAAAAAAAAAH !

    Posté par . Évalué à 3.

    Bon les gens/gentes :!!!!
    je viens d'installer compiz/xgl sur une debian unstable !
    c'est trop beauuuuuuuuuuuuuuuuuuuuuuuuuu !
    mais il manque 2/3 plugins qui permettent le cube et le zoom,
    j'ai ceci au demarage :

    nimize cube rotate zoom scale move resize place switcher
    compiz: Couldn't load plugin 'libcube.so'
    compiz: 'rotate' plugin must be loaded after 'cube' plugin
    compiz: Can't activate 'rotate' plugin due to dependency problems
    compiz: 'zoom' plugin must be loaded after 'cube' plugin
    compiz: Can't activate 'zoom' plugin due to dependency problems

    Si quelqu'un a une idée, j'ai trouvé qu'il y avait un nouveau paquet compiz-gnome...
    a mediter
    • [^] # Re: YEAAAAAAAAAAAAH !

      Posté par . Évalué à 2.

      Salut,

      Ça y est, le debianeux frustré montre à tous le monde qu'on peux avoir compiz sur sa debian **aussi** :P

      Comme tu peux le lire, les plugins ont des dépendances, ils doivent être lancés dans un ordre. À toi de le trouver soit en dans un tuto, soit à tatons.

      Il faut pas hésiter à se balader dans /apps/compiz/ avec gconf-editor pour avoir un truc adapté. Enfin, pour avoir une carte clavier correcte en français, je rappelle la commande :

      xmodmap /usr/share/xmodmap/xmodmap.fr

      > a mediter
      Oh là, t'es vraiment parti en vrille là :)

      Ave.
      • [^] # Re: YEAAAAAAAAAAAAH !

        Posté par . Évalué à 1.

        mais comme tu peux le lire il y a un probleme avec libcube..
        • [^] # Re: YEAAAAAAAAAAAAH !

          Posté par . Évalué à 2.

          J'ai rien dit, mais en meme temps malgré qu'il ne fasse plus l'erreur ca ne fonctionne quand meme pas... donc bon...
    • [^] # Re: YEAAAAAAAAAAAAH !

      Posté par . Évalué à 1.

      Ok, ca marche sur la sid ;) C'est parfait . adopté.

      Je n'arrive malheureusement pas à utiliser ou voir autre chose que du blnac sur les faces superieur et inferieur du cube.

      J'ai en plus cette erreur :
      compiz:dlsym: /usr/lib/libmenu.so: undefined symbol: getCompPluginInfo
      compiz: Failed to lookup getCompPluginInfo in 'libmenu.so' plugin

      au lancement de ceci :
      compiz --replace decoration wobbly fade minimize cube rotate zoom scale move resize place switcher menu

      any idea ?
      • [^] # Re: YEAAAAAAAAAAAAH !

        Posté par . Évalué à 1.

        compiz --replace gconf decoration wobbly fade minimize scale move resize place switcher cube rotate zoom

        mais le cube ne fonctionne quand meme pas...
        • [^] # Re: YEAAAAAAAAAAAAH !

          Posté par . Évalué à 1.

          En mettant gconf en premier, je n'ai plus la possibilité de faire ALT-TAB :/ Je n'ai pourtant aucun message d'erreur au lancement de compiz. Et les faces superieur et inferieur du cube ne fonctionne pas non plus. space :o
          • [^] # Re: YEAAAAAAAAAAAAH !

            Posté par . Évalué à 1.

            alors la ligne que j'ai donné fonctionne,
            meme avec le cube maintenant ( j'ai réparé ce matin )
            donc le probleme etait qu'il y avait des librairies qui n'etaient pas libcairosvg en particulier.

            pour le savoir (chez moi en tout cas )

            ldd /usr/lib/compiz/libcube.so

            et voir les lignes ou il y a des "not found"
            les trouver, et les mettre au bon endroit.
            • [^] # Re: YEAAAAAAAAAAAAH !

              Posté par . Évalué à 1.

              Ok étrange en mettant gconf je n'ai plus de alt tab et quelques comportement etrange, j'arrive cependant bien a changer de svg sur la face superieur du cube ( pas inferieur, rien a faire ) :p Pourtant aucune erreur au lancement de compiz et ldd libcube.so ne me montre aucun "not found" ;)
              Merci quand même pour ton retour.
              En tout ca c'est bien jolie :p
            • [^] # Re: YEAAAAAAAAAAAAH !

              Posté par . Évalué à 1.

              Bon tout marche, sauf wobbly ( l'effet "fenetres molles" si je ne m'abuse ).
              Pouvez vous me dire quels sont vos valeurs, dans gconf, des clés "Focus_window_types" et "grab_window_types".

              Voici ma conf wobbly :

              focus_effect Shiver
              focus_window_type []
              friction 3
              grab_window_types []
              grid_resolution 8
              map_effect Shiver
              map_window_types [Splash,Unknown]
              min_grid_size 8
              move_window_types [Toolbar,Menu,Utility,Dialog,Normal]
              snap spring_K 8

              je lance compiz comme ceci :

              compiz --replace gconf decoration wobbly fade minimize cube rotate zoom scale move resize place menu

              Tout baigne coté dépendance ou message d'erreur.
              ldd /usr/lib/compiz/libcube.so ok
              • [^] # Re: YEAAAAAAAAAAAAH !

                Posté par . Évalué à 1.

                compiz --replace gconf decoration wobbly fade minimize scale move resize place switcher cube rotate zoom

                et sinon j'ai exactement les memes valeurs...
                • [^] # Re: YEAAAAAAAAAAAAH !

                  Posté par . Évalué à 1.

                  compiz --replace gconf decoration wobbly fade minimize cube rotate zoom scale move resize place menu
                  et
                  compiz --replace gconf decoration wobbly fade minimize scale move resize place switcher cube rotate zoom

                  me donne exactement la meme chose. mais dans les deux cas wobbly ne marche pas :'o
                  • [^] # Re: YEAAAAAAAAAAAAH !

                    Posté par . Évalué à 1.

                    Ok ca roule !

                    Dans gconf, il manquait la valeur "wobbly" a la liste de valeur de la clé active-plugins.


                    tout fonctionne... ca me plait grave moi xgl.

                    A quand e17 && Xgl ?

                    Mais apparement ils ne sont pas très chaud à l'idée.

                    Tout baigne, merci novell, merci linufr, merci Nauhuel.
                    • [^] # Re: YEAAAAAAAAAAAAH !

                      Posté par . Évalué à 1.

                      Nahuel ;)

                      Xgl... quand tu nous tient !
                      d'ailleur l'autre jour je suis rentré chez moi... ( où il n'y a pas xgl )... je me suis senti tout vioc ;)
    • [^] # Re: YEAAAAAAAAAAAAH !

      Posté par . Évalué à 1.

      J'ai cru comprendre que sous Debian il fallait avoir XORG version 7.
      Est-ce que c'est vrai ?
      • [^] # Re: YEAAAAAAAAAAAAH !

        Posté par . Évalué à 1.

        Pas que sous debian.
        Mais ce qu'ils appellent Xorg 7 est Xgl.
        Il faut juste alieniser les fichiers .rpm de suse et tout roule à quelques bidouillages près.
        • [^] # Re: YEAAAAAAAAAAAAH !

          Posté par . Évalué à 1.

          Moi j'ai trois process qui tourne : Xorg, Xgl, et Compiz. Xorg est en version 7. J'en déduis que Xgl est donc un module, un process qui tourne a coté de Xorg, et qui lui apporte des fonctionalités; Mais je me trompe peut être ...
          • [^] # Re: YEAAAAAAAAAAAAH !

            Posté par . Évalué à 1.

            Compiz est le remplacent de metacity ( pour gnome ).
            donc le manager de fenetres.

            Xgl est a mon avis ce qui gere le controle du calcul par le GPU
            et Xorg doit etre ce qui fait l'interface entre lesl ibrairies graphiques et l'interface avc la carte graphique
          • [^] # Re: YEAAAAAAAAAAAAH !

            Posté par . Évalué à 1.

            http://principe.homelinux.net/

            petite url pour savoir comment fonctionne Xgl

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.