Visualiser une révision

Rédiger avec LibreOffice Writer pour Linuxfr

Ysabeau : révision n°4 (18 avril 2019 11:32:15)

Une dépêche, un journal ou une page de wiki n’ont aucun caractère d’urgence et gagnent à être soigneusement mitonnés. Autant utiliser un outil performant de rédaction avec tout le confort moderne d’un excellent correcteur orthographique, grammatical et orthotypographique doté d’un conjugueur et de la facilité à introduire des caractères dits spéciaux. Ça va éviter pas mal de fautes diverses et faciliter la rédaction tout en donnant un peu de recul.

Ce tutoriel est un complément aux autres pages d’aide à la rédaction du site linuxfr. On y retrouvera donc des éléments qui figurent dedans mais sélectionnés et réunis dans une optique de rédaction avec l’application de traitement de texte de LibreOffice.

**À savoir** : si LibreOffice permet de générer des pages de wiki au format mediawiki, il faut un compte d’accès à un serveur wiki pour que ça fonctionne. On oublie. Par ailleurs, si vous mettez proprement en forme votre texte avec des styles et que vous le copiez-collez, ça ne passe pas. **Solution** : marquer votre texte avec les marqueurs « Markdown ». C’est facile et cela ne vous empêche pas de structurer et mettre en forme votre texte avec des styles pour un meilleur confort de travail.

# La structure
## Les titres
Les titres sont marqués avec des croisillons : # de un à cinq selon le niveau de titre. Paramétrez la *Numérotation des chapitres* (menu *Outils*) : pour chaque niveau de titre (de un à cinq) indiquez comme séparateur *Avant* un # pour le titre de premier niveau, deux pour le titre 2, etc.
Vous pouvez même enregistrer le format au besoin, vous le retrouverez dans la liste des formats de numérotation des chapitres.
## Les listes
Il y a deux types de listes : les listes à puce, ou listes non-ordonnées et les listes numérotées ou listes ordonnées. On ne peut pas utiliser les styles dans ce cadre.
Dans les deux cas, en typographie française, à la fin de chaque élément, saisir un point virgule précédé d’une espace insécable (normalement l’autocorrection transforme automatiquement l’espace normale en insécable de ce type de ponctuation) et allez à la ligne. Le dernier élément se termine par un point.
La marque de la liste à puce est l’astérisque suivi d’une espace, Unicode 2A : *
* liste ;
* liste.
Pour introduire un sous-élément, faire deux espaces et saisir l’astérisque : *. cela ne fonctionnera que si le premier sous-élément est précédée d’un élément de liste.
La marque de la liste numérotée est le numéro suivi d’un point et d’une espace : « 1. ».
1. numéro 1 ;
2. numéro 2.

# La mise en forme et la saisie
## Mise en forme : gras et italiques
Pour marquer un mot en italique, il faut l’encadrer d’astérisques, sauf que, dans les options d’Autocorrection de Writer, cette opération, souvent, change le texte en gras, un « gras » qui ne passe pas dans le copier-coller vers Linuxfr. Il faut donc commencer par aller dans les **Outils > Autocorrection** et là, aller sur l’onglet **Options**, décocher les deux cases *gras*, /italique/, etc.
Pour mettre en italiques, encadrer l’expression d’un astérisque, pour le gras, de deux astérisques.
## Liens, codes, citations
Pour les **liens externes**, mettre le texte de présentation du lien entre crochets ouverts et fermants : [ et ] et le lien lui-même entre parenthèses ( et ). Il y a [d’autres catégories de liens détaillées sur cette page du wiki](https://linuxfr.org/wiki/aide-edition#hyperliens).
Pour le **code avec coloration syntaxique**, insérer une ligne blanche avant puis saisir trois apostrophes inversées ``` suivies du nom du code, aller à la ligne saisir un croisillon, taper ou copier-coller le code terminer en passant à la ligne et en saisissant ces mêmes apostrophes inversées. L’apostrophe inversée s’obtient, avec un clavier azerty par le raccourci clavier *Alt Gr + 7*[^1 Numéro Unicode ?]. 

Les **citations** commencent à la ligne suivante par un signe supérieur, rajouter une ligne à la fin de la citation : >
>Avant d’entrer dans ma cellule 
Il a fallu me mettre nu 
Et quelle voix sinistre ulule 
Guillaume qu’es-tu devenu

# Astuces LibreOffice
## Saisie de caractères «  spéciaux »
Avec Writer, si on saisit le code Unicode du caractère et qu’on le fait suivre par le raccourci *Alt + X* on obtient le caractère désiré, par exemple B6 suivi d’*Alt + X* donne la marque de paragraphe ¶. 
Cela fonctionne avec tous les OS et surtout **tous** les claviers. Les limites : la police utilisée doit les avoir.
## Rédaction
Tout rédiger y compris le titre, l’introduction et les liens selon le type de contenu. De cette façon vous bénéficiez du confort de rédaction du traitement de texte et du correcteur orthographique, grammatical et orthotypographique ce qui évite notamment les acrobaties de montée et descente pour copier-coller les caractères, les espaces insécables et autres. Passer le titre en style **Titre principal** (bouton Titre dans le modèle) peut aider au confort visuel.
Pour les liens des dépêches à saisir dans les cartouches de saisie, saisissez-les, par exemple, à la fin de la dépêche, avec le titre et l’URL à côté. Les vérifications et les ajouts dans la dépêche seront plus faciles.

## Le modèle
Le modèle de document, au format ODF, a tous les styles signalés déjà paramétrés et quelques autres éléments utiles qui vous permettent de l’utiliser de façon autonome. Ces éléments figurent aussi dans les commentaires des **Propriétés** du document (menu **Fichier**), vous pourrez les effacer sans problème.
Il est également doté d’une barre d’outils spécifique avec les styles concernés dans le cadre de ce tutoriel. En cliquant sur le bouton du style, on l’attribue au paragraphe. Le niveau de titre des boutons ne va que jusqu’au niveau 3. Au-delà c’est trop (déjà trois…).
Vous travaillerez plus facilement et pourrez mieux contrôler votre travail en affichant les caractères invisibles : **Affichage > Marques de formatage** ou *Ctrl +F10*.
Pour l’utiliser, après l’avoir téléchargé, enregistrez-le comme modèle : **Fichier > Modèles > Enregistrer comme modèle**, ensuite pour créer des documents à partir de ce modèle, **Fichier > Nouveau > Modèles** ou *Maj + Ctrl + N*, choisir ce modèle *Linuxfr rédaction*.

**Télécharger le modèle** : [fichier linuxfr_redaction.ott](https://linuxfr.org/images/historique/linuxfr_redaction.ott), 14,5ko.

# L’ajout à Linuxfr
Après avoir pris le temps de rédiger votre texte et l’avoir relu, il reste à le copier-coller dans une dépêche, un journal ou une page de wiki.
**Pour les journaux et le wiki** :  copier-coller le texte. Ajouter le sujet du journal ou du wiki, prévisualiser, corriger au besoin, et poster.
**Pour les dépêches** : si vous l’avez intégralement rédigée avec son chapeau d’introduction et son titre. Commencer par le titre, puis par le chapeau dans la zone *Contenu de la dépêche* et enfin tout le reste, sauf les liens, dans la zone *Seconde partie*. Il ne restera plus qu’à rajouter les liens un à un dans les zones prévues et, évidemment, relire et corriger ce qui doit l’être avant de soumettre la dépêche.
# L’utilisation de Grammalecte et autres astuces
## Grammalecte
Grammalecte est l’extension de correction orthographique, grammaticale et orthotypographique du français de LibreOffice (elle existe aussi pour Firefox, Thunderbird et Chrome). On peut choisir le titre d’orthographe, réforme de 1990 ou celle dite « classique » et configurer les options grammaticales. Laisser les options par défaut pour ces dernières surtout si vous êtes fâché avec l’orthographe.
Outre les fonctions de corrections qui, bien que performantes n’ont aucune capacité de vérification sémantique et pas plus que les autres logiciels de ce type, il propose deux outils fort utiles :

* le Conjugueur ;
* et le Formateur de texte.

Le premier, comme son nom l’indique, vous permet d’avoir la conjugaison d’un verbe et donc de limiter, normalement, les confusions entre l’infinitif des verbes de premier groupe, la deuxième personne du pluriel au présent ou encore le participe passé et, bien évidemment de vérifier la conjugaison du verbe. C’est tout sauf un gadget.
Le second permet de mettre votre texte d’équerre avec la typographie, c’est un outil précieux également. Mais peut-être à éviter si vous avez du code.
## Astuces
Le recours à un dictionnaire comme, par exemple, celui du Centre National de Ressources textuelles et Lexicales (CNRTL) n’est jamais inutile pour vérifier le sens d’un mot il devrait d’ailleurs figurer dans la liste des moteurs de recherche accessible par un clic de votre navigateur. Néanmoins, sans consulter un dictionnaire, si on hésite entre deux ou trois graphies pour un mot, par exemple « des », « dés » et « dès », faire un clic droit sur le mot et regarder les synonymes que vous propose Grammalecte. Ils vous donnent le sens du mot et vous permettent de trouver la bonne graphie.
Et, quand Grammalecte vous signale soit une faute (quelque chose qu’il n’a pas dans ses lexiques) soit une possible erreur (grammaire, typographie qu’il soupçonne fautive), faites un clic droit sur l’expression et lisez ce que Grammalecte vous explique avant d’approuver ou d’ignorer.
Si l’accord des participes passés vous donne des mots de tête et que même [le dossier de langue-fr.net](http://www.langue-fr.net/Accord-du-participe-passe) ne vous aide pas, essayez de rédiger autrement afin de les éviter. Souvent, vous gagnez en fluidité de la lecture. Le conjugueur de Grammalecte vous en donne la graphie y compris au féminin.
D’une manière générale, quand vous avez un problème lié à un accord, rédiger autrement permet de le contourner et pas forcément au détriment du texte.
# Pour aller plus loin
Wiki Aide Edition : https://linuxfr.org/wiki/aide-edition
Wiki Rédaction-dépêche https://linuxfr.org/wiki/redaction-depeche
Grammalecte : https://grammalecte.net
CNRTL : http://www.cnrtl.fr/definition
Accord du participe passé : http://www.langue-fr.net/Accord-du-participe-passe