Forum général.général Correction orthographique : vérification abusive

Posté par (page perso) . Licence CC by-sa
1
31
jan.
2014

bonjour,

avec firefox, sur linuxfr (uniquement), presque chaque mot que je tape dans le champs markitup (commentaire, journal etc) est souligné en rouge comme étant mal orthographié (alors que ce n'est pas le cas). Il s'agit sans doute d'un problème de réglage, mais pourtant dans les options > contenu, la langue indiquée est premier est bien le français. Je n'ai pas cela avec chrome. (Le rendu de prévisualisation s'affiche correctement sous firefox)

Savez-vous de quoi ça peut venir ? Serait-il également possible de désactiver la vérification d'orthographe sur linuxfr par rapport aux options du compte ?

Mon navigateur gère a priori correctement celle-ci (sur les autres sites je n'ai pas ce problème), aussi je préfèrerais l'utiliser.

  • # Problème de langue

    Posté par . Évalué à 3.

    Je pense que ça vient de ton Firefox.
    Dans "about:config", recherche la paramètre "spellchecker.dictionary"
    et vérifie que la valeur est "fr"

    Ça ne se produit que sur linuxfr, car les champs on l'attribut spellcheck=true.
    L'utilisation de cet attribut est rare sur le web.

    • [^] # Re: Problème de langue

      Posté par (page perso) . Évalué à 3.

      j'avais à cet attribut la valeur "fr-reform". J'ai remis à fr, c'est pareil.
      J'ai également mis services.sync.prefs.sync.spellchecker.dictionary à false pour voir, mais c'est pareil là aussi, ça souligne toujours.

      J'avais vu spellcheck=true dans le code de la page, mais je pensais que c'était un variable spécifique au site. Au pire des cas, un script greasemonkey devrait pouvoir supprimer cela.

      « I approve of any development that makes it more difficult for governments and criminals to monopolize the use of force. » Eric Raymond

      • [^] # Re: Problème de langue

        Posté par (page perso) . Évalué à 2.

        à noter que si je mets layout.spellcheckDefault à 0 au lieu de 1 par défaut, je n'ai plus le soulignement dans linuxfr, mais également plus non plus la correction orthographique (elle correcte), dans tous les autres sites.

        « I approve of any development that makes it more difficult for governments and criminals to monopolize the use of force. » Eric Raymond

      • [^] # Re: Problème de langue => dictionnaire ?

        Posté par . Évalué à 2. Dernière modification le 31/01/14 à 12:25.

        Hypothèse :
        Peut-être que Firefox ne peut simplement pas avoir accès au dictionnaire et fait de la merde. As-tu un myspell ou hunspell d'installer avec les dictionnaires fr ?

        • [^] # Re: Problème de langue => dictionnaire ?

          Posté par (page perso) . Évalué à 2.

          j'ai juste le dictionnaire français « dicollecte », rien d'autre.

          « I approve of any development that makes it more difficult for governments and criminals to monopolize the use of force. » Eric Raymond

      • [^] # Re: Problème de langue

        Posté par (page perso) . Évalué à 2.

        Bon, c'est réglé avec ça :

        // ==UserScript==
        // @name        linuxfr_disable_spellcheck
        // @namespace   http://linuxfr.org
        // @description linuxfr disable spellcheck
        // @include     https://linuxfr.org/*
        // @version     1
        // @grant       none
        // ==/UserScript==
        
        inputs = document.getElementsByTagName("textarea");
        for(i = 0; i < inputs.length; i++){
          inputs[i].setAttribute("spellcheck","false");
        }
        

        Le problème maintenant c'est que cela désactive même la vérification avec l'outil natif de firefox, et si je mets autre chose que false ça active le spellcheck buggé.

        j'ai essayé du coup de retirer tous les spellcheck avec ça :

        inputs = document.getElementsByTagName("textarea");
        for(i = 0; i < inputs.length; i++){
          inputs[i].removeAttribute("spellcheck");
        }
        

        ça retire bien l'attribut, mais ça affiche tout souligné en rouge, il doit y avoir autre chose qui provoque ces corrections orthographiques…

        « I approve of any development that makes it more difficult for governments and criminals to monopolize the use of force. » Eric Raymond

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.