Forum Linux.debian/ubuntu Accès internet ralentis lenny

Posté par .
Tags : aucun
1
6
sept.
2008
Bonjour,
Je viens de passer de Etch à Lenny.
Après quelques déboires (notamment une installation de kde4 infructueuse) tout est rentré dans l'ordre... sauf ma connexion internet (Livebox) qui rame à donf.
il semble que cela vienne du DNS.
voici mon /etc/resolv.conf
# Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)
# DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN
nameserver 192.168.1.1 # Livebox
nameserver 80.10.246.2 # DNS Orange primaire
nameserver 80.10.246.129 # DNS Orange secondaire



Il se trouve que Livebox a aussi fait une mise à jour de l'interface de sa box.

Si quelqu'un a une idée pour me rendre mon ADSL...
  • # DNS

    Posté par (page perso) . Évalué à 2.

    il semble que cela vienne du DNS.

    alors ajoute ceux d'opendns http://opendns.com

    208.67.222.222
    208.67.220.220
    • [^] # Re: DNS

      Posté par (page perso) . Évalué à 1.

      Oui, ça vient du DNS. Il y a des problèmes de DNS avec la dernière version du firmware de la livebox SAGEM, je l'ai expérimenté, ainsi que d'autres utilisateurs linux (voir un moteur de recherche).

      Pour ma part, je l'ai résolu en installant bind et en mettant donc 127.0.0.1 comme serveur dans mon resolv.conf, mais dans ce cas il ne faut pas oublier de mettre

      zone "wanadoo.fr" in {
      type forward;
      forwarders {
      193.252.19.3;
      193.252.19.4;
      };
      };

      dans le /etc/named.conf.local , sinon on ne peut pas envoyer de mail en passant par le SMTP d'orange.
  • # DHCP et/ou mauvais DNS

    Posté par . Évalué à 1.

    je ne suis pas sur que la livebox sache faire dhcp.

    active le dhcp de ta livebox
    met ta machine en dhcp

    regardes si ca va mieux.

    si oui, regarde le /etc/resolv.conf, et
    - soit tu conserve le reglage en dhcp,
    - soit tu copie le reglage pour en faire une ip fixe.

    (ps tu peux commenter la ligne 192.168.1.1 du resolv.conf pour tester rapidement et sans autre modif)
  • # DNS or not DNS ?

    Posté par (page perso) . Évalué à 2.

    Tout d'abord, ton resolv.conf est étrange. Soit tu mets le dns de la LiveBox, soit tu mets ceux du FAI, mais pas les deux.

    Pour vérifier que c'est un problème de dns, il te suffit de faire un wget http://tonsite.com/grosfichier.iso
    Si le téléchargement met longtemps à débuter mais qu'ensuite le débit est normal, c'est probablement un soucis de dns. Sinon... c'est autre chose.
    • [^] # Re: DNS or not DNS ?

      Posté par . Évalué à 2.

      Effectivement c'était pas très propre tout ça.
      Après essais/erreurs inspirées des conseils des uns et des autres, j'ai fini par trouver ceci: http://forum.ubuntu-fr.org/viewtopic.php?id=214145
      et notamment le post de Pierre Valiron qui préconise de désactiver ipv6 incompatible avec la nouvelle version de la Livebox.
      J'ai testé : ça marche impeccable. Et les SMTP aussi !

      Je garde l'idée de bind pour une autre fois...

      Merci à tous pour votre réactivité
      • [^] # Re: DNS or not DNS ?

        Posté par . Évalué à 2.

        Oui, c'est un problème de la livebox depuis des mois et qui n'est toujours pas réglé : quand tu fais une requête DNS, ta bécane commence par faire une requête IPv6 au cas où, et si elle se prend une erreur (dans la plupart des cas, puisqu'aujourd'hui l'IPv6 est encore très très peu répandu), elle tente en IPv4. Le problème, c'est que la livebox ne renvoit pas d'erreur et donc ton ordi attend un certain temps avant d'abandonner et de retomber sur IPv4. Ce qui fait que "c'est lent".

        Bon, la solution de désactiver l'IPv6 doit être temporaire et n'est pas idéale, parce que le jour où on commencera à switcher en IPv6, tous les abonnés livebox qui auront eu ce problème vont se mettre à gueuler parce que la moitié des sites ne marche plus : bravo FT, c'est grace à des erreurs comme ça que les gens vont se mettre à haïr une techno à cause de l'implémentation bidon d'un provider qui a fait le con.

        Ce message n'est pas du tout contre toi, c'est juste pour information pour les gens qui seraient intéressés par ce problème.
  • # meme probleme, opendns marche

    Posté par . Évalué à 1.

    salut,

    J'avais des temps de réponse énorme pour les noms de domaine avec ma livebox et une debian testing (lenny). J'ai suivi la procédure pour utiliser opendns sur le site concernant ubuntu.
    Ca marche très bien.

    A noter que je ne rencontre pas le problème sous Vista.

    Julien.

    Vous voulez pas la jouer soft ? Je suis pas contraignant... vous voulez la jouer hard ? On va la jouer hard

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.