Forum Linux.debian/ubuntu Configuration IP forcée au démarrage

Posté par .
Tags : aucun
1
14
fév.
2011
Bonjour @ tous,

Petite question svp :
Dans quel fichier et avec quelle syntaxe écrire pour que ma machine sous debian obtienne en forcing une bonne configuration IP à son démarrage ?

Voila ce que je devrais obtenir maisl'interface graphique de Zentyal n'accepte pas cette config et le template écrase tout au démarrage.

/etc/network/interfaces
auto lo eth0
iface lo inet loopback
iface eth0 inet static
address 17x.xxx.xxx.xxx
netmask 255.255.255.255
broadcast 17x.xxx.xxx.xxx
post-up route add 9x.xxx.xxx.254 dev eth0
post-up route add default gw 9x.xxx.xxx.254
post-down route del 9x.xxx.xxx.254 dev eth0
post-down route del default gw 9x.xxx.xxx.254

Ca a déjà fonctionné mais comme j'ai dù écraser ma machine, j'aimerai pouvoir refaire cette opération moi-même.

On m'a dit d'écrire ça dans /etc/rc.local mais je ne suis pas certain que ce soit la bonne syntaxe à écrire dans ce fichier.

Merci.
  • # pas mal mais...

    Posté par . Évalué à 3.

    une question me vient à l'esprit,
    quand tu ecris
    /etc/network/interfaces
    auto lo eth0
    iface lo inet loopback
    iface eth0 inet static
    address 17x.xxx.xxx.xxx
    netmask 255.255.255.255
    broadcast 17x.xxx.xxx.xxx
    post-up route add 9x.xxx.xxx.254 dev eth0
    post-up route add default gw 9x.xxx.xxx.254

    post-down route del 9x.xxx.xxx.254 dev eth0
    post-down route del default gw 9x.xxx.xxx.254


    1°) je ne sais pas si la ligne auto accepte de mettre 2 cartes sur la meme ligne, j'ai toujours vu marqué sur 2 lignes.

    2°) tu veux envoyer ta route par defaut à la machine 9x.xxx.xxx.254 seulement tu n'es meme pas dans son reseau (tu n'as pas d'IP en 9x.xxx.xxx.yyy), je ne vois pas trop comment la machine en face va te repondre.

    donc soit mes cours de reseau datent un peu, soit il te manque un alias ou une carte reseau dans cette configuration
    • [^] # Re: pas mal mais...

      Posté par (page perso) . Évalué à 2.

      1°) Oui, c'est permis. C'est même en exemple dans la page de man, en fait :-)
      2°) 9x.xxx.xxx.254 n'est pas dans son réseau, mais la ligne juste au dessus précise comment atteindre cette adresse: en envoyant sur eth0.

      Je ne pense pas que son problème vienne de la syntaxe de son /etc/network/interfaces, mais probablement de l'outil de config Zentyal (que je ne connais absolument pas), cette "interface graphique" à laquelle Bzh7000 fait référence.
      • [^] # Re: pas mal mais...

        Posté par . Évalué à 2.

        pour le 2°) je viens de tester chez moi
        dans une VM en bridge sur mon LAN OS debian squeeze
        iface eth0 inet static
        address 172.100.100.101
        netmask 255.255.255.255
        broadcast 172.100.100.255
        post-up route add 192.168.1.254 dev eth0
        post-up route add default gw 192.168.1.254
        post-down route del 192.168.1.254 dev eth0
        post-down route del default gw 192.168.1.254


        si la carte reseau se monte bien, et les routes s'installent bien, mais impossible de pinguer des machines sur internet (par leurs IPs)
        • [^] # Re: pas mal mais...

          Posté par . Évalué à 3.

          je viens de comprendre en lisant le guide OVH que Bzh7000 essaie de configurer une adresse IP dans une machine virtuelle, qui tournera ensuite sur un serveur dédié.

          cette precision aurait pu etre utile en premiere partie de la demande, car evidemment cela change pas mal de chose au niveau reseau (et cela explique pourquoi cela ne fonctionne pas sur une machine physique)
          • [^] # Re: pas mal mais...

            Posté par . Évalué à 1.

            Oups,

            Ben, oui, je suis dessus depuis si longtemps sans réponse que j'en ai oublié le détail.

            Pour synthétiser,
            Dans mon /etc/network/interfaces il est impossible de garder en mémoire la configuration expliquée dans le guide de l'hébergeur.


            Je modifie (en sudo) la passerelle en IPDUSERVEURDEDIE.254
            Mais cette config ne tient pas.
            Je me retrouve à chaque fois avec la passerelle identique à la carte/

            Il y a une astuce pour ''Forcer'' la bonne config de la passerelle au démarrage mais j'ignore comment.
            • [^] # Re: pas mal mais...

              Posté par . Évalué à 2.

              tu utilises quoi comme techno de virtualisation ?

              parce que de memoire, on travaille avec des br0 ou parfois des TAP sur la machine principale si on utilise KVM avec des cartes en bridge

              ensuite ca devient une configuration reseau classique.

              mais dans ton cas on dirait que c'est plutot un NAT caché.

              en gros tes machines sont en reseau entre elles,
              mais il faut envoyer les infos non locales à la machine HOTE qui l'enverra à la gateway...
              • [^] # Virtualisation

                Posté par . Évalué à 1.

                J'utilise ESXi.
                La carte vpn est en TAP.

                Tout ça fonctionne. J'ai l'impression que le ping ne trouve pas la sortie du serveur. Mauvaise route.

                Je suis presque certain que le problème vient du fait que Zentyal n'accepte pas mon ip de passerelle (qui est celle de mon Serveur dédié mais avec 254 à la fin.)

                Par defaut Zentyal remet en passerelle la même adresse que ma carte.
                • [^] # Re: Virtualisation

                  Posté par . Évalué à 2.

                  c'est peut-etre bien de faire confiance à une interface graphique,
                  mais parfois il faut aussi savoir faire à la main ;)

                  sur ta machine virtuelle, tu veux la mettre sur le meme reseau que la machine physique (fonctionnement en mode bridge) mais utiliser une des IPs failover fournies par OVH.

                  ca vaut peut-etre le coup de les mettre en NAT (sur un reseau interne)
                  de laisser la machine physique recevoir le trafic a destination de l'IP failover

                  puis de rerouter dans ton NAT vers "serveur virtuel A" ou "serveur virtuel B" suivant la destination demandée par le client
                  • [^] # Interface graphique

                    Posté par . Évalué à 1.

                    En fait, pour configurer tout ça, je ne m'appuie pas sur l'interface graphique,

                    J'y vais en ligne de commande sur un terminal.
                    Mais malgré tout...

                    Quand je modifie /etc/network/interfaces et que je redémarre la machine, tout revient comme avant. Il ne garde pas mes modifs à cause de ce fameux template.

                    il n'y a vraiment qu'en forçant la config par une sorte de script au démarrage que ça peut tenir.

                    Mais je doute que la syntaxe à mettre dans /etc/rc.local soit la même que dans /etc/network/interfaces

                    J'ai essaye mais sans succès
                    • [^] # Re: Interface graphique

                      Posté par . Évalué à 2.

                      la commande ifconfig peut prendre pas mal d'options.

                      sinon regarde si tu peux demander à zenityal de NE PAS configurer le reseau à ta place
                      • [^] # ifconfig

                        Posté par . Évalué à 1.

                        Alors il faudrait : ?
                        - Aller dans rc.local
                        ifconfig
                        auto lo eth0
                        iface lo inet loopback
                        iface eth0 inet static
                        address 17x.xxx.xxx.xxx
                        netmask 255.255.255.255
                        broadcast 17x.xxx.xxx.xxx
                        post-up route add 9x.xxx.xxx.254 dev eth0
                        post-up route add default gw 9x.xxx.xxx.254
                        post-down route del 9x.xxx.xxx.254 dev eth0
                        post-down route del default gw 9x.xxx.xxx.254

                        Et ainsi faire tenir cette configuration apres un redemarrage ?
                        Je vais essayer.
                        • [^] # Re: ifconfig

                          Posté par . Évalué à 1.

                          Et non...

                          Il y a deux solutions qui existent mais dont je ne connais que la théorie :

                          1) - Forcer au démarrage la bonne configuration IP
                          2) - Faire en sorte que Zentyal n'utilise pas son template au demarrage

                          Un tech de OVh l'a fait en décembre dernier et ça a fonctionné.
                          J'aimerai bien trouver cette technique.
                          • [^] # Re: ifconfig

                            Posté par . Évalué à 2.

                            visiblement tu sembles appliquer sans comprendre ce qui est proposé.

                            en l'occurence, ma reponse precedente disait de voir avec l'outil ifconfig auquel tu peux donner plein d'option pour configurer une carte reseau

                            si tu tapes man ifconfig ca t'en dira un peu plus
                            mais je peux deja te dire que tu peux mettre une IP, un masque, une route en une seule ligne.

                            ex :ifconfig eth0 192.168.1.10 netmask 255.255.255.0 gateway 192.168.1.254 broadcast 192.168.1.255

                            ensuite les outils pour manipuler les routes, tu les connais deja puisque tu les appelles deja quand tu fais le post-up ou le pre-down
                            • [^] # Re: ifconfig

                              Posté par . Évalué à 1.

                              Ah, je ne pretends pas le contraire.
                              Je decouvre Linux.
                              Zentyal est plutôt simple d'ailleurs pour débuter grâce à son interface graphique.
                              Configurer le réseau ne me pose pas de problème, même en ligne de commande.
                              C'est juste que Zentyal ne garde pas en mémoire mes paramètres.
                              • [^] # Pas de réponse...

                                Posté par . Évalué à 1.

                                Personne n'aurais la réponse pour garder en mémoire les bons paramètres sans que Zentyal ne les écrase au redémarrage ?
                  • [^] # Re: Virtualisation

                    Posté par . Évalué à 1.

                    Et Esxi permet de faire ça ?
                    Ou bien faut il créer une VM qui s'en charge ?
                    Il est vrai qu'en réseau local derrière un routage, ça, je sais faire.
                    • [^] # Re: Virtualisation

                      Posté par . Évalué à 2.

                      oui vmware doit savoir faire.

                      il doit suffir de lui dire que la carte reseau de cette machine est en NAT plutot qu'en bridge
                      • [^] # Forcer la config IP au démarrage

                        Posté par . Évalué à 1.

                        Salut,
                        J'ai regardé mais il faut une autre VM qui fasse le routage.

                        Je crois que je vais continuer de chercher la solution pour que ma Debian accepte de mémoriser mon adressage IP avec cette particularité décrite dans le guide ovh bridge client.

                        Ça a déjà marché... Y'a pas de raison.
                        • [^] # Re: Forcer la config IP au démarrage

                          Posté par . Évalué à 2.

                          J'ai regardé mais il faut une autre VM qui fasse le routage.

                          oui et non
                          le routage se fait sur ta machine physique
                          c'est elle qui recoit tout, et qui transmet à l'une ou l'autre des tes machines virtuelles.

                          Je crois que je vais continuer de chercher la solution pour que ma Debian accepte de mémoriser mon adressage IP avec cette particularité décrite dans le guide ovh bridge client.
                          ne plus utiliser zenityal pourrait etre une solution puisque ca semble etre lui qui ecrase la config que tu a faite.
                          • [^] # Quelques progres... Mais encore un détail.

                            Posté par . Évalué à 1.

                            On approche de la vérité :

                            /etc sudo nano rc.local

                            ifconfig eth0 178.xxx.yyy.zzz netmask 255.255.255.255 broadcast 178.xxx.yyy.zzz
                            route add 91.xxx.yyy.254 dev eth0
                            route add default gw 91.xxx.yyy.254

                            Voila une chose.
                            Maintenant le problème se réduit à mon accès VPN.

                            Lors de la connexion VPN :
                            J'obtiens 3 ou 4 ping OK sur mon serveur
                            (ping 192.168.160.1 -t (son adresse vpn))

                            En général, le ping est OK arrivé à cette ligne :
                            Successful ARP Flush on interface [14] {C

                            Puis...

                            TEST ROUTES: 1/1 succeeded len=1 ret=1 a=0 u/d=up

                            C:\WINDOWS\system32\route.exe ADD 178.xxx.yyy.0 MASK 255.255.255.0 192.168.160.1

                            ROUTE: CreateIpForwardEntry succeeded with wForwardMetric1=30 and dwForwardType=4

                            Route addition via IPAPI succeeded [adaptive]

                            Initialization Sequence Completed

                            La fenetre de connexion se ferme normalement
                            E là,t le ping ne répond plus alors que le vpn est monté.

                            J'arrive à pinger mon serveur pendant quelques secondes lors de l'ouverture du tunnel.
                            Il ne manque pas grand chose....
              • [^] # Virtualisation

                Posté par . Évalué à 1.

                J'utilise ESXi.
                La carte vpn est en TAP.

                Tout ça fonctionne. J'ai l'impression que le ping ne trouve pas la sortie du serveur. Mauvaise route.

                Je suis presque certain que le problème vient du fait que Zentyal n'accepte pas mon ip de passerelle (qui est celle de mon Serveur dédié mais avec 254 à la fin.)

                Par defaut Zentyal remet en passerelle la même adresse que ma carte.
    • [^] # Précision, le serveur est un Zentyal sous Esxi

      Posté par . Évalué à 1.

      En fait voila le lien du guide fourni par l'hebergeur.

      http://guide.ovh.com/BridgeClient

      Debian Like (Debian, Ubuntu...)
      ATTENTION : il ne faut en aucun cas utiliser l'IP principale de votre serveur comme gateway !! Vous devez en aucun cas utiliser : route add default gw dev eth0 sinon vous risquez la coupure de votre IP pour le serveur virtuel.

      /etc/network/interfaces
      auto lo eth0
      iface lo inet loopback
      iface eth0 inet static
      address IP.FAIL.OVER
      netmask 255.255.255.255
      broadcast IP.FAIL.OVER
      post-up route add IP.DE.VOTREDEDIE.254 dev eth0
      post-up route add default gw IP.DE.VOTREDEDIE.254
      post-down route del IP.DE.VOTREDEDIE.254 dev eth0
      post-down route del default gw IP.DE.VOTREDEDIE.254


      /etc/resolv.conf
      nameserver 213.186.33.99

      **************************************************

      Pour le moment, ça marche à moitié.
      Voila ce que j'ai :

      Serveur VPN et Samba fonctionnent :
      - Accède à Internet
      - Accessible depuis l'exterieur (https et VPN)

      IP du serveur : 178.33.uvw.xyz
      MASK : 255.255.255.255
      Passerelle : 178.33.uvw.xyz
      (impossible de mettre 91.mno.pqr.254 en passerelle)

      IP du reseau VPN : 192.168.160.0/24
      IP du serveur VPN : 192.168.160.1

      IP du PC client1 : 192.168.160.2 Obtenue par le serveur
      IP du PC client2 : 192.168.160.3 Obtenue par le serveur
      IP du PC client3 : 192.168.160.4 Obtenue par le serveur

      Résultat : VPN OK
      : Pas de ping 192.168.190.1 depuis les PC clients
      : Le serveur non vu des PC clients
      : Pas d'accès aux dossiers partagés du serveur

      On m'a dit qu'il fallait forcer les bons paramètres dans rc.local
      Ca a déjà été bien configuré mais comment ?
      C'est la la question...
      Quoi écrire et où ?

      Merci
  • # Comparaison

    Posté par . Évalué à 1.

    Sur deux installations en réseau local tout marche à merveille (firewall configuré bien entendu).

    Je pense qu'il y a une histoire de route qui ne se monte pas car la passerelle est identique à l'adresse de la carte eth0.
    En réussissant à forcer l'adresse de passerelle 91.xxx.xxx.254 ça devrait aller.

    De plus, il faut que cette configuration se force au redémarrage de la VM car Zentyal utilise un templat qui écrase tout ce qui ne lui plait pas au démarrage.
    Et une passerelle qui n'est pas sur le même réseau, ça ne lui plait pas.

    Ou alors, il faudrait modifier le templat
    Mais là, je m'y risque encore moins. ;-)
  • # Faute de frappe

    Posté par . Évalué à 1.

    Il faut lire :

    Résultat : VPN OK
    : Pas de ping 192.168.160.1 depuis les PC clients

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.