Forum Linux.debian/ubuntu Connexion limitée au VPN

Posté par . Licence CC by-sa
Tags : aucun
1
22
mai
2016

Bonjour à tous.

J'utilise une connexion VPN via openvpn, tout fonctionne très bien.

En fait j'aimerais que la connexion filaire ou wifi ne soit valide que lorsque je suis connecté à ce VPN.

Sur KDE il y a cette option dans le gestionnaire de réseau, mais pas dans le gestionnaire gnome (l'environnement que j'utilise )

Concrètement, il faudrait que dès que je me connecte sur ma session, la connexion au VPN s'effectue puis en cas de coupure à celui-ci il la connexion filaire ou wifi soit coupée.

Je galère vraiment pour trouver les infos sur linux, mais j'ai vraiment envie d'y arriver.

Merci d'avance et bonne journée ou soirée.

  • # Iptables

    Posté par . Évalué à 1.

    Creuse du côté d'Iptables tu devrais trouver ton bonheur. Par exemple ce topic sur le forum de Freedom-IP ;)

  • # tu peux pas

    Posté par . Évalué à 4.

    Concrètement, il faudrait que dès que je me connecte sur ma session, la connexion au VPN s'effectue puis en cas de coupure à celui-ci il la connexion filaire ou wifi soit coupée.

    ben oui, c'est idiot, mais pour que le VPN se lance, il faut que ta machine soit connectée au reseau (en filaire ou en wifi) et à internet.
    et une fois le VPN ouvert, tu fais passer tout le trafic dedans..

    ou alors en effet, tu ne veux pas que le PC se connecte à autre chose que le serveur VPN tant que celui-ci n'est pas monté.
    il faut donc jouer avec les scripts pre-up, post-up, pre-down, post-down pour appliquer une regle iptables qui bloque tout 'sauf le DNS et le flux vers le VPN'
    puis debloque les flux uniquement vers la carte VPN quand celui-ci est monté.

  • # Dur dur..

    Posté par . Évalué à 1.

    Merci pour vos réponse, mais j'avoue que c'est un peu du chinois pour moi :( J'étais encore sur Windows le mois passé et il me suffisais de cliquer et s'était fait ^

    • [^] # Re: Dur dur..

      Posté par . Évalué à 3.

      J'étais encore sur Windows le mois passé et il me suffisais de cliquer et s'était fait ^

      bienvenu sur Linux, c'est justement la difference entre windows et linux

      windows, tu cliques ca fait des trucs (sans que tu saches quoi, pourquoi, comment)
      quand c'est un truc que tu souhaites, c'est bien, quand c'est une truc non voulu c'est plus problematique.

      linux, tu comprends ce qu'il se passe, puisque c'est toi qui a coché la case, ecrit le script pour faire des choses que TU as demandé.

      sinon pour repondre à quelqu'un, il faut cliquer sur "repondre" en bas de son post, et non sur "ecrire un commentaire" qui repond à la question de depart (ton post dans le cas present)

  • # Que de problème.

    Posté par . Évalué à 1.

    Et en plus, impossible d'éviter le "dns leaks", je suis entrain de devenir maboule. J'ai aucune envie de revenir sur Windows, tout fonctionne très bien sur linux, sauf ce satané VPN.

    • [^] # Re: Que de problème.

      Posté par . Évalué à 2.

      c'est quoi que tu appelles "DNS leaks" ?

      • [^] # Re: Que de problème.

        Posté par . Évalué à 3.

        si c'est le fait de laisser ouvert les flux vers le DNS avant que le VPN soit ouvert,
        c'est parce que je partais du principe que tu montais ton VPN vers un serveur VPN avec un nom de domaine genre levpn.delaboiteàvpn.tld qui pointerait eventuellement vers plusieurs IPs.

        mais si tu te connectes directement en IPs sur les serveurs VPNs,
        alors il faudra juste faire les requetes DNS via le VPN, une fois que celui-ci est monté mais en utilisant les DNS du fournisseur VPN et non ceux de ton FAI.

        apres la bonne question à se poser c'est "pourquoi as-tu besoin d'un VPN ?" qui t'oblige à couper la connexion reseau local quand le VPN est eteint ?
        cela veut aussi dire que de chez toi, tu n'accedes meme pas aux autres ordis de la maison, à la box, au nas, …

        • [^] # Re: Que de problème.

          Posté par . Évalué à 1.

          Salut,

          Pas le réseaux local, juste la connexion internet. C'est juste pour une question de principe, d'avoir un minimum d'anonymat/vie privée.

          Pour le leak, je parles de ceci https://www.dnsleaktest.com/ qui m'affiche le nom de mon FAI.

          • [^] # Re: Que de problème.

            Posté par . Évalué à 3. Dernière modification le 23/05/16 à 13:35.

            ca c'est parce que ton VPN ne prend pas tous le trafic par defaut, sinon ce serait l'IP du fournisseur VPN qui devrait s'afficher.

            donc on en revient au probleme de depart,
            - as-tu besoin du DNS pour ouvrir le VPN ?
            si la reponse est NON, alors :
            - vires le fichier /etc/resolv.conf au demarrage de la machine (enfin juste apres avoir recu les infos du DHCP de ta box) => tu as alors internet SANS DNS (juste en IP),
            - tu montes le VPN
            - tu demandes à ce que TOUT le traffic, sauf celui vers le serveur VPN, passe DANS le VPN.
            - et tu configures des DNS en dehors de ceux de ton FAI.

            • [^] # Re: Que de problème.

              Posté par . Évalué à 1.

              Au risque de passer pour le con du village, je comprend absolument rien a comment faire. J'ai trouvé des script, des exemple qui ne m'on amené à rien et croyez moi avant d'écrire sur un forum, je cherche longtemps.

              Je crois que j'ai plus qu'une solution je crois, retourner sur Windows 10 pour avoir un vpn qui fonctionne à 100% comme il faut ou rester sur Debian mais sans ça.

              Dans les deux cas, ça ne correspond pas à mon "éthique", je crois que je vais vendre le PC et aller jardiner, plein de désespoir T_T'

    • [^] # Re: Que de problème.

      Posté par . Évalué à 2.

      Pour le DNS leak, c’est probablement parce que tes DNS sont configurés pour interroger ta box, qui n’est pas impactée par le VPN. Utilise des DNS externes à la place (ceux de google, ou ceux de ton fournisseur VPN s’il en fournit), et ils devraient être redirigés vers le VPN.

      • [^] # Re: Que de problème.

        Posté par . Évalué à 1.

        Même pas, je les ais tous entré manuellement avec des ip de openDNS et rien y fait.

        • [^] # Re: Que de problème.

          Posté par . Évalué à 1.

          Pour régler ce problème il faut modifier les DNS de la connexion physique une fois la connexion VPN établie.

          Par exemple, si tu as 8.8.8.8 et 8.8.4.4 sur ta connexion physique, une fois que la connexion VPN est établie tu les modifies en 1.1.1.1 et 1.1.1.1 par exemple (des adresses IP bidons histoire que ça pointe nul part).

        • [^] # Re: Que de problème.

          Posté par . Évalué à 2.

          alors ca veut dire qu'une fois ton VPN ouvert tes flux DNS continuent de sortir par la connexion normale.

          il faut donc faire des regles de ROUTAGE pour lui dire de TOUT faire PASSER DANS LE VPN (sauf le flux vers le serveur VPN)

  • # Quelques pistes

    Posté par . Évalué à 2.

    N’ayant ni OpenVPN, ni NetworkManager sous la main je ne peux pas te donner de situation toute prête, mais grosso modo, la marge à suivre est :

    1. Trouver comment déconnecter le réseau à partir d’un script avec networkmanager. Cf la doc: ça devrait être quelque chose comme nmcli device disconnect.

    2. Lancer ce script lors de la déconnexion du VPN: tu as une option qui fait ça dans la configuration du client OpenVPN, down-pre, qui devrait du coup donner quelque chose du genre down-pre nmcli device disconnect.

  • # Abandon

    Posté par . Évalué à 1.

    Bonjour à tous et merci d'avoir essayé de m'aider. Mais toute ces pistes reste du chinois pour moi…

    J'ai juste pas le temps de me former sur iptables, script et compagnie… Donc en gros ---> Windows -_-'

    Mais merci d'avoir pris le temps de me répondre.

    Bonne journée !

    • [^] # Re: Abandon

      Posté par . Évalué à 2.

      en gros non pas windows, mais windows avec le logiciel du fournisseur de VPN qui va tout faire à ta place.

      • [^] # Re: Abandon

        Posté par . Évalué à 1.

        Bah oui, on est pas tous informaticien ou amateur… Moi je n'y arrive simplement pas.

        • [^] # Re: Abandon

          Posté par . Évalué à 2.

          ben faut demander au fournisseur du VPN de te fournir son logiciel en version linux ;)

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.