Forum Linux.debian/ubuntu Debian 6 et les ventilateurs des ordinateurs portables

Posté par (page perso) .
Tags : aucun
2
12
août
2011

Bonjour à tous, Lors de la sortie de Debian 6.0 (en février dernier) je me suis précipité pour l'installer sur mon ordinateur portable (un Dell Studio acheté deux ans plus tôt environ).

L'installation s'était bien déroulée et tout semblait parfaitement fonctionner ... sauf que les ventilateurs tournaient en permanence. Étonnant non ? Ubuntu ne me posait pas ce problème. J'ai fait quelques recherche via Google et à ma grande surprise ce problème se pose depuis un moment déjà avec Debian sur certains ordinateurs portables (il suffit de taper 'Debian ventilateur' dans Google pour constater l'ampleur du phénomène).

Ma question est donc : Quelqu'un connait il une solution à cette anomalie ?
Et encore merci (pour le poisson).

Anciens sujets du forum à toutes fins utiles :
http://linuxfr.org/forums/linuxdebianubuntu/posts/salet%C3%A9-de-ventilo
http://linuxfr.org/forums/linuxdebianubuntu/posts/capteurs-ventilateurs-debian-sid

  • # laptop-mode et autres joyeuseté ?

    Posté par . Évalué à 1.

    tu as pensé à installer et activer les scripts et outils generalement appeler laptop-mode ?

  • # Paquets manquants ?

    Posté par (page perso) . Évalué à 1.

    Salut,

    Je n'ai pas de problème avec ma Debian Testing sur un Dell Latitude. C'est peut-être tout simplement un problème de paquets manquants ?

    Quels sont les paquets acpi* que tu as installés ?
    La fréquence de ton processeur diminue-t-elle avec la charge ? (je crois que pour ça il faut installer le paquet cpufrequtils)

    BBK

    • [^] # Re: Paquets manquants ?

      Posté par (page perso) . Évalué à 1.

      Quels sont les paquets acpi* que tu as installés ?

      J'avais fait l'installation par défaut. (sans rien ajouter)

      • [^] # Re: Paquets manquants ?

        Posté par (page perso) . Évalué à 0.

        Dans ce cas là je te conseille d'ajouter les paquets conseillés pour les laptops :
        Wiki Debian (en bas de la page)
        Tu aurais pu installer ces paquets en cochant "ordinateur portable" à l'installation.

        A mon avis il y a de bonnes chance que cpufrequtils règle ton problème.

        BBK

        • [^] # Re: Paquets manquants ?

          Posté par (page perso) . Évalué à 1.

          Je pense que je l'option s'était sélectionné automatiquement (ou que je l'avais coché).

          • [^] # Re: Paquets manquants ?

            Posté par (page perso) . Évalué à 1.

            • [^] # Re: Paquets manquants ?

              Posté par (page perso) . Évalué à 1.

              Ok, et bien il serait quand même bien de vérifier que cpufrequtils est installé (dans ton gestionnaire de paquet).

              Et ensuite on pourra commencer à enquêter : pour la surveiller la fréquence du processeur, il y a un truc en ligne de commande (mais je ne me souviens plus, peut-être cpufreq-info, donne toujours le résultat pour voir). Sinon il y a l'applet Gnome (clic droit sur la barre en haut, ajouter, moniteur de fréquence du processeur ou quelque chose qui ressemble)

              • [^] # Re: Paquets manquants ?

                Posté par . Évalué à 1.

                je cherchais le nom de ces outils quand j'ai repondu pour le laptop-mode plus haut, mais j'avais un trou de memoire.

              • [^] # Re: Paquets manquants ?

                Posté par (page perso) . Évalué à 1.

                Par la suite j'ai réinstallé Ubuntu (aucun problème). Je pose la question pour ... tenter de savoir si la situation s'est améliorée ou si il existe une solution. Et dans ce cas je réinstalle Debian ...

                • [^] # Re: Paquets manquants ?

                  Posté par (page perso) . Évalué à 0.

                  En gros Ubuntu est basé sur Debian avec quelques modifications d'organisation et de configuration, destinées à faciliter la vie des néophytes. Donc si ça marche avec Ubuntu, ça devrait marcher avec Debian, mais sous Debian il est probable que ça nécessite un peu de configuration.

  • # cpufreq ou GPU

    Posté par (page perso) . Évalué à 2.

    Normalement, pour régler ce soucis, j'activais la variation de fréquence du processeur (module acpi_cpufreq) à la demande (ondemand). Mais depuis Debian 6 squeeze, c'est fait par défaut.

    Si tu as une carte vidéo ATI, certains forums semblent pointer du doigt le driver vidéo et disent que l'installation du driver ATI propriétaire règle le problème. Je ne sais pas si Ubuntu utilise par défaut le driver Xorg propriétaire ou radeon, mais dans le second cas, peut-être que la version présente dans Ubuntu est plus récente et règle le problème.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.