Forum Linux.debian/ubuntu DEBIAN: Probleme montage cle USB (qui marche sous Ubuntu)

Posté par .
Tags : aucun
0
30
mai
2006
Bonjour,

J'ai un soucis avec une cle USB 512Mo sous Debian. Celle-ci est reconnue sous Ubuntu par gnome-volume-manager et elle marche lorsque je la monte à la main.

Voici le contenu de /proc/partition avant l'insertion de la cle usb

major minor #blocks name

3 0 120060864 hda
3 1 30724281 hda1
3 2 30764475 hda2
3 3 58564957 hda3
3 64 58615704 hdb
3 65 2048256 hdb1
3 66 1951897 hdb2
3 67 1 hdb3
3 68 6666975 hdb4
3 69 96358 hdb5
3 70 979933 hdb6
3 71 1951866 hdb7
3 72 5855661 hdb8
3 73 39062016 hdb9


Voici le contenu de /proc/partition apres l'insertion de la cle usb

major minor #blocks name

3 0 120060864 hda
3 1 30724281 hda1
3 2 30764475 hda2
3 3 58564957 hda3
3 64 58615704 hdb
3 65 2048256 hdb1
3 66 1951897 hdb2
3 67 1 hdb3
3 68 6666975 hdb4
3 69 96358 hdb5
3 70 979933 hdb6
3 71 1951866 hdb7
3 72 5855661 hdb8
3 73 39062016 hdb9
8 0 500736 sda
8 1 2033513652 sda1

Sachant que la cle est en fat32

Je tape: mount -t vfat /dev/sda1 /mnt/cle

Et j'ai le retour classique

mount: wrong fs type, bad option, bad superblock on /dev/sda1,
missing codepage or other error
In some cases useful info is found in syslog - try
dmesg | tail or so

Voici les logs systemes

usb 4-6: new high speed USB device using ehci_hcd and address 8
scsi6 : SCSI emulation for USB Mass Storage devices
usb-storage: device found at 8
usb-storage: waiting for device to settle before scanning
Vendor: Model: USB Flash Memory Rev: 1.04
Type: Direct-Access ANSI SCSI revision: 00
SCSI device sda: 1001472 512-byte hdwr sectors (513 MB)
sda: Write Protect is off
sda: Mode Sense: 23 00 00 00
sda: assuming drive cache: write through
SCSI device sda: 1001472 512-byte hdwr sectors (513 MB)
sda: Write Protect is off
sda: Mode Sense: 23 00 00 00
sda: assuming drive cache: write through
sda: [CUMANA/ADFS] sda1<5>sd 6:0:0:0: Attached scsi removable disk sda
usb-storage: device scan complete
printk: 14 messages suppressed.
Buffer I/O error on device sda1, logical block 508378384
Buffer I/O error on device sda1, logical block 508378384
Buffer I/O error on device sda1, logical block 508378412
Buffer I/O error on device sda1, logical block 508378412
Buffer I/O error on device sda1, logical block 508378412
Buffer I/O error on device sda1, logical block 508378412
Buffer I/O error on device sda1, logical block 508378412
Buffer I/O error on device sda1, logical block 508378412
Buffer I/O error on device sda1, logical block 508378405
Buffer I/O error on device sda1, logical block 508378405
FAT: invalid media value (0xb9)
VFS: Can't find a valid FAT filesystem on dev sda1.
FAT: invalid media value (0xb9)
VFS: Can't find a valid FAT filesystem on dev sda1.
FAT: invalid media value (0xb9)
VFS: Can't find a valid FAT filesystem on dev sda1.
FAT: invalid media value (0xb9)
VFS: Can't find a valid FAT filesystem on dev sda1.

Merci de m'aider
  • # Le commentaire enflammé

    Posté par (page perso) . Évalué à  0 .

    Attention !!!!!


    Faut pas ajouter une mention comme "(qui marche sous Ubuntu)" en parlant de debian, sinon, tu vas attirer les foudres de debianeux de linuxfr ( note que je les aimes beaucoup nos debianeux !)
    • [^] # Re: Le commentaire enflammé

      Posté par . Évalué à  1 .

      J'avais peur que le post ne soit meme pas lu car encore un sujet sur les clés USB.

      Je voulais juste dire que j'avais vérifié la même cle sur le même ordinateur et que j'avais reussi à la monter.

      Moi j'utilise Debian
  • # FAT32 ?

    Posté par . Évalué à  3 .

    es-tu certain qu'elle est en fat32 ?

    parce que visiblement linux ne trouve rien à ce sujet sur la clé.

    FAT: invalid media value (0xb9)
    VFS: Can't find a valid FAT filesystem on dev sda1.


    par contre la ligne suivante

    sda: [CUMANA/ADFS] sda1<5>sd 6:0:0:0: Attached scsi removable disk sda


    semble indiquer
    soit que c'est du ADFS
    soit que c'est SDA5 qui est la partition que tu cherches.

    à essayer donc.
    • [^] # Resolution du probleme

      Posté par . Évalué à  2 .

      Voici l'explication du probleme

      "le noyau detecte a tort que c'est une partition de type CUMANA/ADFS car ce type est teste avant le type msdos."

      Alors j'ai formaté la clé en fat32

      Voici la procédure que j'ai faite:
      # dd if=/dev/zero of=/dev/sda1
      # fdisk /dev/sda
      # mkdosfs /dev/sda1

      le lien où j'ai eu l'info:
      http://lists.bxlug.be/pipermail/devel/2006-March/003074.html

      Merci pour votre aide

      Bien sûr que j'adore debian.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.