Forum Linux.debian/ubuntu Difficultés avec wpa_supplicant

Posté par .
Tags : aucun
1
8
jan.
2009
Bonjour,

Après avoir parcouru google et divers sites je suis parvenu à faire fonctionner ma carte wifi.
Cependant le réseau se connecte sur un point d'accès neuf-wifi et non sur ma freebox que j'ai essayé de configurer.

Voici mes fichiers

/etc/network/interfaces

allow-hotplug ath0
iface ath0 inet dhcp
wpa-driver wext
wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf


/etc/wpa_supplicant

ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev


network={
key_mgmt=NONE
}

network={
ssid="ssidfreebox"
proto=WPA
key_mgmt=WPA-AES
psk="clefreebox"
id_str="freebox"
}


Ai-je oublié quelque chose ?
Merci d'avance
  • # Correction

    Posté par . Évalué à 1.

    J'ai recopié une mauvaise version de mes fichiers

    Voici une version correcte :

    allow-hotplug ath0
    iface ath0 inet manual
    wpa-driver wext
    wpa-roam /etc/wpa_supplicant/wpa_supplicant.conf



    ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=netdev


    network={
    key_mgmt=NONE
    }

    network={
    ssid="ssidfreebox"
    proto=WPA
    key_mgmt=WPA
    group=CCMP
    psk="clefreebox"
    id_str="freebox"
    }


    Lorsque je teste avec : #ifup ath0
    J'obtiens les erreurs suivantes :


    wpa_supplicant: /sbin/wpa_supplicant daemon failed to start
    run-parts: /etc/network/if-pre-up.d/wpasupplicant exited with return code 1
    Failed to connect to wpa_supplicant - wpa_ctrl_open: Not a directory
    wpa_supplicant: /sbin/wpa_cli daemon failed to start
    run-parts: /etc/network/if-up.d/wpasupplicant exited with return code 1


    voila
    • [^] # Re: Correction

      Posté par . Évalué à 1.

      - le second fichier est /etc/wpa_supplicant ?
      Car dans ton /etc/network/interfaces tu dis que le fichier de conf est /etc/wpa_supplicant/wpa_supplicant.conf

      - de plus quels sont les droits sur ce fichier ? (il me semble, qu'il faut faire un chmod 600 dessus).
      Enfin, je ne suis certain de rien, donc désolé si je me plante.
  • # Qu'est ce qui permet de dire...

    Posté par . Évalué à 1.

    que ta carte wifi fonctionne ?
    >Ai-je oublié quelque chose ?
    donner des infos peut etre...... ;-)

    Quelle version de wpa_supplicant uitlise tu ? sous quel distrib ? quel kernel ?
    as tu essayer WPA1 (TKIP) avec key_mgmt=WPA-PSK ) ? (ce n'est pas tout les drivers de cartes qui supporte le AES)

    que donne le resultat des commandes :
    dmseg (juste apres la tentative de demarrage)
    lsmod
    iwconfig
    iwlist scan

    ta carte wifi est de quel type ? elle est recente ?
    • [^] # Re: Qu'est ce qui permet de dire...

      Posté par . Évalué à 1.

      Bonjour,

      JMerci beaucoup j'ai pu progresser depuis hier!

      Ma config
      Debian Lenny kernel à jour (2.6.26-1 i686) sur un thinkpad T30
      Carte PCMCIA assez récente : TP-LINK TL-WN610G (Chipset Atheros)

      J'ai modifié mon fichier /etc/wpa_supplicant/wpa_supplicant.conf

      Voici à quoi il ressemble :


      ctrl_interface=DIR=/var/run/wpa_supplicant GROUP=0

      ap_scan=2

      network={
      ssid="ssidfreebox"
      proto=WPA
      key_mgmt=WPA-PSK
      group=CCMP
      pairwise=CCMP
      psk="clefreebox"
      id_str="freebox"
      }

      network={
      key_mgmt=NONE
      }


      iwconfig me donne

      lo no wireless extensions.

      eth0 no wireless extensions.

      irda0 no wireless extensions.

      wifi0 no wireless extensions.

      ath0 IEEE 802.11g ESSID:"ssidfreebox" Nickname:""
      Mode:Managed Frequency:2.412 GHz Access Point: D2:8C:80:93:0E:F8
      Bit Rate:48 Mb/s Tx-Power:18 dBm Sensitivity=1/1
      Retry:off RTS thr:off Fragment thr:off
      Encryption key: XXXX-XXXX-XXXX-XXXX-XXXX-XXXX-XXXX-XXXX Security mode:restricted
      Power Management:off
      Link Quality=73/70 Signal level=-23 dBm Noise level=-96 dBm
      Rx invalid nwid:1456 Rx invalid crypt:0 Rx invalid frag:0
      Tx excessive retries:0 Invalid misc:0 Missed beacon:0


      si j'essaie avec le programme wpa_supplicant
      wpa_supplicant -D wext -i ath0 -c /etc/wpa_supplicant/wpa_supplicant.conf
      Associated with d2:8c:80:93:0e:f8
      CTRL-EVENT-DISCONNECTED - Disconnect event - remove keys
      Associated with d2:8c:80:93:0e:f8
      WPA: Key negotiation completed with d2:8c:80:93:0e:f8 [PTK=CCMP GTK=CCMP]
      CTRL-EVENT-CONNECTED - Connection to d2:8c:80:93:0e:f8 completed (auth) [id=0 id_str=freebox]
      CTRL-EVENT-SCAN-RESULTS


      Et ça ne fonctionne pas ... Ma freebox est bien en WPA AES et j'ai la bonne clé.

      Je sais que ma carte fonctionne car avant de retoucher à ma config j'arrivais à me connecter sur un AP ouvert Neuf-wifi.

      Merci de votre aide.
      • [^] # Re: Qu'est ce qui permet de dire...

        Posté par . Évalué à 1.

        Bon je n'y comprends plus grand chose ...
        ça fonctionne maintenant! et tant mieux...
        J'ai rebooté le pc pour voir si ça marchait "vraiment". Il a fallu quand même que je lance dhclient en console pour que ça fonctionne.
        J'ai pensé que c'était du au fait que j'ai précisé "manual" dans la configuration du fichier /etc/interfaces. En roaming l'option "dhcp" ne marche pas (j'ai essayé ça me donne une erreur). Que faire pour éviter d'avoir à lancer dhclient à chaque boot ? Il y a une méthode propre ?
      • [^] # Re: Qu'est ce qui permet de dire...

        Posté par . Évalué à 1.

        sur la freebox tu ne pas essayer en selectionnant un chiffrage (WPA TKIP) simple et non pas (WPA TKIP+AES) qui semble moins compatible pour voir?

        Peut tu refaire iwconfig apres avoir fait wpa_supplicant -D wext -i ath0 -c /etc/wpa_supplicant/wpa_supplicant.conf
      • [^] # Re: Qu'est ce qui permet de dire...

        Posté par (page perso) . Évalué à 3.

        Celà fonctionne mieux car tu as inversé les deux blocs network : key_mgmt=NONE attrape tous les réseaux ouverts (donc neuf-wifi). L'ordre doit avoir une importance. Si tu veux quelquechose de plus explicite, tu peux utiliser les priorités :
        network={
        	ssid="your_case_sensitive_ssid"
               id_str="home"
        	psk="your_passphrase"
        	priority=5
        }
        
        # Connect to any public open access point  
        network={
        	key_mgmt=NONE
        	priority=0
        }
        

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.