Forum Linux.debian/ubuntu /etc/postfix/transport qui ne veut rien entendre...

Posté par (page perso) .
Tags : aucun
1
16
déc.
2004
J'ai une Debian Woody avec un postfix de base de la distrib mais j'ai un souci quand j'envoie un mail à certaines personnes dont le MTA est du genre "geek unfriendly". Vu que je suis en *.dyndns.org et que je n'ai pas mis en place le reverse dns, certains domaines (club-internet, ifrance...) refusent mes e-mails.
Une solution avec postfix est de paramétrer le fichier /etc/postfix/transport en mettant des lignes de la sorte :

club-internet.fr smtp:smtp.de.mon.fai

et de lancer la commande

postmap /etc/postfix/transport && /etc/init.d/postfix reload


ainsi postfix utilisera le smtp.de.mon.fai pour relayer ces e-mails.

bon pour des raisons qui m'échappent, ca n'a pas l'air de marcher tout le temps...

Mais je me pose une autre question. Si j'achete un nom de domaine en .org par exemple, que je positionne le reverse dns sur ce nom de domaine, les mechants-fai-qui-se-protegent-un-peu-brutalement-du-spam accepteront-ils mes e-mails ? ne serait-ce une meilleure technique plus efficace et plus simple ?
  • # Si seulement...

    Posté par . Évalué à 2.

    Il y a aussi des méchants-FAI-qui-refusent-les-mails-qui-viennent-de-l'adresse-IP-d'un-client-qui- est-dans-un-pool-d'IP-attribué-a-l'ADSL... et là, tu es obligé de passer par le SMTP de ton FAI (ceci dit, il n'y en a pas beaucoup-beaucoup, mais ça existe).
    • [^] # Re: Si seulement...

      Posté par (page perso) . Évalué à 1.

      club-internet et noos en feraient ils partie de ces fameux "méchants-FAI-qui-refusent-les-mails-qui-viennent-de-l'adresse-IP-d'un-client-qui- est-dans-un-pool-d'IP-attribué-a-l'ADSL" ?

      parceque meme avec un domaine en .com, un reverse dns qui va bien.
      le serveur mail qui envoie les mails dans les mx du domaine, etc
      et bien les mails club-internet et noos ne passaient pas.

      ( ca expliquerait donc pas mal de choses )
  • # hoù la la

    Posté par (page perso) . Évalué à 2.

    Bonjour,

    Quand tu envoies tes méls depuis ton poste, tu utilises le serveur smtp de ton provider ou le service smtp de ta machine via postfix. Tu ne peux pas relayer tes méls chez un autre provider que celui qui te fournit un accés ( mise à part en faisant du Pop before smtp ) ou alors leur MTA est un relais de spam. Dans postfix, tu peux paramétrer relayhost pour définir le serveur smtp qui relaiera et le relay-domains pour les domaines à relayer. Si tu es derrière un routeur, il se peut que le serveur smtp de ton provider ne te reconnaisse pas. Je ne vois pas ce que vient faire le reverse DNS ici surtout si tu passes par une adresse dynamique. Paramétre correctement ton postfix et cà doit fonctionner.
  • # relayhost

    Posté par . Évalué à 3.

    J'essaierai ça d'abord dans /etc/postfix/transport:

    club-internet.fr smtp:smtp.de.mon.fai
    .club-internet.fr smtp:smtp.de.mon.fai

    et man transport pour les options de main.cf qui influent là dessus.

    Mais la meilleure solution est AMHA de passer autant que possible
    par le relais de ton fai

    postconf -e 'relayhost = smtp.de.mon.fai'
    postfix reload

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.