Forum Linux.debian/ubuntu Extinction du PC

Posté par (page perso) . Licence CC by-sa
Tags : aucun
3
5
nov.
2014

Bonjour,

Depuis que je suis passé à systemd sur ma debian, j'ai l'extinction du PC qui se fait immédiatement contre 1 ou 2 secondes avant. J'aimerais donc savoir si c'est normal ou s'il y a un problème. Comment je peux savoir si l'extinction s'est faite comme il faut ?

J'ai un autre PC passé lui aussi sur systemd qui a un autre problème à l'extinction : tout ce qui est graphique est bien fermé mais je me retrouve sur un terminal et l'ordi ne s'éteint pas. Et aucun message de type "shutdown" d'un quelconque service.

Merci.

  • # Regarder les logs

    Posté par . Évalué à 2.

    Bonjour.

    J'ai l'extinction du PC qui se fait immédiatement contre 1 ou 2 secondes avant. J'aimerais donc savoir si c'est normal ou s'il y a un problème. Comme je peux savoir si l'extinction s'est faite comme il faut ?

    En regardant les logs avec l'outil journalctl -b

    La commande journalctl -b 0 fournit tous les logs de l'utilisation actuelle de l'ordinateur (du dernier démarrage jusqu'à maintenant).
    La commande journalctl -b -1 fournit tous les logs de l'avant-dernière utilisation de l'ordinateur (du démarrage jusqu'à l'arrêt).
    La commande journalctl -b -2 fournit tous les logs de l'avant-avant-dernière utilisation de l'ordinateur (du démarrage jusqu'à l'arrêt)
    La commande journalctl -b -3 fournit tous les logs de l'avant-avant-avant-dernière … Bref, je pense que tu as compris :o)

    Jette également un coup d'œil sur la commande journalctl --list-boots

    Plus d'infos sur ce lien (voir également la page de manuel).

    • [^] # Re: Regarder les logs

      Posté par (page perso) . Évalué à 2.

      Merci mais je n'ai les logs que depuis le dernier démarrage. J'imagine que ça se configure ?

      • [^] # Re: Regarder les logs

        Posté par (page perso) . Évalué à 4. Dernière modification le 05/11/14 à 20:13.

        Je me réponds : il faut créer un dossier /var/log/journal si on veut que les logs soient persistants…

  • # Arrêt lent sous Debian

    Posté par (page perso) . Évalué à 3.

    J'ai eu le même problème de lenteur à l'arrêt de ma Debian Testing/Jessie il y a quelques temps. Le coupable était Samba.

    Analyse :
    - Au démarrage de GRUB, retire le paramètre "quiet" de la ligne de boot de ton kernel linux (ou alors, modifie à la main le "/boot/grub/grub.cfg" . Ainsi, tu verras tout les messages de démarrage de systemd.
    - graçe à ceci, lors de l'arrêt de la machine, tu verras les messages d'arrêt de systemd. Il est probable que tu observes alors un timeout de 5 minutes pour samba (il y a un compteur qui décroît).

    Solution:
    - chez moi, le symptôme était que "/etc/init.d/samba" était lancé via systemd, et qu'il fait double emploi avec "/etc/init.d/smbd" et "/etc/init.d/nmbd"
    - j'ai donc complètement désactivé "samba", mais laissé "smbd", "nmbd" et "samba-ad-dc" d'actif :

    systemctl stop samba
    systemctl disable samba
    update-rc.d -f samba remove

    • [^] # Re: Arrêt lent sous Debian

      Posté par (page perso) . Évalué à 2.

      Merci, effectivement le timeout est très long et sans aucun message pour me dire ce qu'il fait je pensais que samba n'était pas le problème.

      Donc je pense que le problème est résolu sur l'une de mes machines. L'autre qui s'éteint très rapidement j'imagine que c'est le miracle systemd + SSD…

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.