Forum Linux.debian/ubuntu Firefox n'ouvre plus les liens en arrière-plan

Posté par .
Tags :
2
16
août
2012

Bonjour,

Depuis une mise à jour il y a quelques semaines, j'ai un petit soucis avec Firefox (Je suis sous Kubuntu 12.04).

Depuis une de ces mises à jours, lorsque j'ouvre un lien dans un programme externe à Firefox (Thunderbird, Akregator,…), celui-ci ouvre le nouvel onglet en avant-plan et passe Firefox en avant-plan aussi, alors qu'avant, Firefox allait sur le nouvel onglet, mais restait en arrière-plan. J'aimerai retrouver ce comportement, et j'ai déjà essayé 2-3 choses.

Modifier about:config : on peut modifier si un nouvel onglet s'ouvre en avant-plan ou pas, mais pas que Firefox reste en arrière-plan

Modifier les options de KDE : On peut changer le comportement des fenêtres pour ne pas prendre le focus aussi facilement, mais ce comportement s'applique à toutes les fenêtres. Cela résous mon problème, mais l'utilisation générale devient désagréable.

Quelqu'un connaît il un moyen pour que Firefox passe sur le nouvel onglet quand on clique sur un lien (pour voir dans la barre de tâche qu'on a bien cliqué sur le lien) en restant malgré tout en arrière plan?

Merci

  • # Question de goûts...

    Posté par . Évalué à 1.

    Je me suis arraché les cheveux dans le sens inverse il y a quelques mois. À mon avis, le nouveau comportement convient mieux aux débutants et aux utilisateurs non informaticiens, mais c'est regrettable qu'il n'y ait pas une option de focus simple pour rendre ce comportement facilement modifiable selon les goûts de chacun. Pas à ma connaissance, en tout cas…

    Pour les onglets, tu n'a pas besoin d'about:config. Il y a une option facile d'accès dans les préférences… à moins qu'about:config te convienne mieux…

    Bon courage dans tes recherches

  • # pas seul

    Posté par (page perso) . Évalué à 0.

    moi aussi j'ai eu le même problème y"a pas longtemps; 'ai filé mon ordi à un pote qui m'a régler ça,j'avoue c'est énervant

    [url=http://www.dailymobile.fr]ubuntu en linux tablette[/url]

    • [^] # Re: pas seul

      Posté par . Évalué à 1.

      Est ce que tu pourrais te renseigner chez ton ami pour savoir ce qu'il a fait?

      Merci

  • # Dans KDE tout est configurable

    Posté par . Évalué à 1. Dernière modification le 17/08/12 à 19:27.

    Modifier les options de KDE : On peut changer le comportement des fenêtres pour ne pas prendre le focus aussi facilement, mais ce comportement s'applique à toutes les fenêtres. Cela résous mon problème, mais l'utilisation générale devient désagréable.

    Tu peux changer le comportement pour Firefox uniquement. Dans la configuration du système > comportement des fenêtres > Règles de la fenêtre. C'est également accessible directement depuis le menu de la fenêtre de Firefox (en cliquant sur la petite icône tout en haut à gauche)

    • [^] # Re: Dans KDE tout est configurable

      Posté par . Évalué à 1.

      Merci, je viens de créer un règle pour Firefox, je ne connaissais pas cette possibilité. Pour le moment cela fonctionne comme je le voulais, sans que cela ne pose problème pour d'autres applications.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.