Forum Linux.debian/ubuntu Grub: Enlever le temps d'attente

Posté par (page perso) . Licence CC by-sa
Tags :
3
10
déc.
2017

Bonjour,

Après plusieurs tentatives, je ne parviens pas à enlever les 10 secondes d'attentes que j'ai au démarrage de mon PC. Voici le contenu actuel de mon fichier /etc/defaut/grub:

# If you change this file, run 'update-grub' afterwards to update
# /boot/grub/grub.cfg.
# For full documentation of the options in this file, see:
#   info -f grub -n 'Simple configuration'

GRUB_DEFAULT=0
GRUB_HIDDEN_TIMEOUT=0
GRUB_HIDDEN_TIMEOUT_QUIET=true
GRUB_TIMEOUT=0
GRUB_DISTRIBUTOR=`lsb_release -i -s 2> /dev/null || echo Debian`
GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
GRUB_CMDLINE_LINUX=""

# Uncomment to enable BadRAM filtering, modify to suit your needs
# This works with Linux (no patch required) and with any kernel that obtains
# the memory map information from GRUB (GNU Mach, kernel of FreeBSD ...)
#GRUB_BADRAM="0x01234567,0xfefefefe,0x89abcdef,0xefefefef"

# Uncomment to disable graphical terminal (grub-pc only)
#GRUB_TERMINAL=console

# The resolution used on graphical terminal
# note that you can use only modes which your graphic card supports via VBE
# you can see them in real GRUB with the command `vbeinfo'
#GRUB_GFXMODE=640x480

# Uncomment if you don't want GRUB to pass "root=UUID=xxx" parameter to Linux
#GRUB_DISABLE_LINUX_UUID=true

# Uncomment to disable generation of recovery mode menu entries
#GRUB_DISABLE_RECOVERY="true"

# Uncomment to get a beep at grub start
#GRUB_INIT_TUNE="480 440 1"

Après modification, j'exécute "sudo update-grub2", mais je n'obtiens pas le résultat voulu… Merci pour votre aide

  • # Update grub

    Posté par . Évalué à 3 (+0/-0).

    Après modification, j'exécute "sudo update-grub2", mais je n'obtiens pas le résultat voulu…

    La commande ne retourne pas d’erreur ? Bizarre ce '2' à la fin du nom du programme… Chez moi c’est /usr/sbin/update-grub, sans le 2… Tu n’as pas ce fichier chez toi ? Genre même un lien symbolique ? Le commentaire dans le fichier parle bien de "update-grub", pas de "update-grub2"…

    • [^] # Re: Update grub

      Posté par (page perso) . Évalué à 1 (+0/-0).

      Dans le doute j'exécutais les deux, mais effectivement ce n'est pas nécessaire:

      ~$ ls -l /usr/sbin/update-grub2
      lrwxrwxrwx 1 root root 11 nov.   5 16:01 /usr/sbin/update-grub2 -> update-grub
      

      Un LUG en Lorraine : https://enunclic-cappel.fr

    • [^] # Re: Update grub

      Posté par (page perso) . Évalué à 6 (+5/-0).

      Concernant update-grub2, son but dans la vie est de générer un fichier de configuration pour GRUB, i.e. /boot/grub/grub.cfg (plus exactement, c'est c'est un wrapper pour grub-mkconfig, dont c'est le but). Si cette commande arrive à générer sans erreur le fichier en question, il n'y a pas de raison qu'elle retourne un code d'erreur non nul, ou qu'elle affiche des erreurs. Il convient de vérifier le contenu du fichier ainsi mis à jour en tenant compte des réglages spécifiés dans les différents fichiers (/etc/default/grub et /etc/grub.d/*) pour vérifier si cette commande a fait son boulot.

      Pour le 2 en fin de commande, il y a eu une période où les paquets grub et grub2 ont cohabité dans Debian (possiblement Ubuntu aussi), avec chacun ses outils. Maintenant, la version 1 est oubliée, et on peut appeler indifféremment l'une ou l'autre des commandes (cf. lien symbolique mentionné dans une autre réponse).

      Maintenant, pour le « résultat attendu », ce serait bien de détailler ce qui est affiché (menu ou non), combien de temps est attendu, etc. Personnellement, je découvre les variables GRUB_HIDDEN_TIMEOUT* ce jour. Je n'aurais pas pensé cela nécessaire pour ce type de manip. Sur Debian Stretch, j'ai juste besoin de changer le GRUB_TIMEOUT=5 en GRUB_TIMEOUT=0, puis update-grub, et plus d'attente.

      Préciser la distribution et la version de GRUB serait une bonne idée, aussi.

      Debian Consultant @ DEBAMAX

      • [^] # Re: Update grub

        Posté par . Évalué à 3 (+0/-0).

        Si cette commande arrive à générer sans erreur le fichier en question, il n'y a pas de raison qu'elle retourne un code d'erreur non nul, ou qu'elle affiche des erreurs.

        Oui justement. Au vu des options choisies, les deux timeout à 0, je suspecte que la commande n’aboutisse réellement pas… M’enfin je me trompe peut-être… En toute logique OP aurait précisé si message d’erreur il y avait… en toute logique…

        Pour le lien grub2 → grub, je viens de vérifier, il est effectivement présent sous Stretch. Chez moi, en Sid, il n’existe plus.

      • [^] # Re: Update grub

        Posté par . Évalué à 3 (+0/-0). Dernière modification le 11/12/17 à 08:02.

        c'est c'est un wrapper pour grub-mkconfig, dont c'est le but

        Plus précisément, et si je ne dis pas de bêtise, c’est un wrapper pour plusieurs des outils grub-*, tel que grub-install. Le wrapper update-grub permet de réaliser l’enchaînement de toutes les étapes nécessaires, dont la génération de la configuration n’est que la première.

        • [^] # Re: Update grub

          Posté par (page perso) . Évalué à 2 (+1/-0).

          (Bon, ma réponse s'est fait shooter plusieurs fois par LinuxFr, je refais en plus court.)

          Non non, cf. sa page de manuel et surtout son code :

          #!/bin/sh
          set -e
          exec grub-mkconfig -o /boot/grub/grub.cfg "$@"
          

          Et je vois bien update-grub et update-grub2 dans le dernier paquet grub2-common disponible dans unstable.

          Debian Consultant @ DEBAMAX

          • [^] # Re: Update grub

            Posté par . Évalué à 3 (+0/-0).

            Et je vois bien update-grub et update-grub2 dans le dernier paquet grub2-common disponible dans unstable.

            Tu dis vrai, j’avais mal regardé.

  • # Exemple

    Posté par (page perso) . Évalué à 1 (+0/-0).

    Je suis sous Linux Mint 18.3. Si quelqu'un peut coller ici une config qui marche chez lui, ce serait parfait!
    La commande update-grub ne me renvoie pas d'erreur, et le menu est bien mis à jour (j'avais encore un Win dans la liste, que j'ai fait disparaitre en supprimant une partition ntfs puis en lançant update-grub).
    Si il faut plus d'infos, j'en posterai quand j'aurai le PC devant moi.

    Un LUG en Lorraine : https://enunclic-cappel.fr

  • # re

    Posté par . Évalué à 1 (+0/-0). Dernière modification le 11/12/17 à 11:32.

    GRUB_HIDDEN_TIMEOUT=0
    GRUB_HIDDEN_TIMEOUT_QUIET=true
    Ajoute # devant c'est ligne et re-teste, elle doivent être utile mais j'ai pas dans la miène debian :D

    Sinon, tu n'aurais pas une autre distribution installer ?
    Si oui, il faut d'abord faire update-grub sur celui actuel, puis pareil sur celui de l'autre distribution, et la ça devrait marcher. Ça marche comme ça chez moi quand il y a plusieurs grub/distribution.

    "Comme ta création n’est pas en vain, la création de ces événements n’est pas non plus en vain." Bediüzzaman

  • # Retour

    Posté par (page perso) . Évalué à 3 (+2/-0).

    Effectivement j'ai plusieurs systèmes, mais un seul que j'utilise: le dernier que j'ai installé, et je lui ai bien fait installer grub sur le mbr du disque de démarrage.
    J'ai jeté un oeil à /boot/grub.cfg (il fait plus de 1900 lignes :O ) et j'ai trouvé dedans:

    set timeout_style=menu
    if [ "${timeout}" = 0 ]; then
      set timeout=10
    fi
    

    Donc j'ai mis un timeout de 1 dans mon /etc/defaut/grub, et le menu ne s'affiche plus que pendant 1 seconde. Ce n'est pas parfait, mais c"est déjà 10 fois mieux :)

    Merci pour votre aide

    Un LUG en Lorraine : https://enunclic-cappel.fr

    • [^] # Solution!

      Posté par (page perso) . Évalué à 4 (+3/-0).

      J'ai trouvé une solution!

      1. Dans /etc/defaut/grub: mettre GRUB_TIMEOUT=0
      2. Dans /etc/grub.d/30_os-prober : modifier la variable quick_boot="1" en quick_boot="0"
      3. Lancer sudo update-grub

      Un LUG en Lorraine : https://enunclic-cappel.fr

Envoyer un commentaire

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.