Forum Linux.debian/ubuntu Monter son téléphone

Posté par . Licence CC by-sa
Tags : aucun
1
10
mai
2014

Bonjour à tous,

Depuis quelques temps, j'essaye de monter mon téléphone sur mon ordi. Il est bien reconnu comme périphérique (/dev/sd…) mais le système ne le monte pas automatiquement.

Voici un extrait du syslog correspondant au périphérique :


May 10 12:16:51 portable-dom kernel: usb 7-1: new high-speed USB device number 4 using ehci-pci
May 10 12:16:51 portable-dom kernel: usb 7-1: New USB device found, idVendor=04e8, idProduct=685e
May 10 12:16:51 portable-dom kernel: usb 7-1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
May 10 12:16:51 portable-dom kernel: usb 7-1: Product: BCM21553-Thunderbird
May 10 12:16:51 portable-dom kernel: usb 7-1: Manufacturer: Broadcom
May 10 12:16:51 portable-dom kernel: usb 7-1: SerialNumber: 0123456789ABCDEF
May 10 12:16:51 portable-dom kernel: cdc_acm 7-1:1.1: This device cannot do calls on its own. It is not a modem.
May 10 12:16:51 portable-dom kernel: cdc_acm 7-1:1.1: ttyACM0: USB ACM device
May 10 12:16:51 portable-dom kernel: usbcore: registered new interface driver cdc_acm
May 10 12:16:51 portable-dom kernel: cdc_acm: USB Abstract Control Model driver for USB modems and ISDN adapters
May 10 12:16:52 portable-dom kernel: usb-storage 7-1:1.0: USB Mass Storage device detected
May 10 12:16:52 portable-dom kernel: scsi5 : usb-storage 7-1:1.0
May 10 12:16:52 portable-dom kernel: usbcore: registered new interface driver usb-storage
May 10 12:16:53 portable-dom kernel: scsi 5:0:0:0: Direct-Access     SAMSUNG  S5830i Card      0000 PQ: 0 ANSI: 2
May 10 12:16:53 portable-dom kernel: sd 5:0:0:0: Attached scsi generic sg2 type 0
May 10 12:16:53 portable-dom kernel: sd 5:0:0:0: [sdb] Attached SCSI removable disk

Par contre en montant manuellement le périphérique :

$ sudo mount /dev/sdb
mount: can't find /dev/sdb in /etc/fstab or /etc/mtab

J'ai la fenêtre du bureau qui m'annonce la détection d'un nouveau stockage.

Est-ce que ça parle à quelqu'un ?

(Mon ordi tourne sur debian testing!)

  • # udisks2

    Posté par (page perso) . Évalué à 1.

    Déjà je commencerai par installer udisks2 (remplaçant de udisks) histoire d'avoir un montage automatique des périphériques de type clé usb.

    Sans udisks2 pour monter je ferais :

    mkdir ~/phone
    sudo mount /dev/sdb ~/phone

    wind0w$ suxX, GNU/Linux roxX!

    • [^] # Re: udisks2

      Posté par . Évalué à 1.

      J'arrive à monter tous les autres périphériques sans problèmes (clé usb et disque dur)

      J'ai déjà udisk2 installé mais apparemment, ça ne change rien!

      • [^] # Re: udisks2

        Posté par (page perso) . Évalué à 1.

        Tu peux essayer de créer une entrée dans le /etc/fstab mais en ce qui me concerne je n'ai aucune entrée dans fstab pour tout ce qui est périphérique de type clé usb.

        Si tu as Gnome regarde dans Paramètres/Détails/Médias amovibles

        Tu peux aussi installer gnome-disk-utility ça dépanne parfois.

        Ton téléphone c'est quel modèle exactement? C'est un Samsung Galaxy non?

        wind0w$ suxX, GNU/Linux roxX!

        • [^] # Re: udisks2

          Posté par . Évalué à 1.

          Mon téléphone est un samsung galaxy ace tournant sur android.

          Merci de ton aide. Je vais essayer et tester tout çà.

          • [^] # Re: udisks2

            Posté par (page perso) . Évalué à 2.

            D'après ce que je vois sur le net avec les Samsung Andoid il faut :

            1) go to Settings->Applications->USB Settings and select the "Mass Storage" option.
            2) go to Settings->Applications->Development and select "Stay Awake"

            Ce qui doit se traduire en français par :

            1) aller dans Paramètres->Applications->Paramètres USB et sélectionner l'option "Stockage de masse".
            2) aller dans Paramètres->Applications->Développement et sélectionner "Rester connecter"

            Ensuite tu connectes le téléphone en usb à ta machine.

            wind0w$ suxX, GNU/Linux roxX!

  • # Du côté d'udev

    Posté par (page perso) . Évalué à 2.

    Même distribution, mêmes symptômes avec un téléphone Android. Le coupable semble être udev : le noyau ne lit pas la table des partitions du média, sauf si on force un premier accès en lecture (par exemple avec file -s /dev/sdb, ou bien avec ton appel à mount).

    Juste après cet appel, tu peux remarquer que le log noyau a pris quelques lignes supplémentaires par rapport à l'extrait que tu donnes.

    Il y a quelques rapports de bugs chez Debian, dont ceux-ci :
    - https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=725978
    - https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=713877

    Dans ce dernier rapport, j'ai trouvé un contournement qui fonctionne chez moi : https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=713877#25 ainsi qu'un bout d'explication du problème : https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=713877#49

    Le bug est réparé dans unstable : il va finir par l'être également dans testing, d'ici quelques jours/semaines.

    • [^] # Re: Du côté d'udev

      Posté par (page perso) . Évalué à 2.

      Merci beaucoup pour ton explication.

      Entre les différents gestionnaires : hal, gvfs, udev je trouve que la gestion des medias amovibles est aussi compliquée que la gestion du son. Quand un point dans la chaîne est cassé il est vraiment compliqué de savoir d'où ça vient…

  • # fdisk pour forcer la lecture de la table des partitions

    Posté par . Évalué à 1.

    Moi j'ai un wiko et j'ai les mêmes symptômes : le système ne voit pas les partitions sur le /dev/sdX, bien que le kernel détecte bien le "mass storage" comme un disque.

    Suis pas du tout fan des trucs qui me font des trucs par derrière sans que je le sache (sans mauvais jeux de mots :) ), udev me saoul, udisk j'en parle pas … Pour m'en sortir à la main, je suis obligé de faire un fdisk dessus pour que le kernel relise la table des partitions :

    root# fdisk /dev/sdX
    ...
    quit
    root#

    freakazohid, une fois que tes partitions sont là (en regardant les logs du kernel ou /proc/partitions), il faut que tu montes la partition et non le disque !

    root# mount /dev/sdbX /mon/point/de/montage

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.