Forum Linux.debian/ubuntu Pas de question au démarrage sur ubuntu 12.04

Posté par .
0
11
nov.
2012

Hello,

J'ai une question sûrement assez simple mais que je sais moyennement par quel bout prendre.

J'ai un vieux PC sous ubuntu 12.04 que j'utilise comme serveur. Il n'a ni clavier ni écran branché. Malheureusement

  • si une erreur se fait sentir et que je redémarre, grub demande que faire, attendant indéfiniment
  • si j'ai une erreur sur un disque, ubuntu demande que faire (M pour reprise manuelle, S pour passer).

J'aimerais éviter ces deux arrêts et que le système démarre quoi qu'il en soit, mettant un message dans les logs bien sur.

1- est-ce sain ou absolument déconseillé de faire ça ?
2- comment faire ? Pour grub j'imagine que je peux trouver une option pour grub.conf mais pour le démarrage ubuntu je ne sais pas trop où chercher (option dans fstab ?), si quelqu'un peut m'indiquer !

  • # des pistes

    Posté par . Évalué à 3.

    1- est-ce sain ou absolument déconseillé de faire ça ?

    c'est ta machine, à toi de voir ce qui est vital.
    ex : avoir un volume raid pas pret, si c'est juste pour des données, à acceder par le reseau, sans que ca impacte d'autres serveurs (ex ton nas perso)
    alors oui, tu peux faire S pour continuer le demarrage sans que ce soit bloquant (c'est ce que je fais quand mon raid à du mal à demarrer.

    2- comment faire ? Pour grub j'imagine que je peux trouver une option pour grub.conf mais pour le démarrage ubuntu je ne sais pas trop où chercher (option dans fstab ?), si quelqu'un peut m'indiquer !

    pour grub faut juste lui indiquer un timeout, ca se regle dans /etc/default/grub

    pour les disques, aucune idée, je penses qu'il rale parce qu'ils sont dans /etc/fstab et qu'ils ne se montent donc pas tous seuls.
    à voir si ca le fait en mettant noauto en option dans le fstab et en faisant le montage dans /etc/rc.local

    • [^] # Re: des pistes

      Posté par (page perso) . Évalué à 6.

      J'aurais plutôt dis que l'erreur des disques survient suite un démontage brusque et qu'il veut faire un fschk mais il y a des erreurs qu'il faut corriger manuellement.

      « Rappelez-vous toujours que si la Gestapo avait les moyens de vous faire parler, les politiciens ont, eux, les moyens de vous faire taire. » Coluche

      • [^] # Re: des pistes

        Posté par . Évalué à 3.

        je confirmes que sur mon ubuntu, le message "continuer à attendre, presser S pour passer ou M pour manuel" apparait aussi quand les disques qui doivent etre monter au boot dans /etc/fstab n'existe pas sur la machine (disque eteint ou enlever)

        • [^] # Re: des pistes

          Posté par (page perso) . Évalué à 4.

          J'avais mal compris ce que tu voulais dire. Effectivement, c'est bien possible qu'il y ait ce message là.

          « Rappelez-vous toujours que si la Gestapo avait les moyens de vous faire parler, les politiciens ont, eux, les moyens de vous faire taire. » Coluche

    • [^] # Re: des pistes

      Posté par . Évalué à 1.

      Merci pour les pistes. En effet le meilleur moyen coté disque semble de mettre le noauto et d'invoquer un mount dans rc.local ou mieux, dans un script upstart.

      Pour grub en fait j'ai dû aller voir /etc/grub.d/00_header pour comprendre qu'il fallait ajouter un option GRUB_RECORDFAIL_TIMEOUT=10 dans /etc/default/grub.conf (puis lancer sudo update-grub pour régénérer /boot/grub/grub.cfg)

      Bon sinon, juste pour info, dans Ubuntu c'est https://wiki.ubuntu.com/Plymouth qui gère le dialogue lors du boot.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.