Forum Linux.debian/ubuntu Problème de boot causé par un périphérique USB

Posté par . Licence CC by-sa
Tags :
1
21
juin
2014

Bonjour,

J'ai installé une Debian 7 sans interface graphique sur un laptop Asus A6000KM.

Lorsque je boot, j'arrive toujours à voir le Grub.

Si je n'ai pas de périphérique USB connecté au laptop, le boot se poursuit et j'arrive à la console.

Si il y a un périphérique USB connecté, l'écran reste définitivement noir avec juste un "_" blanc clignotant en haut à gauche.

J'ai évidement testé tous les port USB de la machine avec 2 claviers et 2 souris différentes. Le problème est à chaque fois identique.

Quelqu'un a-t-il une idée?

  • # Solution

    Posté par . Évalué à 3.

    J'ai fini par trouver une solution.

    Je suis donc passé en mode de dépannage dans Grub et j'ai vu que la dernière ligne parlait de ACPI.
    Après avoir consulté https://wiki.ubuntu.com/DebuggingACPI, j'ai fini par modifier /etc/default/grub:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet"
    =>
    GRUB_CMDLINE_LINUX_DEFAULT="quiet acpi=off"

    Plus de problèmes au boot. Par contre je suis maintenant obligé de pousser sur le bouton du laptop pour l'éteindre complétement…

    Apparemment le bios est trop vieux (v210) pour fonctionner avec ACPI. J'ai donc essayé de le flasher avec freedos, mais impossible de faire fonctionner l'utilitaire Aflash2.

    Donc ça va rester comme ça…

    • [^] # Re: Solution

      Posté par . Évalué à 0.

      bah suffit de laisser ACPI qui marche correctement
      et de ne brancher le peripherique USB qu'apres le boot

      • [^] # Re: Solution

        Posté par . Évalué à 2.

        Si ça ne tenais qu'à moi …
        C'est l'ordinateur de mon père qui se fait vieux et qui est un peu réfractaire à la technologie.

        • [^] # Re: Solution

          Posté par . Évalué à -1.

          un utilisateur ca s'eduque
          si tu lui dis de ne pas brancher les clefs/disques USB avant d'avoir demarré la machine, il le fera.

          evidemment c'est plus embetant sur un PC fixe, s'il faut demarrer sans clavier/souris :/

          • [^] # Re: Solution

            Posté par . Évalué à 3.

            un utilisateur ca s'eduque

            Un utilisateur ça s'éduque mais faut quand même voir que ça empêche de laisser branché un périph' comme une clé USB (stockage, wifi, tnt, que sais-je…) quand on éteint l'ordinateur, pour pas avoir à le rebrancher quand on le démarre…

    • [^] # Re: Solution

      Posté par (page perso) . Évalué à 2.

      Et si tu enlèves le "quiet" des options de démarrage du noyau pour savoir où cela plante exactement cela donne quoi ?

      • [^] # Re: Solution

        Posté par . Évalué à 1.

        Je testerais ça mercredi quand je retournerais chez moi.

  • # Grub et USB

    Posté par . Évalué à 3. Dernière modification le 23/06/14 à 13:40.

    Si il y a un périphérique USB connecté, l'écran reste définitivement noir avec juste un "_" blanc clignotant en haut à gauche.

    ca ressemble à un peripherique USB de stockage
    avec un grub installé avec un /dev/sdXY plutot qu'avec l'UUID du disque

    du coup il ne trouve plus ses fichiers

    si ce n'est pas un peripherique USB de stockage, là ca devient plus embetant.

    • [^] # Re: Grub et USB

      Posté par . Évalué à 1.

      Les périphérique USB sont juste un pad numérique et une souris. Pas de clé USB dans l'histoire.

      Grub est en principe installé sur le seul disque dur.

      • [^] # Re: Grub et USB

        Posté par (page perso) . Évalué à 1.

        Le problème ne se situe pas au niveau de Grub, mais au niveau du noyau lui-même, car l'ajout de l'option noyau "acpi=off" permet le démarrage.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.