Forum Linux.débutant aide CUDA linux

Posté par . Licence CC by-sa
Tags : aucun
2
25
fév.
2016

Bonjour à tous!

Je viens vous voir car je cherche depuis plusieurs semaine une solution pour faire fonctionner ma carte graphique Quadro FX 4800 comme moteur de rendu pour Blender.

Le problème ce que soit je ne trouve pas les pilotes, soit il y a des incompatibilités que je ne comprends pas a 100%.

J'ai essayé d'installer plusieurs pilotes qui n'ont rien changé, ma carte graphique n'est pas repérée dans Blender.

J'ai trouvé un site expliquant comment installer CUDA sur linux:

Mais arrivé à l'étape de test (après l'installation du toolkit et du SDK et compilation):
[ Le dossier ~/NVIDIA_GPU_Computing_SDK/C/bin/linux/release/ contient de petites applications qui servent d'exemple d'utilisation de Cuda.
Lancez une de ces applications:
~/NVIDIA_GPU_Computing_SDK/C/bin/linux/release/./fluidsGL ]
Je lance donc une des applications et je reçois un message d'erreur dans la console:

/opt/cuda/include/host_config.h:82:2 error: #error—unsupported GNU version! gcc and up are not supported!
#error—unsupported GNU version! gcc 4.7 and up are not supported!
make[1]: *** [obj/x86_64/release/simpleAssert.cu_20.o] Erreur 1
make[1]: quittant le répertoire << /home/luspha/NVIDIA_GPU_Computing_SDK/C/src/simpleAssert >>
make: *** [src/simpleAssert/Makefile.ph.build] Erreur 2

avant de me lancer dans la recherche de la version gcc 4.6 (je ne sais pas a quoi cela correspond d'ailleurs, peut etre le toolkit..) comme m'indique le rapport d'erreur, je voulais savoir si c'est effectivement la solution ou si c'est perdu d'avance. Cela va faire 1 mois que je cherche a installer CUDA, d'abord sur windows ( un echec cuisant). Si ma carte graphique est trop vieille et qu'il n'y a plus de solution merci de me l'indiquer car je m'approche dangereusement de la religion à la recherche du Graal…

Merci à vous !
(Si ce n'est pas le bon endroit pour poster un message veuillez m'en excuser, promis je ne recommencerais pas)

  • # dans l'ordre

    Posté par . Évalué à 5.

    Si ma carte graphique est trop vieille et qu'il n'y a plus de solution merci de me l'indiquer

    faut peut-etre simplement commencer par aller lire les specifications techniques :
    - du constructeur
    - du projet CUDA qui indiquera les cartes compatibles

    avant de me lancer dans la recherche de la version gcc 4.6 (je ne sais pas a quoi cela correspond d'ailleurs, peut etre le toolkit..)

    ah oui, là on revient de loin.

    gcc, c'est un compilateur, qui va convertir des programmes C en code machine.

    il te faut probablement installer un ensemble d'outils pour pouvoir compiler puis installer les programmes.

    avec ubuntu, c'est le paquet build-essential qui va installer make, gcc, et quelques autres outils.

    • [^] # Re: dans l'ordre

      Posté par . Évalué à 1.

      Merci d'avoir répondu aussi vite, je possède déjà build-essential version 11.6 qui apparament est la dernière version. Est-ce utile de télécharger "Package: gcc (4:4.8.2-1ubuntu6) " qui semble suffire ou plutôt la dernière version de gcc ?

      Merci pour ces éclaircissements ! une version au de

  • # Problème (peut-être) classique

    Posté par (page perso) . Évalué à 5.

    Salut,

    Dans la seconde partie du post, tu parles de logiciels test qui foirent. Donc peut-être as-tu vraiment des problèmes avec tes drivers, je sais pas.
    Mais sinon, peut-être que ton driver est bien installé, et tu rencontres un problème assez classique de Blender qui ne voit pas ta carte pourtant parfaitement installée et fonctionnelle. Je l'ai eu aussi sur un ordi.

    De mémoire, un "truc" qui marchait bien — et attention, c'est sale et horrible — c'est de lancer une fois blender en root. Blender détectera la carte à ce moment là. Puis après en lançant blender comme un utilisateur normal à nouveau, cette fois, ça détectera aussi. Oui, ce comportement est ridicule et incompréhensible, mais apparemment avec certaines versions du pilote, CUDA n'est disponible pour les utilisateurs "normaux" que si tu as d'abord exécuté du code CUDA en root. Tu n'as donc pas à lancer blender en root forcément. Tu peux lancer n'importe quoi d'autre avec du code CUDA en root, pour qu'après tout logiciel utilisateur ait aussi accès à CUDA.
    Après une petite recherche, j'ai trouvé ce post qui réexplique notamment ce contournement de bug du pilote.

    Un autre truc — il me semble, toujours de mémoire — est que Blender n'est pas forcément compilé avec toutes les options. Les paquetages de distribution sont typiquement décevants sur ce type de logiciel où on aimerait vraiment avoir le maximum d'options avancées dispos. C'est donc aussi possible que ta distrib livre un Blender compilé sans support CUDA (oui c'est triste, surtout pour un tel logiciel, mais il me semble avoir eu le cas). Il est souvent préférable d'utiliser les versions de Blender en téléchargement sur http://blender.org. C'est dommage, car ça casse complètement l'intégration (non dispo dans les menus, ni par double clic sur un fichier, etc.), mais de toutes façons, quand tu utilises Blender, tu en viens souvent à vouloir la dernière version.
    Une autre solution est de compiler Blender toi-même avec toutes les options que tu veux, dont le support CUDA. Mais c'est pas forcément à la portée de tous (enfin sans trop de prise de tête quoi).

    Film d'animation libre en CC by-sa/Art Libre, fait avec GIMP et autre logiciels libres: ZeMarmot [ http://film.zemarmot.net ]

    • [^] # Re: Problème (peut-être) classique

      Posté par . Évalué à 1.

      Merci beaucoup! je regarde cela de plus près..

      • [^] # Re: Problème (peut-être) classique

        Posté par . Évalué à 1.

        Bon je suis grave largué. Je n'ai pas trouvé comment lancer une application en root (de ce que j'ai comprit la commande). Mes pilotes sont bien a jour (3.40 pour ma QuadroFX4800) et gcc 4.9. Via ton post il est dit que le moteur de rendu "Cycles" de blender nécessite une versionde CUDA supérieure ou égale a 2.0, hors ma carte graphique (sur le site de wikipedia) n'est pas compatible ne monte que à la version 1.3 (https://en.wikipedia.org/wiki/CUDA). A part compiler seul Blender, ou essayer d'installer la version CUDA toolkit 1.3, je ne vois pas…

        En tout cas merci de t'être penché sur mon problème!

        • [^] # Re: Problème (peut-être) classique

          Posté par . Évalué à 2.

          Via ton post il est dit que le moteur de rendu "Cycles" de blender nécessite une versionde CUDA supérieure ou égale a 2.0, hors ma carte graphique (sur le site de wikipedia) n'est pas compatible ne monte que à la version 1.3

          voila qui repond alors à ta question.

          pour utiliser CUDA avec Blender il faut CUDA >= 2.0
          ta carte fournit CUDA 1.3
          bilan tu ne pourras pas utiliser CUDA avec Blender

  • # supprimer

    Posté par . Évalué à 1. Dernière modification le 26/02/16 à 09:48.

    À supprimer

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.