Forum Linux.débutant pb de lecture vidéo ??

Posté par .
Tags : aucun
1
25
août
2008
Bonjour,
J'ai un souci avec mes logiciels de lecture vidéo sous mandriva: que ce soit vlc, kaffeine, mplayer, je n'ai que le son, et que du bleu en guise d'image.
Que faire ??

d'avance merci
  • # codec

    Posté par . Évalué à 0.

    installer le codec qui permet de lire ta video

    par definition certains codecs sont "libres" et donc inclus dans la distrib
    mais parfois d'autres codecs ne le sont pas (mp3, dvdcss), il te faut donc les ajouter par toi meme.

    google est ton ami là dessus
  • # Format

    Posté par . Évalué à 0.

    Il faudra savoir en quel format sont tes vidéos.
    Avec une description un peu plus précise, à savoir ton matos (carte graphique en particulier)
    • [^] # Re: Format

      Posté par . Évalué à 1.

      Alors alors. Les vidéos en question sont au format divx, ou plutôt xvid, mais aussi en mpeg ou avi, et meme en dv.
      Je travaille sur un portable sony, la carte video est une ati radeon IGP 300M.
      J'ai essayé de réinstaller kaffeine que j'avais viré entre temps. J'ai essayé de trouver quels codecs me manquaient. Mais j'avoue que je manque de connaissances (j'étais sous xp il n'y a encore pas si longtemps).
      Avidemux fonctionne très bien, lui : il peut visionner n'importe quelle vidéo, et ce depuis le début de mes ennuis. Alors les codecs sont là, non ?
      ...
      Bon, maintenant j'arrive à visualiser les videos sous vlc, mais pas avec kaffeine (!!)
      • [^] # Re: Format

        Posté par . Évalué à 1.

        cf http://easyurpmi.zarb.org/ pour installer les dépots PLF qui récupèrent les paquets légalement 'limite' (comme deCSS, mp3, xvid, etc...)

        Ensuite, tu dois pouvoir installer un player ou mettre à jour pour aller chercher tous les bon codecs.

        "La première sécurité est la liberté"

        • [^] # Re: Format

          Posté par (page perso) . Évalué à 1.

          Les paquets que tu cites sont légaux en France (voire en Europe), les brevets logiciels étant encore illégaux et DADVSI ayant vu son interprétation des MTP^WDRM^Wprotections efficaces ne pouvant aller à l'encontre d'une utilisation légitime (manifestement regarder ses DVD notamment).
  • # fond bleu et VLC, preuves tangibles

    Posté par (page perso) . Évalué à 2.

    Bonjour,

    si ça ne fonctionne pas avec VLC, alors c'est un problème d'affichage. VLC intègre ses propres codecs (corrigez moi si nécessaire). Le fait que tu ais un fond bleu est caractéristique également.

    On en parle ici: http://linuxfr.org/forums/14/25712.html
  • # Problème XV

    Posté par . Évalué à 6.

    Le bleu que tu vois, c'est très probablement la colorkey utilisée par XV, signe que l'accélération vidéo ne marche pas. Ca n'a rien à voir avec les codecs, car tu aurais soit un rendu dégueulasse, soit un message d'erreur, mais jamais un écran bleu.

    Donc la "solution idéale" serait que tes drivers graphiques marchent correctement (t'utilises lesquels, les libres ou proprio ?), sinon en attendant tu peux demander à tes logiciels de ne pas utiliser XV, mais X11.

    As-tu compiz d'activé ? Ca peut aussi jouer.
    • [^] # Re: Problème XV

      Posté par . Évalué à 3.

      Plop
      tout pareil : essaye de renseigner tes lecteurs pour qu' ils utilisent une autre sortie vidéo que Xv. Pour trouver celui qui te va bien, essaye avec mplayer, car c' est facile et rapide.

      Exemple :
      mplayer -vo help (afin d' obtenir la liste des VideoOutpout) puis
      mplayer -vo gl2 /chemin/vers/video.avi

      Une fois trouvé, renseigne la conf de tes autres lecteurs.
      Mandriva permet d' éviter ce type de configuration "a la mano" dans un grande majorité de cas. Tu te trouve peut être dans un cas non courant : Pourrais tu s' il te plait rapporter ta carte vidéo, le driver utilisé (quel modèle de carte intel ;p quel driver, et si compiz est activé). Merci d' avance


      ps : rien à voir donc, mais voici une liste de codecs (attention, certains ne sont pas libres, donc avoir les dépôts PLF de configurés) :

      urpmi flac vorbis-tools mpe1 twolame libffmpeg51 libvorbisenc2 ffmpeg2theora transcode mencoder ffmpeg dirac libavformat51 libavformat52 libavutil49 lame lame-mp3x libqicktime libqicktime0 libquicktime-faac libquicktime-faad libquicktime-x264 libaviplayavcodec x264 vorbisgain faac faad2 xanim-codecs win32-codecs real-codecs

      Cdlt
      • [^] # Re: Problème XV

        Posté par . Évalué à 1.

        En effet, avec mplayer, c'est facile de trouver puis changer de sortie vidéo : j'ai mis X11 et ça marche.
        Pour vlc en revanche, je n'ai pas trouvé où changer... mais ça marche aussi (là j'ai pas compris...).
        Pour mettre toutes les chances de mon côté, j'ai chargé tous les codecs. Malgré ça, kaffeine ne fonctionne toujours pas.

        Quant à mes drivers graphiques, je ne sais pas s'ils sont libres ou proprios. Comment fais-je pour le savoir ?
        • [^] # Re: Problème XV

          Posté par . Évalué à 1.

          Après bidouillage, il semblerait que kaffeine fonctionne avec le pilote video xshm.
          Pour ceux que ça intéresse...
        • [^] # Re: Problème XV

          Posté par . Évalué à 1.

          J'avais mal lu la question: les drivers graphiques que j'utilise sont libres. Mais j'ai aussi rajouté des proprios (je suis passé par plf pour compléter)
          • [^] # Re: Problème XV

            Posté par . Évalué à 2.

            Mhh ... tu utilises soit les libres, soit les proprios, mais pas les deux. Je pense que tu confonds codec et driver.
            En gros, faudrait juste savoir quelle distribution t'utilises et quelle est ta carte graphique, et si tu n'as pas installé explicitement les drivers proprio, normalement c'est que tu utilises les libres.
            • [^] # Re: Problème XV

              Posté par . Évalué à 1.

              La carte video est une ati radeon IGP 300M, et j'utilise mandriva 2008.
              • [^] # Re: Problème XV

                Posté par . Évalué à 2.

                Ouai, bon, les drivers ATI ils doivent pas encore être complètement au point pour ta carte. Tant mieux si t'as trouvé moyen de faire marcher tout ça quand même.
                • [^] # Re: Problème XV

                  Posté par . Évalué à 1.

                  Ah. J'ai eu du bol alors ?
                  • [^] # Re: Problème XV

                    Posté par . Évalué à 2.

                    Non, t'as trouvé un "workaround", parce qu'avec X11 ça doit bouffer du CPU comme c'est pas permis quand tu lis une vidéo ...

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.