Forum Linux.débutant Problème Installation Pilote Graphique AMD

Posté par . Licence CC by-sa
0
10
août
2017

Bonjour à tous, voilà dans quelques mois je rentre en 2e année de développement et design web. Je décide de mettre a Linux de façon approfondie pour mon futur pro.

J'ai installé Linux, changé mon bios en UEFI etc. Tout fonctionne parfaitement (enfin je crois) !

Mais maintenant quand je dois installer mon pilote graphique (Sapphire Radeon R9 390) j'ai un message d'erreur.
Et j'ai un problème d'affichage quand j'ouvre des fenêtres, mon écran se met à freeze par endroit je n'ai donc pas le choix :/
http://imgur.com/NEn3EEQ
Je vois bien que le problème vient de paquet non installés, mais je n'arrive pas à les installer…
J'ai bien suivi les consignes d'installation du pilote, j'ai essayé d'installer dkms avec cette commande "sudo apt-get install dkms" ce qui me donne :
http://imgur.com/N51slnC

Mais toujours rien y fait, je n'ai pas trouvé de solutions sur le net.

Si quelqu'un peut m'aider je suis bloqué depuis hier soir :(

  • # sources.list

    Posté par . Évalué à 2 (+0/-0).

    Le système connaît le paquet, mais il n'a pas l'air d'avoir de sources.

    Pourrais-tu nous donner le contenu du fichier /etc/apt/sources.list et des fichiers dans /etc/apt/sources.list.d (j'ai un doute sur le nom du dossier)? Savoir quelle distrib tu utilises serait aussi utile (en général on peut la deviner à partir de sources.list, mais dans ton cas j'ai l'impression qu'il y a un problème dans ce fichier donc…).

    • [^] # Re: sources.list

      Posté par . Évalué à 1 (+0/-0).

      Le fichiers sources.list ne contient rien du tout, complètement vide ! Il ne devrait pas y avoir une ligne cdrom ou je ne sais quoi ??? J'y avais déjà accédé l'année dernière pour un cours….

      Le dossier sources.list.d est vide aussi.

      http://imgur.com/I3EEXDm

      • [^] # Re: sources.list

        Posté par . Évalué à 1 (+0/-0). Dernière modification le 10/08/17 à 12:59.

        Je connais pas ubuntu mais je penses qu'il devrait être rempli, faut que tu donnes la version de ton ubuntu installer et quelqu'un pourrait peut-être te donné le bon contenu (ou d'autre méthode qui le rempliront).

        "Comme ta création n’est pas en vain, la création de ces événements n’est pas non plus en vain." Bediüzzaman

        • [^] # Re: sources.list

          Posté par . Évalué à 1 (+0/-0).

          Niveau version c'est la dernière, je l'ai téléchargé et installé hier depuis le repo Ubuntu, donc 16.04.3 si je ne dis pas de bêtises !

          • [^] # Re: sources.list

            Posté par . Évalué à 1 (+0/-0). Dernière modification le 10/08/17 à 13:00.

            Peux-tu faire un ls -la /etc/apt/sources.list* (ajoute bien l'étoile en fin) peut-être une version caché en backup y est resté.

            Je connais pas les contenus sources.list des ubuntus, faut attendre une autre réponse.

            "Comme ta création n’est pas en vain, la création de ces événements n’est pas non plus en vain." Bediüzzaman

            • [^] # Re: sources.list

              Posté par . Évalué à 1 (+0/-0). Dernière modification le 10/08/17 à 13:05.

              tohru@Tohru-Mitsuki:/etc/apt/sources.list.d$ ls -la /etc/apt/sources.list*
              -rw-rw-r-- 1 root root 0 août 10 10:57 /etc/apt/sources.list
              -rw-rw-r-- 1 root root 2903 août 10 00:40 /etc/apt/sources.list.save

              /etc/apt/sources.list.d:
              total 8
              drwxr-xr-x 2 root root 4096 août 10 11:42 .
              drwxr-xr-x 6 root root 4096 août 10 10:57 ..

              Il y a en effet un fichier save. Je l'ouvre et met le contenu dans le fichier normal ?

              Edit : Le fichier save ne contient rien lui non plus.

              • [^] # Re: sources.list

                Posté par . Évalué à 1 (+0/-0). Dernière modification le 10/08/17 à 13:11.

                fait:
                rm /etc/apt/sources.list
                mv /etc/apt/sources.list.save /etc/apt/sources.list

                Envoi le nouveau contenu du sources.list ici, mais je penses que tu peux quand même poursuivre (sauf si tu veux pas prendre risque, on sait jamais):

                Fait un:
                sudo apt-get update

                S'il y a des mise à jours etc tu les fais, un bon redémarrage (pas toujours nécessaire mais vaut mieux pour ton cas).

                Puis faire directement le script d'installation en commençant par sudo, sans faire la deuxième manipulation (dkms) (sauf si l'installateur refait la même erreur).

                "Comme ta création n’est pas en vain, la création de ces événements n’est pas non plus en vain." Bediüzzaman

                • [^] # Re: sources.list

                  Posté par . Évalué à 1 (+0/-0). Dernière modification le 10/08/17 à 13:17.

                  Contenu du nouveau fichier :
                  ```
                  #deb cdrom:[Ubuntu 16.04.3 LTS Xenial Xerus - Release amd64 (20170801)]/ xenial main restricted

                  # See http://help.ubuntu.com/community/UpgradeNotes for how to upgrade to
                  # newer versions of the distribution.
                  deb http://fr.archive.ubuntu.com/ubuntu/ xenial main restricted
                  # deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial main restricted
                  
                  ## Major bug fix updates produced after the final release of the
                  ## distribution.
                  deb http://fr.archive.ubuntu.com/ubuntu/ xenial-updates main restricted
                  # deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial-updates main restricted
                  
                  ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu
                  ## team. Also, please note that software in universe WILL NOT receive any
                  ## review or updates from the Ubuntu security team.
                  deb http://fr.archive.ubuntu.com/ubuntu/ xenial universe
                  # deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial universe
                  deb http://fr.archive.ubuntu.com/ubuntu/ xenial-updates universe
                  # deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial-updates universe
                  
                  ## N.B. software from this repository is ENTIRELY UNSUPPORTED by the Ubuntu 
                  ## team, and may not be under a free licence. Please satisfy yourself as to 
                  ## your rights to use the software. Also, please note that software in 
                  ## multiverse WILL NOT receive any review or updates from the Ubuntu
                  ## security team.
                  deb http://fr.archive.ubuntu.com/ubuntu/ xenial multiverse
                  # deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial multiverse
                  deb http://fr.archive.ubuntu.com/ubuntu/ xenial-updates multiverse
                  # deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial-updates multiverse
                  Voila le contenu du nouveau fichier :
                  
                  ## N.B. software from this repository may not have been tested as
                  ## extensively as that contained in the main release, although it includes
                  ## newer versions of some applications which may provide useful features.
                  ## Also, please note that software in backports WILL NOT receive any review
                  ## or updates from the Ubuntu security team.
                  deb http://fr.archive.ubuntu.com/ubuntu/ xenial-backports main restricted universe multiverse
                  # deb-src http://fr.archive.ubuntu.com/ubuntu/ xenial-backports main restricted universe multiverse
                  
                  ## Uncomment the following two lines to add software from Canonical's
                  ## 'partner' repository.
                  ## This software is not part of Ubuntu, but is offered by Canonical and the
                  ## respective vendors as a service to Ubuntu users.
                  # deb http://archive.canonical.com/ubuntu xenial partner
                  # deb-src http://archive.canonical.com/ubuntu xenial partner
                  
                  deb http://security.ubuntu.com/ubuntu xenial-security main restricted
                  # deb-src http://security.ubuntu.com/ubuntu xenial-security main restricted
                  deb http://security.ubuntu.com/ubuntu xenial-security universe
                  # deb-src http://security.ubuntu.com/ubuntu xenial-security universe
                  deb http://security.ubuntu.com/ubuntu xenial-security multiverse
                  # deb-src http://security.ubuntu.com/ubuntu xenial-security multiverse
                  
                  • [^] # Re: sources.list

                    Posté par . Évalué à 1 (+0/-0). Dernière modification le 10/08/17 à 13:18.

                    Oui c'est bon, tu fais les deux premières commande de mon message dessus, puis sudo apt-get update, sudo apt-get upgrade, s'il y a des upgrades tu les fais puis reboot et tu lances "sudo xxxTon_install_machin_amd" ce script d'installateur installera désormais les paquets requis vu que tu lances avec sudo et que ton sources.list est rempli.

                    "Comme ta création n’est pas en vain, la création de ces événements n’est pas non plus en vain." Bediüzzaman

                • [^] # Re: sources.list

                  Posté par . Évalué à 2 (+0/-0).

                  Cool, tu as fini le debrief.

                  Ceci dit, je suis quand même intrigué, j'aurai aimé savoir ce qui a fait un backup du fichier de sources pour le remplacer par un fichier vide… le fait de devoir passer par une commande qui ne viens pas du dépôt ubuntu ne me semble pas logique, en fait.

                  Normalement il devrait y avoir des paquets xserver-xorg-video-*, le * étant remplacé par le nom du pilote (probablement radeon). Je serais (extrêmement) surpris que Ubuntu n'ait pas ça. Quant à savoir lequel installer, personnellement je dirais d'utiliser la commande aptitude et d'aller lire la description des paquets dont le nom commence par xserver-xorg-video, tout en sachant qu'il existe des pilotes génériques qui ne marchent pas trop mal (enfin, ils permettent d'utiliser le système quoi… mais c'est sûr que pas d'accél graphique).

                  • [^] # Re: sources.list

                    Posté par . Évalué à 1 (+0/-0).

                    Oui je me suis renseigné par rapport aux pilotes justement et j'ai vu qu'il y en avait de base sur ubuntu, cependant ils fonctionne mais mal, j'ai des résolution différentes a chaque allumage, un coup celle de base en 2K, ensuite j'ai du 1024x900 c'est très étrange.

                    Donc, apres l'installation du pilote j'ai reboot, normal, je n'arrive plus a me connecter à ma session, je rentre le mdp, et je suis renvoyé sur l'écran de session de début, j'ai essayé le mode invité, rien n'y fait.
                    Je ne sais pas si c'est moi qui m'y prend mal ou si je n'ai vraiment pas de chance. S'il n'y a pas de solution ce n'est pas grave je recommencerai mon installation a partir de 0 ahaha je ne suis plus a ca pret.

                    • [^] # Re: sources.list

                      Posté par . Évalué à 2 (+0/-0).

                      Le pilote proprio d'amd n'a pas une super réputation, je ne sais pas si c'est avéré ou pas. Concernant ce point, je crains de ne pas pouvoir t'aider, mes GPUs sont nvidia (ou intel) et je n'ai jamais eu de problèmes genre résolution qui change selon le reboot…

                      Tenter une réinstall ne me semble pas déconnant, compte tenu du fait que, à un moment ou un autre, quelque chose à dégommé un fichier clé du système. Ce quelque chose à peut-être fait d'autres dégâts ailleurs… et même pour quelqu'un qui connaît bien sa distrib, refaire ou vérifier un /etc est super dur.

                      • [^] # Re: sources.list

                        Posté par . Évalué à 1 (+0/-0).

                        Ok, bon je vais pas m’embêter alors… En tout cas merci beaucoup pour ton aide Freem ! :D Peut-être à plus tard :)

                  • [^] # Re: sources.list

                    Posté par . Évalué à 1 (+0/-0).

                    Concernant le backup tu dis vrai, je ne comprends pas trop ce qui s'est passé non plus ! Apres mes compétences en la matière ne sont pas très évoluées.

  • # re

    Posté par . Évalué à 1 (+0/-0). Dernière modification le 10/08/17 à 12:53.

    Je connais pas ubuntu mais je suis utilisateur debian.

    Pour le premier ajoute sudo devant la commande, vu que tu installes un driver il te faudra les droits root.
    Pour la deuxième essaye un sudo apt-get update puis recommence (si ça marche pas, donne le fichier sources.list demander).

    Je te conseille de commencer par le deuxième, s'il réussi (ou pas) tu fais le premier avec sudo (peut-être le script d'installation s'en chargera quand il aura les droits via sudo).

    (ps: tu peux simplement copier/coller les résultats en texte, les images sont que jolie mais pas vraiment necessaire, ça te fera gagner du temps)

    "Comme ta création n’est pas en vain, la création de ces événements n’est pas non plus en vain." Bediüzzaman

    • [^] # Re: re

      Posté par . Évalué à 1 (+0/-0). Dernière modification le 10/08/17 à 12:56.

      J'ai deja essayé en ajoutant sudo, rien y fait :/ En fait, après le lancement du script Ubuntu demande le mot de passe su.

      Comme dit au dessus, il n'y a rien dans le fichier source.list

      D'accord pour les images au temps pour moi, je débute je débute :D

  • # Pas besoin d'AMDGPU-PRO

    Posté par . Évalué à 3 (+1/-0). Dernière modification le 10/08/17 à 17:06.

    Ubuntu 16.04.3 contient un nouveau noyau, et le pilote propriétaire (AMDGPU-PRO) n'est pas encore compatible.

    Ceci dit, as-tu vraiment besoin du pilote propriétaire ? Car par défaut le pilote libre prends en charge complètement ta carte graphique (sauf pour l'audio via HDMI).

    • [^] # Re: Pas besoin d'AMDGPU-PRO

      Posté par . Évalué à 1 (+0/-0). Dernière modification le 11/08/17 à 15:21.

      En fait oui, ce n'est pas que le pilote libre me déplaît, au contraire je me fiche un peu de tourner sur une résolution / IPS plus basse…. Mais c'est que j'ai une sorte de bug d'affichage avec ce pilote libre, à chaque rafraîchissement mon écran affiche mal l'image. L'image est décalée par endroit, j'ai des lignes de pixels vertes, rouges, bleues. J'ai même peur pour ma carte graphique et mes écrans.

      Je vais attendre que le pilote libre sois compatible ou qu'AMD sorte un nouveau pilote proprio.
      Ou tout simplement revenir en 16.04.2.

      • [^] # Re: Pas besoin d'AMDGPU-PRO

        Posté par . Évalué à 2 (+1/-0).

        Quel pilote est sensé gérer ta carte graphique dans Xorg.conf ? est-ce que tu as aussi des artefacts en console tty, sur l'écran du gestionnaire de session ou seulement une fois arrivé sur le bureau ? est-ce que libgl-mesa et ses potes sont bien installées ? est-ce que ça bug aussi sur la session live de ton image d'installation ? est-ce que tu as tenté de résoudre le problème dans les paramètres d'affichage ? est-ce que tu es allé voir si personne d'autre n'avait rencontré ce problème avec ce modèle de carte graphique ou d'écran ?

        Le pilote amdgpu libre est fait par AMD donc il est compatible. C'est pas la dernière Vega que tu as donc c'est pris en charge correctement. amdgpu c'est la brique de base inclue dans amdgpu-pro donc le pilote proprio n'y changera sûrement rien.

        Revenir à 16.04.2 ça va être compliqué et inutile puisque le système va trouver les mises à jour et te proposer de les installer. Rester sur une version qui n'est plus maintenu est la pire solution possible car comme toute LTS seules la 16.04 de base, avec uniquement les MÀJ de sécurité, et la 16.04(.3) backport, avec des nouvelles versions de logiciels, sont maintenues.

        • [^] # Re: Pas besoin d'AMDGPU-PRO

          Posté par . Évalué à 1 (+0/-0).

          Voilà des questions auxquelles je en saurais répondre…. Je suis novice en la matière je n'ai fait que du réseau jusqu’à présent dans mes études.

          En gros, le bug se produit quand j'ouvre une fenêtre, par exemple le menu applications, ou l'explorateur de fichier etc.. Cela se produit aussi sur le Live de iso oui. Quand tu dis paramètres d'affichage, on est d'accord que c'est dans l'application réglages --> Paramètres d'affichage ? Si oui, j'ai tenté, Il prend la résolution d'un écran (2560x1440) et l'autre qui a la même résolution, il ne me trouve pas la résolution en général, ça dépend des fois ><
          J'ai cherché sur le net, j'ai pas trouvé grand chose d'ou ma venu sur ce forum, la plupart je me débrouille tout seul en bidouillant et en cherchant pendant de longues heures. Mais laaaa… J'avoue être allé au bout de mes idées pour résoudre tout cela :/

          Donc pas de retour, aucun soucis !

          • [^] # Re: Pas besoin d'AMDGPU-PRO

            Posté par . Évalué à 2 (+0/-0).

            en console tty,

            Les TTY sont les consoles qui permettent de communiquer avec Linux. Par habitude, on distingue les TTY de l'affichage graphique (je ne suis pas sûr que ce soit vraiment pertinent, honnêtement, mais ça à le mérite d'être simple et clair pour tout le monde à priori). Les terminaux, shells, mode texte, etc… se situant traditionnellement (depuis systemd certaines distribs ont changé ça) sur les TTY 1 à 6, les serveurs graphiques sur les TTY 7 et 8.

            Pour basculer d'un TTY à l'autre, il faut appuyer sur CTRL+ALT+Fx, ou x est le numéro du TTY cible.

            sur l'écran du gestionnaire de session

            C'est l'affichage sur lequel tu entres ton login et ton password.

            est-ce que libgl-mesa

            Soit tu passes par je ne sais plus quelle sous commande d'apt, soit tu passes par aptitude et tu cherches à la main dans une interface ncurses (il faut juste taper «aptitude» dans un terminal, sans paramètres).

      • [^] # Re: Pas besoin d'AMDGPU-PRO

        Posté par . Évalué à 2 (+0/-0).

        Si vraiment l'accel materielle et une bonne resolution ne sont pas exigees… bon, j'insiste sur le vraiment hein, il reste le pilote vesa… je cite (ce qui est penible via un tel):

        pilote permettant […] d'utiliser l'interface VESA standard qui fonctionne, mais sans acceleration matérielle, avec toutes les cartes vidéos. Son utilisation est déconseillée, sauf en cas de problèmes avec les pilotes adaptés à la carte vidéo, car ses performances sont plutôt mauvaises.

        Je ne l'ai pas mentionné plus tôt, pour des raisons j'espère évidentes. En tout cas je l'installe toujours sur mes machines graphiques, au cas ou, mais n'ai jamais eu a l'utiliser…
        Pour l'utiliser… le plus simple c'est d'enlever tous les autres, le plus intelligent/pointu c'est de configurer Xorg pour l'utiliser: je ne sais pas faire (je garde juste l'option de ne garder que lui, j'ai pleins de trucs plus utiles a faire qu'apprendre a maitriser xorg. Je ferai quand je n'aurai pas le choix xD)

Envoyer un commentaire

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.