Forum Linux.débutant [résolu] écran sur VGA sans le bureau ?

Posté par . Licence CC by-sa
Tags : aucun
1
6
fév.
2018

Bonjour,
Je suis sous Linux Mint 17.3 sur un portable petit écran (15'). Le rétro éclairage de la dalle ne fonctionnant plus, je veux brancher un écran sur la prise VGA.
Le bureau ne s'affiche pas. J'ai bien l'écran avec l'image de fond d'écran mais pas les fichiers et dossiers qui sont sur mon bureau, ni la barre de tâche en bas (Menu, etc….)
Par contre si je fais clic droit sur l'écran, le menu contextuel du bureau s'ouvre et je peux créer un nouveau dossier (par exemple) qui s'affiche bien sur l'écran.
Pour éteindre l'ordi, je ne peux évidemment pas passer par Menu. En faisant CTRL+Maj+Suppr, s'affiche sur l'écran la fenêtre pour Éteindre, mettre en veille etc.
Donc, il semble que ce soit une question d'affichage puisque certaines fenêtres s'affichent.
Comment puis-je résoudre ce pb d'affichage.

J'espère avoir été clair. En vous remerciant.
Aristée

  • # double écran

    Posté par (page perso) . Évalué à 6.

    Vous devez être en mode double écran (mais pas en écran jumeau). Donc il faut aller voir dans le paramétrage du partage d'écran, si vous y avez accès, sinon, en ligne de commande je ne sais pas.

    • [^] # Re: double écran

      Posté par . Évalué à 2. Dernière modification le 06/02/18 à 15:27.

      sinon, en ligne de commande je ne sais pas.

      Pour les utilisateurs de Xorg: xrandr | grep connected donne la liste des écrans connectés.
      De là, on récupère l'écran qui nous intéresse (le nom dépend du pilote utilisé et du matériel. Il devrait être stable d'un démarrage à l'autre, mais sur Jessie avec le pilote AMD c'était semi-aléatoire) en fonction de ce que l'on veut faire.

      Puis, 3 solutions (le "" représente le nom trouvé en 1ère ligne:

      • on éteint l'écran qui ne nous intéresse pas: xrandr --output <ECRAN> --off
      • on passe l'écran que l'on veut utiliser avec le bureau en écran primaire: xrandr --output <ECRAN> --off
      • on fait se chevaucher les écrans, avec le paramètre --pos

      Bien entendu, il faut le faire à chaque démarrage, ou alors le lancer au début de la session Xorg, ce qui se fait différemment en fonction du bureau utilisé. Pour ceux qui n'utilisent pas de bureaux monolithiques, il ajouter cette ligne dans le fichier $HOME/.xinitrc, avant la dernière ligne (mais ceux qui utilisent ce genre de système le savent déjà :)).

      Je sais, ça ne sera sans doute pas ce qui sera utilisé par l'auteur, mais ça peut servir à quelqu'un d'autre, on sait jamais.

      • [^] # Re: double écran

        Posté par . Évalué à 1.

        Bonjour,

        Merci pour ces informations mais les commandes indiquées pour les deux première solutions sont les mêmes… n'y aurait-il pas une erreur ?

        • [^] # Re: double écran

          Posté par . Évalué à 2.

          Si, en effet, pour la seconde (passer en écran principal) c'est --primary et non --off… désolé.

  • # bureau étendu

    Posté par (page perso) . Évalué à 1.

    Par défaut l'écran se paramètre pour être utilisé en complément du premier. Il est possible de modifier cela dans le menu, ou bien en appuyant sur une touche fonction de l'ordinateur: appuyer en même temps sur la touche [fn] et la touche [F*], qui est différente sur chaque ordinateur (il faut regarder les petits dessins sur les touches, le logo ressemble à un rectangle avec une barre de part et d'autre).
    Cela permet de basculer entre les différent modes (écran unique, mode étendu, écrans clonés…)

    Un LUG en Lorraine : https://enunclic-cappel.fr

    • [^] # Re: bureau étendu

      Posté par . Évalué à 1. Dernière modification le 06/02/18 à 16:29.

      Je suis en mode écran cloné avec "même image sur les écrans" coché.
      J'ai essayé toute les autres config je n'obtiens pas le bureau.
      Note : avec un écran(un seul) ça marche. Mais il ne m'appartient pas. Avec les autres essayés ça ne fonctionne pas.
      Je suis avec Cinnamon.

  • # bureau cloné

    Posté par . Évalué à 3.

    Voilà j'ai trouvé un chemin pour parvenir à cloner les 2 écrans.
    Je rappelle que je ne pouvais pas accéder aux menus car l'écran principale de mon portable est HS. Et sur l'écran branché sur la VGA, je n'obtenais que le logo, sans barre de tâches, sans bureau.

    Il me fallait atteindre les Paramètres système, puis l'Affichage.

    Sur l'écran additionnel, où rien n'apparaissait, j'ai fait un clic gauche et dans le menu contextuel j'ai opté pour "Modifier l'arrière plan du bureau" afin d'atteindre la fenêtre des paramètres.
    A partir de là, en cliquant sur la flèche noire en haut, j'arrive sur la fenêtre "Paramètres système", puis en déroulant le chapitre "Matériel" et clic sur "Affichage".
    Là je coche "même image sur tous les écrans", puis sur "Appliquer".

    Et voilà, tout s'affiche sur l'écran additionnel.

    Merci à tous ceux qui se sont penchés sur mon pb.

  • # réparation

    Posté par . Évalué à 1. Dernière modification le 06/02/18 à 17:09.

    Ça ne répond pas à ta question mais tu peux certainement remplacer l'écran ou l'inverter. En recherchant avec le nom du modèle tu trouvera la bonne pièce. Ça demande de la patience et de la mesure pour tout démonter mais c'est faisable avec seulement un set de tournevis et un outil fin et rigide en plastique pour déclipser l'habillage (un médiator de guitare par exemple).

    Au pire, ça te permettrait de débrancher physiquement l'écran inutile (si le BIOS/UEFI s'affiche bien sur l'écran externe).
    Aussi, c'est toujours bon de faire régulièrement (annuel/semestriel) un dépoussiérage du radiateur et du ventilateur.

    Enfin, vu que ce n'est que le rétro-éclairage, il serait possible de réparer l'écran mais ça demande des compétences en électronique et du matériel de soudure.

    • [^] # Re: réparation

      Posté par . Évalué à 1.

      @ xev
      Ben ça fait plus d'un an que je recherche une dalle pour ce portable. Mais pas trouvé. C'est un vieux ThinkPad modèle R400.
      La dalle est démontée depuis longtemps pour avoir les réf. du modèle. Pas de difficulté particulière.
      Mais pour ce modèle j'ai du mal à trouver une dalle de remplacement.
      Je suis intéressé par les modalités de réparation du rétro-éclairage dont tu parles. As-tu des liens, ou une vidéo, ou une fiche technique à proposer.
      Ou bien, éventuellement, une dalle d'un modèle proche qui pourrait remplacer l'actuelle.
      Merci

      • [^] # Re: réparation

        Posté par . Évalué à 1.

        Ça se répare mais c'est compliqué et pas garanti. Un fusible qui crame c'est qu'il y a potentiellement un problème plus grave en aval. Et en plus on est avec des composants de surface minuscules donc pas forcément facile pour mesurer et souder.

        Sinon j'ai trouvé ce qu'il te faudrait sur Ebay. Avec le nom du modèle, on se rend compte que l'écran possède bien une carte inverter (de référence 41w1478 mais vérifie sur ton modèle) pour alimenter le rétroéclairage. Ouf, même pas besoin de remplacer toute la dalle, seulement la partie qui ne fonctionne pas. Et le prix est dérisoire. :)

        • [^] # Re: réparation

          Posté par . Évalué à 2.

          Merci xev pour le lien et la recherche.
          Je vais opter pour l'achat d'une carte inverter, vu le prix ça ne mange pas de pain. Il y a le modèle qui correspond.
          Merci encore. Comme ça vient de Chine, faut compter un mois avant réception. Je ne pourrai donner des nouvelles que passé ce délai.
          Aristee

          • [^] # Re: réparation

            Posté par . Évalué à 2.

            Je remonte ce post pour donner suite :
            Commandé la carte Inverter comme prévu. Reçue de Thaïlande et installée sur le ThinkPad R400 ………… elle a tenu 10 minutes.
            Puis c'est redevenu comme expliqué au début de ce post, à savoir, affichage sur un écran extérieur en VGA ok, et écran du portable noir MAIS on devine l'affichage sur la dalle qui n'est plus éclairée.

            D'après vous d'où peut venir que l'Inverter grille comme ça ?
            Bon si nous ne trouvons pas, je n'aurai perdu que 1,86 euros ! Mais je serai toujours sous écran noir.

            Merci de votre rétroéclairage :=))
            Aristée

            • [^] # Re: réparation

              Posté par . Évalué à 2.

              Forcément ça pouvait pas être aussi simple :/
              Va falloir que tu sortes le multimètre pour établir un véritable diagnostic et ça va te demander quelques compétences en électronique.

              Pour moi c'est très certainement un problème en aval avec le néon qui déconne et qui grille l'inverter (après je ne suis pas expert non plus, ).
              Par précaution vérifie si en amont il n'y a pas un problème avec la nappe, la soudure de la fiche ou la tension d'alimentation en sortie de carte-mère (repère bien à chaque fois où est la masse, c'est la référence).
              Tu peux aussi tester le fusible de l'inverter et sa tension de sortie (attention c'est du 300-600V AC donc ça pique) mais il y a de fortes chances qu'il ait cramé et que même un remplacement de fusible ne lui redonnera pas une seconde vie.

              Tu peux acheter un néon de rechange (ça devrait se trouver en cherchant backlight CCFL bulb ) mais c'est compliqué à remplacer car il faut faire gaffe à pas endommager le LCD en le démontant (regarde des tuto en vidéo, et tente si tu sens que c'est dans tes cordes). La plupart des gens ne s'embètent pas et remplacent l'ensemble complet dalle+inverter mais oui c'est pas donné. Et à mon humble avis, quitte à démonter la dalle autant essayer d'améliorer l'autonomie en trouvant un kit de rétro-éclairage LED.

              • [^] # Re: réparation

                Posté par . Évalué à 1.

                OK, xev. J'ai bien compris.
                Je vais voir si mon niveau électronique me permet ces manips.
                Sinon, je pense que je vais opter pour un kit dalle + inverter. J'ai vu sur le lien, que tu m'avais déjà donné, que le budget tournerait autour des 60 à 70 euros.
                Je te tiens au courant, bien sûr.
                Merci.
                Aristée

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.