Forum Linux.général Comment charger alsactl au démarrage

Posté par .
Tags : aucun
1
6
oct.
2010
Bonjour,
je veux désactiver les bips système qui apparaissent pour diverses raison. J'ai donc lancé "alsamixer" et mis sur muet le bip système. Jusque là tout va bien puisque je n'ai plus de bip. Cependant, pour le moment je suis obligé de recommencer ma manip après chaque redémarrage. J'ai vu que mes réglages étaient enregistrés dans alsactl. Après avoir mis le bip en muet, j'enregistre ma configuration en tapant en root
alsactl store

J'ai vu que pour restaurer ce réglage, il fallait lancer la commande
alsactl restore

Maintenant je voudrais savoir dans quel fichier est ce que je met cette commande pour qu'elle soit lancer au démarrage.
Je suis sous Mandriva 2010.1 si ça peut aider.
Merci d'avance
  • # Dans la boite.

    Posté par . Évalué à 1.

    Normalement y'a des scripts qui vont bien fournis avec alsa dans ta distrib, ça ce trouve dans /etc/init.d et c'est linké vers /etc/rc"runlevel".d
    • [^] # Re: Dans la boite.

      Posté par . Évalué à 2.

      Sur les distrib de type redhat, ya un fichier /etc/rc.local qui est là exactement pour ça: il est appelé en dernier, et quel que soit le runlevel.

      Sinon, moi j'ai juste un 'xset b off' dans mon script d'init de session X.
      En fait, mon problème c'est plutôt l'inverse: ya de plus en plus de distrib où c'est difficile d'avoir le bip; Et alors ping -a ne sert plus à rien ...
    • [^] # Re: Dans la boite.

      Posté par . Évalué à 1.

      J'ai ajouté cette ligne
      alsactl restore
      dans rc.local mais ça n'a rien changé. Vous savez pourquoi ?
      • [^] # Re: Dans la boite.

        Posté par . Évalué à 1.

        une question de path surement.
      • [^] # Re: Dans la boite.

        Posté par . Évalué à 2.

        sur ma distrib (derivé de DEbian et sud africaine) le rc.local est en fait lu quand je quitte l'interface graphique pour arreté la machine :(

        du coup je prefere me faire un script à moi, que j'ajoute dans le bon niveau d'execution (RC)
  • # Blacklist

    Posté par (page perso) . Évalué à 3.

    Personnellement, je blaklist le module pcspkr, mais c'est peut-être un peu trop bourrin... En même temps, je ne savais même pas qu'alsa pouvait s'en occuper ;)

    Sous ma Debian, il suffit d'ajouter la ligne:


    blacklist pcspkr


    dans un des fichiers sous /etc/modprobe.d (le plus indiqué étant blacklist.conf :D)
    • [^] # Re: Blacklist

      Posté par . Évalué à 3.

      voire dans un fichier dedié au blacklist personnel
      /etc/modprobe.d/myblacklist.conf

      histoire de ne pas les perdre quand une mise à jour remplace le fichier blacklist par defaut
    • [^] # Re: Blacklist

      Posté par . Évalué à 1.

      C'est assez intéressant car dans modprobe.d il y a un fichier blacklist-mdv qui contient déjà "blacklist pcspkr". Donc si j'ai bien compris il devrait déjà être désactivé.
      C'est très étrange.
      • [^] # Re: Blacklist

        Posté par . Évalué à 1.

        dans mon modprobe.d (peut être modifié par la manip que j'ai décrite plus bas)
        j'ai une ligne supplémentaire propre à alsa d'après la description : blacklist snd-pcsp
        L'as tu aussi ?
        # disable PC speaker by default
        # pcspkr is the standard driver, while snd-pcsp is the ALSA driver
        blacklist pcspkr
        blacklist snd-pcsp
  • # pulseaudio ?

    Posté par . Évalué à 2.

    Sous Mandriva 2010, j'ai réglé ce problème ainsi :

    0 - pulseaudio empêche le réglage fin du mixeur (du moins c'est ce que j'en ai déduit, dans kmix (kde), je n'ai plus que deux onglets : périphériques de lecture et périphériques de capture)
    1 - désactivation de pulseaudio dans le MCC
    2 - déconnexion - reconnexion
    3 - ouverture du mixeur kmix : clic droit sur l'applet dans le systray -> (sans pulseaudio, on retrouve les différents onglets pour les canaux (correspondants à alsamixer)
    4 - je passe bip système à muet
    5 - réactivation de pulseaudio dans le MCC

    et cela persiste ensuite lors des redémarrages.

    Cela marche peut être aussi directement, sans passer pas kmix, dans alsamixer.
    En espérant aider, je n'ai par contre aucune idée quant aux fichiers modifiés par cette bidouille.
    • [^] # Re: pulseaudio ?

      Posté par . Évalué à 1.

      En fait j'ai essayé mais après une simple déconnexion, j'ai toujours les mêmes choix dans kmix qu'avec pulseaudio. Je vais essayer de redémarrer complètement voir s'il y a un changement.
      • [^] # Re: pulseaudio ?

        Posté par . Évalué à 1.

        Hum

        J'ai rédigé la "procédure" de tête, je ne me souviens plus des détails.
        Comme j'accusais à l'époque pulseaudio de tous les mots, j'avais trouvé ce truc par hasard.
        Depuis, le réglage étant resté lors de l'update en 2010.1, je n'ai pas eu à le refaire.
        J'espère que c'est toujours valide avec la dernière version de Mandriva.
        Peut être que j'ai redémarré complètement moi aussi.
        Tiens moi au courant, au pire je re-testerais sur ma machine.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.