Forum Linux.général Impossible de rejoindre un Active Directory SAMBA

Posté par . Licence CC by-sa
Tags : aucun
0
7
avr.
2017

Bonjour,

Je fais appel a vous, sur un sujet qui me bloque depuis quelque temps….

J'ai un synology, avec un package beta: Active Directory Server (beta…) Version 4.4.5-0032 (samba: v4.4.5)

Si je prends un Windows 7 ou 10, j'arrive a rejoindre le domaine.

Par contre, sur plusieurs systèmes Linux, enfin sur tous, je n'arrive pas.
Ce qui est paradoxal, c'est que synology utilise…. SAMBA!

Pour les verions utiliser: archlinux samba 4.5.7 et ubuntu lts 16.04 samba 4.3.11-Ubunut

labclt# net join -U administrator%password42
kerberos_kinit_password administrator@HC.LABEXEMPLE.FR failed: Additional pre-authentication required
Failed to join domain: failed to connect to AD: Additional pre-authentication required
ADS join did not work, falling back to RPC...
kerberos_kinit_password administrator@HC.LABEXEMPLE.FR failed: Additional pre-authentication required
Failed to join domain: failed to connect to AD: Additional pre-authentication required`
labclt#

Avec un mot-de-passe foireux:

labclt# net join -U administrator%password   
Failed to join domain: failed to lookup DC info for domain 'HC.LABEXEMPLE.FR' over rpc: Logon failure
ADS join did not work, falling back to RPC...
Failed to join domain: failed to lookup DC info for domain 'HC' over rpc: Logon failure
labclt#

Bien sûr, kinit fonctionne correctement.
klist retourne bien un ticket valide.

Je peu fournir des log.

Une idée ?

  • # mdp

    Posté par (page perso) . Évalué à 2.

    Le mot de passe contient un caractère accentué ?

    • [^] # Re: mdp

      Posté par . Évalué à 1.

      non, lettre/chiffre uniquement.
      La politique synology réclame [a-z][A-Z][0-9] mini

  • # kerberos ?

    Posté par . Évalué à 2.

    la reponse parle de kerberos,

    sur tes machines linux, tu as configurés les fichiers suivants :
    /etc/samba/smb.conf
    et
    /etc/krb5.conf

    pour pointer ton domaine et ton synology ?

    ensuite si tu as du kerberos, il faut utiliser net ads join -U 'user@domaine%password'

    • [^] # Re: kerberos ?

      Posté par . Évalué à 1.

      Le kinit fonctionne bien,

      le klist affiche correctement le token krb.

      les smb.conf sont bien sur le bon realm et workgroup

      • [^] # Re: kerberos ?

        Posté par . Évalué à 2.

        Hello paipai62,

        as-tu solutionné ton problème ?
        J'ai exactement le même problème pour joindre un samba 4.5.8-Ubuntu avec le samba 4.4.5 de l'active directory server d'un synology.
        Ca fait 2j que je fouille sur les forums et que je test des options ntlm et autre sur les 2 samba sans parvenir à joindre le domaine …

        Merci pour ton aide.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.