Forum Linux.général Problème avec systemd et des partitions chiffrées

Posté par .
Tags :
5
30
juil.
2012

Bonjour,

Utilisateur d'Arch, je suis passé récemment à systemd, et je rencontre des problèmes pour saisir au boot la passphrase nécessaire pour monter mon /home chiffré et le swap

Je n'ai pas le temps de saisir toute la passphrase, systemd continues à booter sans que j'ai le temps de valider.

Est ce qu'il y a un moyen de forcer systemd à attendre que j'ai saisi la passphrase avant de poursuivre la phrase de boot ?

Pour info, le contenu de mon fichier /etc/crypttab :

    swap           /dev/sda2        none    timeout=1h
    home           /dev/sda9        none    timeout=1h

Et mon /etc/fstab :

# 
# /etc/fstab: static file system information
#
# <file system> <dir>   <type>  <options>       <dump>  <pass>

/dev/mapper/home /home ext3 defaults 0 1
/dev/mapper/swap swap swap defaults 0 0
UUID=0b408d8d-176a-4125-963d-3336c1122623 /var ext4 defaults 0 1
UUID=504126a5-5f6a-4241-b8e8-2dc7f43bf4eb /boot ext2 defaults 0 1
UUID=74682c6c-2144-4f13-ad15-fad581855295 /tmp ext4 defaults 0 1
UUID=869039e9-ade7-49b7-a7b1-23c25393edb4 / ext4 defaults 0 1
UUID=c2513c12-0df0-4740-9989-9a796bb97eae /usr ext4 defaults 0 1

Merci d'avance.

  • # Ah ça...

    Posté par . Évalué à 3.

    Je n'ai pas le temps de saisir toute la passphrase, systemd continues à booter sans que j'ai le temps de valider.

    On vous l'avait pourtant bien dit que systemd c'était rapide !

    Blague à part je suis désolé de ne pas être en mesure de t'aider. Il ne fait aucun doute que d'autres personnes sur ce site pourront.

  • # Fedora

    Posté par . Évalué à 4.

    Testé à l'instant avec Fedora 17, systemd bloque bien sur la demande du mot de passe. Tu utilises quelle version de systemd ?

    • [^] # Re: Fedora

      Posté par . Évalué à 0.

      La version fournie par Arch, apparemment il s'agit de la 187-4 :
      http://www.archlinux.org/packages/core/x86_64/systemd/

      Elle utilise ce PKGBUILD

      • [^] # Re: Fedora

        Posté par . Évalué à 1.

        Tu as fait une configuration spécifique ou il s'arrête automatiquement pour demander la passphrase dès qu'il détecte une partition chiffrée, sans rien faire de particulier ?

        • [^] # Re: Fedora

          Posté par . Évalué à 3.

          Bon, j'ai trouvé mon erreur : c'est la ligne suivante, planquée à la fin de mon fstab qui faisait planter le montage des fs (pour cause de réseau non démarré, du coup ça partait dans une boucle d'erreur infinie) :

          //192.168.0.2/media /media/nas cifs defaults,credentials=/etc/smb.credentials,ro,gid=91,uid=1000,iocharset=utf8,file_mode=0444,dir_mode=0555 0 0
          
          

          J'ai réglé le problème en utilisant automount : il suffit d'ajouter les deux options nomount,x-systemd.automount :

          //192.168.0.2/media /media/nas cifs defaults,credentials=/etc/smb.credentials,ro,gid=91,uid=1000,iocharset=utf8,file_mode=0444,dir_mode=0555,x-systemd.automount 0 0
          
          

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.