Forum Linux.gentoo Monter clef usb avec pcmanfm

Posté par (page perso) .
Tags : aucun
0
29
août
2011

Bonsoir.

Je cherche à pouvoir monter avec pcmanfm mon disque dur externe usb. Lorsque que je le fait en utilisateur j'ai une popup qui me dit:
Erreur
Not Authorized

(J'ai essayé avec root ça fonctionne, oui c'est mal de lancer pcmanfm en root mais c'était pour voir).

Aprés quelques recherche, j'ai ajouté un fichier plka, tel que:

$cat /etc/polkit-1/localauthority/50-local.d/10-filesystem-mount.pkla

[Mount external devices]
Identity=unix-group:users
Action=org.freedesktop.udisks.filesystem-mount
ResultAny=no
ResultInactive=no
ResultActive=yes

Pour les démons en question (je suppose que c'est ceux la):
[lutin@siberie ~]$ ps -aef|grep dbus
101 1842 1 0 15:48 ? 00:00:00 /usr/bin/dbus-daemon --system
lutin 2175 1 0 15:49 ? 00:00:00 dbus-launch --autolaunch=9c32d5e261bcfd8c74fa793d0000000f --binary-syntax --close-stderr
lutin 2176 1 0 15:49 ? 00:00:00 /usr/bin/dbus-daemon --fork --print-pid 5 --print-address 7 --session
[lutin@siberie ~]$ ps -aef|grep udisk
root 2183 1 0 15:49 ? 00:00:01 /usr/libexec/udisks-daemon
root 2184 2183 0 15:49 ? 00:00:00 udisks-daemon: polling /dev/sr0
lutin 9599 9590 0 19:36 pts/1 00:00:00 grep --colour=auto udisk

Auriez vous une idée ?

  • # udev ou fstab

    Posté par . Évalué à 3.

    au choix, la plus facile :
    - faire une ligne dans fstab avec l'UUID du disque, un point de montage sur lequel l'utilisateur a les droits, et les bonnes options.
    OU
    - faire une regle avec udev

    • [^] # Re: udev ou fstab

      Posté par (page perso) . Évalué à 1.

      Pour la ligne dans le fstab non, parce que je ne met pas toujours la même clef usb, c'est n'est pas l'usage que je cherche.
      Je vais fouiller pour les règles udev, merci.

  • # org.freedesktop.udisks.policy

    Posté par . Évalué à 0.

    Peut être modifier le contenu de
    /usr/share/polkit-1/actions/org.freedesktop.udisks.policy ?

    Voir http://romain.therrat.fr/gnome-disque-usb-not-authorized/396/

  • # J'étais pas loin en fait

    Posté par (page perso) . Évalué à 4.

    Trouvé, ça servira peut être:
    cat /etc/polkit-1/localauthority/50-local.d/50-local.pkla
    [Automount]
    Identity=unix-group:plugdev
    Action=org.freedesktop.udisks.drive-eject
    ResultAny=yes
    ResultInactive=yes
    ResultActive=yes

    [Automount]
    Identity=unix-group:plugdev
    Action=org.freedesktop.udisks.drive-detach
    ResultAny=yes
    ResultInactive=yes
    ResultActive=yes

    [Automount]
    Identity=unix-group:plugdev
    Action=org.freedesktop.udisks.filesystem-mount
    ResultAny=yes
    ResultInactive=yes
    ResultActive=yes

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.