Suivi - Autres Pas de colorisation du code après validation

#167 Posté par . État de l'entrée : corrigée
Tags : aucun
1
22
fév.
2011

Si ce bug est bien réel, le code suivant est colorisé lors de la prévisualisation mais pas quand je validerai.

public class Hello {
  public static main(String[] args) {
    System.out.println("Hello!")
  }
}
  • # Complexe

    Posté par (page perso) . Évalué à 2 (+0/-0).

    Le bug n'a pas l'air réel.

    public class Hello {
      public static main(String[] args) {
        System.out.println("Hello!")
      }
    }

    Par contre, je vois bien la coloration syntaxique du code ci-dessus pendant la prévisualisation.

    « Rappelez-vous toujours que si la Gestapo avait les moyens de vous faire parler, les politiciens ont, eux, les moyens de vous faire taire. » Coluche

    • [^] # Re: Complexe

      Posté par . Évalué à 1 (+0/-0).

      public class Hello {
        public static main(String[] args) {
          System.out.println("Hello!")
        }
      }

      Titre de l'image

    • [^] # Re: Complexe

      Posté par . Évalué à 1 (+0/-0).

      C'est bien ça le problème. la coloration est présente lors de la prévisualisation mais pas lors de la publication.

      • [^] # Re: Complexe

        Posté par . Évalué à 1 (+0/-0).

        public class Hello {
          public static main(String[] args) {
            System.out.println("Hello!")
          }
        }

        Test en utilisant java au lieu de ruby. (Je sais, ça ne change pas grand chose mais bon...)

      • [^] # Re: Complexe

        Posté par . Évalué à 1 (+0/-0).

        On est bien d'accord.

        Je me suis dit qu'une image valait mieux que de long discours...

        Ce bug me rappelle un bug de la version précédente de dlfp où quand on saisissait des balises dans un commentaire elles apparaîssaient correctement dans la prévisualisation avant d'être transformée en "& l t ;" ....

      • [^] # Re: Complexe

        Posté par (page perso) . Évalué à 2 (+0/-0).

        Désolé, j'ai lu le bug à l'envers, je ne sais pas pourquoi.

        « Rappelez-vous toujours que si la Gestapo avait les moyens de vous faire parler, les politiciens ont, eux, les moyens de vous faire taire. » Coluche

  • # Centrage

    Posté par . Évalué à 1 (+0/-0).

    J'ajoute aussi que ce bug intervient lorsqu'il s'agit de centrer un paragraphe.

    Ce paragraphe est centré en prévisualisation mais pas lors de la publication.

  • # Corrigé

    Posté par (page perso) . Évalué à 2 (+0/-0).

    Voilà, ça devrait mieux marcher maintenant.

    • [^] # Re: Corrigé

      Posté par . Évalué à 1 (+0/-0).

      Il faut attendre un certain temps ? Parce que je ne vois pas de différences par exemple sur la page d'aide à l'édition. Je l'ai modifiée puis validée après avoir vu ton commentaire pensant que c'était peut-être une étape nécessaire mais pas de changements.

      J'utilise bien la CSS par défaut et en ajoutant la section sur les tableaux, j'ai le même problème : OK en prévisualisation mais pas en publication.

      • [^] # Re: Corrigé

        Posté par (page perso) . Évalué à 2 (+0/-0).

        Il faut attendre un certain temps ?

        Oui, quelques minutes. Je commente et ferme les bugs au fur et à mesure que je les corrige, mais je ne déploie pas aussi souvent. http://linuxfr.org/changelog permet de voir les derniers commits déployés.

        Pour ce bug en particulier, maintenant, ça devrait être vraiment corrigé (le correctif est déployé).

Envoyer un commentaire

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.