Journal Pour les cartes graphiques gen9+, vous aurez OpenGL 4.5 et OpenGL ES3.2

Posté par . Licence CC by-sa
20
22
sept.
2016

Le site Mesamatrix vient d'annoncer que c'est Intel qui est le premier à proposer un pilote libre exploitant la totalité de l'OpenGL et de l'OpenGL ES. Il reste encore des libellés mais Kronos ne les a mis dans aucune version pour l'instant (OpenGL 4.6???)

Par contre, il vous faudra une carte graphique très récente: une de la 9ème génération:
https://en.wikipedia.org/wiki/List_of_Intel_graphics_processing_units#Ninth_generation
Soit Skylake sorti en août 2015 et Goldmont (Bizarre Wikipédia les déclare toutes les 2 comme OpenGL 4.4, cela doit être le maximum d'OpenGL lors de leur sortie).

La prochaine dépèche sur la prochaine version de Mesa va envoyer du lourd \o/

  • # amdgpu

    Posté par (page perso) . Évalué à 3.

    Il y a quelque chose que je ne comprends pas.
    Sur mesamatrix, pour les cartes amd, il y a r600 et radeonsi.
    Et amdgpu, ca se trouve où?
    Je croyais qua ca rempmaçait le driver radeonsi.
    Quelle version d'opengl est supportée avec les drivers libres si la carte utilise amdgpu?

    • [^] # Re: amdgpu

      Posté par . Évalué à 4.

      Si je comprends bien le pilote noyau est maintenant amdgpu (pas encore pour toutes les révisions de l'architecture GCN mais ça progresse) mais le pilote mesa est identique à radeonsi.

      • [^] # Re: amdgpu

        Posté par (page perso) . Évalué à 5.

        C'est ça, coté mesa, il n'y a qu'un seul et même "pilote", que l'on utilise coté noyau le module radeonsi ou le module amdgpu.

        Quelle version d'opengl est supportée avec les drivers libres si la carte utilise amdgpu?

        La colonne radeonsi de mesamatrix est valable pour toutes les cartes GCN, qu'elles soient pilotées par radeonsi ou par amdgpu. C'est pour ça qu'il n'y a pas besoin de séparer les deux (alors que pour Intel ce serait plus clair). Par contre pour réellelment bénéficier de toutes ces fonctionnalités il faut un LLVM très récent. Un Mesa récent avec un noyau récent et un LLVM ancien genre celui par défaut de ta distro peut t'ammener de sèvères régressions (dans certains cas tu peux même être limité à OpebGL 3.3) !

        Des dépôts comme le PPA Padoka pour Ubuntu fournissent un Mesa servi tout droit du chaudron, compilé ave un LLVM encore chaud. Un vieux noyau peux brider les performances, mais un vieux Mesa ou un vieil LLVM bridera les fonctionnalités.

        ce commentaire est sous licence cc by 4 et précédentes

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.