Forum Linux.debian/ubuntu ALSA HDA Intel Debian Wheezy

Posté par  . Licence CC By‑SA.
Étiquettes : aucune
0
7
mai
2013

Bonjour à tous,

Suite à la mise à jour de Debian sur ma machine principale (de Squeeze vers Wheezy) j'ai le problème suivant : pas de son.

Plus précisément le symptôme suivant :

$ alsamixer 
les commandes de mixage ne peuvent pas être chargés: Argument invalide

J'ai trouvé le contournement suivant, sur un forum d'Archeux (comme quoi…) :

Mettre options snd-hda-intel model=generic dans /etc/modprobe.d/alsa-base.conf

Avec ça j'ai du son mais dans le mixer ALSA je n'y trouve que Master et PCM, rien d'autre.

Le chipset c'est ça :

00:14.2 Audio device: Advanced Micro Devices [AMD] nee ATI SBx00 Azalia (Intel HDA)

Je sens qu'il faut mettre ce qui va bien à la place de « generic » (j'avais du faire un truc similaire pour Squeeze je crois) mais je me perds dans tous les résultats Google sur les problèmes ALSA.

J'espère que certains ici pourront m'indiquer sinon une solution, la bonne méthode pour régler ce genre de problème. Je remarque par exemple qu'il n'y a pas l'air d'y avoir une commande « alsaconf » sous Debian.

Merci pour votre attention.

  • # manque quelque chose.

    Posté par  . Évalué à 0.

    installe alsa-utils et la tu aura alsamixer. ;)

    Merci aux personnes qui mon aidé a trouvé des solutions pour essayer d’écrire sans faute d’orthographe.

    • [^] # Re: manque quelque chose.

      Posté par  . Évalué à 2.

      Il est installé. Comme tu le peux voir alsamixer ne me retourne pas command not found.

      Non, mon problème, je pense, c'est qu'il faut que j'indique précisément mon chipset (et pas generic) dans /etc/modprobe.d/alsa-base.conf

      Je vais encore chercher moi-même, je suis presque sûr d'avoir eu à faire la même chose à l'époque pour Squeeze. Bizarrement lors de l'upgrade il ne m'a pas posé la question pour ce fichier de conf alors qu'il est sensé le faire pour tous les fichiers de configuration qui ont été modifiés localement :\

  • # Arf

    Posté par  . Évalué à 4.

    En fait c'était tout simple :

    options snd-hda-intel model=auto

    • [^] # Re: Arf

      Posté par  . Évalué à 1.

      J'ai la même carte son et j'ai jamais été confronté a ton problème… bizarre.

      Merci aux personnes qui mon aidé a trouvé des solutions pour essayer d’écrire sans faute d’orthographe.

  • # merci de rapporter le bug STP !

    Posté par  . Évalué à 2.

    Comme le dit la maxime bien connue: "pas de bugreport, pas de problème; pas de bugreport, pas de solution".

    Sachant que le paquet pour lequel il faudrait que tu ouvres un bug, c'est le noyau (regarde quel paquet est utilisé pour ton noyau 'dpkg -l |grep linux-image').

    http://www.debian.org/Bugs/Reporting

    Merci d'avance pour les autres utilisateurs :)

    • [^] # Re: merci de rapporter le bug STP !

      Posté par  . Évalué à 2.

      Tu as raison. Mais vu que le problème est réglé et que j'ai donné la solution plus haut, j'espère que ce post sera peut-être déjà utile à d'autres.

      • [^] # Re: merci de rapporter le bug STP !

        Posté par  . Évalué à 1.

        C'est dommage, les pistes que tu as trouvées ne seront accessibles qu'aux utilisateurs francophones, et ne permettront pas de corriger la véritable source du problème .

        Merci d'avance de prendre 5 minutes (max) pour signaler ce genre de bug tordu.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.