Forum Linux.debian/ubuntu Incompatibilité wifi b43 et NeufBox ?

Posté par (page perso) .
Tags : aucun
0
7
juil.
2009
Bonjour à tous,

J'avoue que cette question peut paraître un peu idiote, mais là je ne sais plus quoi faire... Il s'agit d'un ordi portable HP Compaq v6000 avec un chipset wifi broadcom 4311. Je lutte depuis plusieurs années pour faire marcher le wifi correctement, et je n'ai jamais vraiment réussi...
Le plus gros problème actuellement est pour me connecter à une Neuf Box. C'est vraiment bizarre, mais j'arrive à me connecter à pratiquement tous les réseaux, sauf les neuf box cryptées (pas de soucis pour le Neuf Wifi). Ca ne vient pas la carte (puisque ça marche sous vista) ni d'une neuf box particulière (puisque j'ai ce problème avec 2 Neuf box différentes).

Lorsque j'essaie de me connecter (quelque soit la méthode, à la main ou avec network-manager), la carte n'arrive pas à s'associer avec l'AP.

C'est un problème vraiment étrange, surtout que ça n'a pas l'air de dépendre du driver (b43, wl, ou ndiswrapper)... je ne suis pas un débutant du wifi sous debian, mais là, je ne vois plus quoi faire à part venir chercher la sagesse et l'expérience sur Linuxfr...

BBK
  • # Des détails ?

    Posté par (page perso) . Évalué à 5.

    C'est possible d'avoir un peu plus de détails que "ça marche pas ©" ?
    Genre des logs wpa_supplicant (avec peut être un maximum d'options de débogage)
    • [^] # Re: Des détails ?

      Posté par (page perso) . Évalué à 1.

      J'ai pas le PC en question sous la main, mais dans les logs de Network-manager, il y a toujours le même "authenticate time out" qui apparait. Et ce uniquement avec les neuf box bien sûr.

      Par contre en ce qui concerne "un maximum d'options de débogage", tu pourrais détailler un peu ce que ça veut dire ? d'ici une ou 2 semaines je devrais être en présence du PC et d'une Neuf Box.
      • [^] # Re: Des détails ?

        Posté par (page perso) . Évalué à 3.

        Pas quand tu fais la conf à la main, à un moment tu lances wpa_supplicant.
        Bah là tu mets pas le -B pour qu'il parte pas en background et tu rajoutes -ddd pour qu'il soit un peu bavard
        • [^] # Re: Des détails ?

          Posté par (page perso) . Évalué à 1.

          Euh pas de WPA_supplicant là où j'ai essayé. C'était des cryptages WEP...
          • [^] # Re: Des détails ?

            Posté par (page perso) . Évalué à 4.

            Regade quand même les messages de wpa_supplicant, mais pour le coup il sera moins bavard :/
            Sinon quitte à mettre un truc qui protège pas autant mettre le réseau en open, ca sera plus simple.
  • # Laisse tomber

    Posté par . Évalué à 1.

    Moi aussi j'ai lutté pendant des années avec le chipset b43 d'un portable Compaq (R4000) et j'ai laissé tomber. J'ai acheté un adaptateur wifi/usb à 15 euros (dwl-g122) et ça a marché d'un coup.

    P.S. jusqu'au noyau 2.6.19 et avec les outils disponibles (b43-fwcutter, iwconfig), j'arrivais à allumer la petite lumière bleue sur le bouton physique wifi. Ça marchait pas, mais y'avait de l'espoir. Un jour, les messages d'erreur de dmesg m'ont mené à un patch noyau où le mainteneur mentionnait explicitement que ça pourrait avoir un impact sur les portables avec un bouton pour le wifi. Depuis, plus de lumière bleue.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.