Forum Linux.débutant clé usb

Posté par  .
Étiquettes : aucune
0
23
mai
2005
Salut à tous!

Je voudrais savoir comment on fait pour envoyer et récupérer un fichier sur une clé USB ???
  • # utfg

    Posté par  (site Web personnel) . Évalué à 7.

    On fait comme tout le monde, on tape sur google : "clé usb linux" et on tombe par exemple sur :
    http://lea-linux.org/hardware/hard_stock/cleusb.html(...)

    Ta clé USB est vue comme un disque SCSI.
    • [^] # Re: utfg

      Posté par  . Évalué à 3.

      J'ai fait l'exercice il n'y a pas si longtemps que ça. Et la solution "utfg" n'est pas si immédiate.
      Comme le monsieur poste dans linux.débutant, je suppose qu'il faut une solution pour laquelle les clefs ne sont pas montées à la main.
      Voici ce que j'ai trouvé pour ma part :
      Noyau 2.6 + udev + hald + pmount + gnome-volume-manager.
      Pour les options du noyau 2.6, je renvoie à ton lien vers Léa.
      Pour les autres outils, ça marche en principe "out of the box", sans rien paramétrer de particulier.
      Ah si, j'oubliais : il faut que l'utilisateur fasse partie du groupe plugdev. Un google avec les mots clefs cités ci dessus devrait pouvoir aider.
  • # Facile !

    Posté par  . Évalué à 6.

    (sous gnome, mais je suppose que c'est similaire sous kde)

    Tu branches ta clef USB, une icone apparait sur ton bureau, tu ouvres le dossier correspondant en double-cliquant dessus, et tu fais ce que tu veux :)

    Pour supprimer : clique-droit->supprimer (ou envoyer vers la corbeille)
    Pour copier des fichiers dessus : tu sélectionnes les fichiers que tu veux copier, et tu les glisses sur la fenetre correspondant a la clef usb. Sous nautiluse, si tu fais la meme chose en cliquant avec le bouton du milieu plutot que celui de gauche, tu auras meme le choix entre copier ou deplacer. Et inversement pour copier des fichiers sur ton disque dur a partir de la clef usb.

    Puis tu cliques avec le bouton droit sur l'icone de la clef sur le bureau et tu fais "démonter le volume" pour la débrancher en toute sécurité.

    Bon, j'arrete la... Si ca ne marche pas, ca doit etre un probleme de reconnaissance de la clef. Dans ce cas, pour qu'on puisse vraiment t'aider, il faut que tu nous dises :

    - ta distrib
    - ce qui se passe quand tu branches la clef
    - ce que tu as essaye de faire et les resultats obetnus
    - les eventuels messages d'erreurs rencontrés.

    En bref : décrire ton problème plus précisément... Car ca marche "comme sous windows" (en plus pour retirer la clef...) si ton materiel est bien supporté (et il n'y a pas de raison pour qu'il ne le soit pas)

    Et un seul point d'interogation suffit ;)
    • [^] # Re: Facile !

      Posté par  . Évalué à 0.

      Est-ce que le fait que l'icône apparaisse sur le bureau est lié à Gnome ou à autre chose (hotplug, automount, un truc spécifique à ta distrib ) ??

      Je suis personnellement sous KDE avec Debian, et la clé n'apparait pas toute seule ...ça pourrait être bien d'ailleurs ;)
      Sous KDE par contre, il suffit d'aller dans les périphériques sou Konqueror ( media:/ ), et de faire "monter" sur la clé usb, si tant est que l'entrée existe dans le /etc/fstab. Ensuite pour démonter il y a un "Enlever en toute sécurité", ou "démonter". Cela dépend de la version de KDE ...

      ;-]
      • [^] # Re: Facile !

        Posté par  . Évalué à 1.

        J'utilise RedHat et la version je ne sais pas...

        Quand je branche ma cléf, c'est simpli, il ne se passe rien.
        Bon pas tout à fait, j'entends un petit bruit dans mon PC et la lumière de ma clé s'allume.
        Sinon c'est tout.

        Sinon le lien dans le premier post , c'est peut-être clair pour vous mais pour moi ca ne voulais pas dire grand chose...

        Il faudrais que je poste dans le forum Linux.Débutant.débutant.débutant
        Ca serai pus approprié.
        • [^] # Re: Facile !

          Posté par  . Évalué à 2.

          Bon, on essayer...

          C'est une "vraie" red hat, ou une fedora ? (il suffit a priori de lire ce qu'il y a d'ecrit au démarage...)

          Sinon, tu utilises cette version a ton bureau ou chez toi ? C'est toi qui l'a installé, ou l'administrateur systeme ?

          Si tu l'as installé toi-meme, comment/ou as tu récupéré les CD d'installation ?

          Si tu utilises linux sur ton lieu de travail, que la clef USB n'apparait pas simplement, ce n'est pas à linux qu'il faut s'en prendre, mais a ton admin system : il est regrétable que dans la plupart des cas (tous pour moi) la facon dont linus est installé par les admin est complètement pourrie (pas de montage automatique, droits mal foutus etc...)

          Essaie, dans un terminal, de taper :
          mount /mnt/removable

          si ca ne marche pas, indique nous le message d'erreur et essaie :

          mount /dev/sda /mnt/removable

          Si ca ne marche pas non plus, indique nous aussi le message d'erreur.

          Mais si ca ne marche pas, il y a de grande chance pour que ca soit l'admin systeme qui est mal configuré la chose, il fadra que tu ailles lui demander de réparer ca, ou qu'il prenne le temps de t'expliquer calmement. Dis lui que tu as vu des linus installé ou icone apparait sur le bureau quand la clef est branché, et demande lui pourquoi ce n'est pas le cas ici, que ca simplifie la vie, et que ca aide les gens a ne pas se braquer contre linux/l'informatique/les administrateurs systemes.

          Voila, j'espere que ca t'as aidé, sinon, essaie de répondre aux questions posées pour qu'on puisse cerner d'ou vient le probleme.
          • [^] # Re: Facile !

            Posté par  . Évalué à 1.

            mount /dev/removable
            Voici ce qu'il me renvoie :
            impossible de trouver le fichier /dev/removable dans /etc/fstab ou /etc/mtab

            -------------------------------------------------------------------------------------------------
            mount /dev/sda /mnt/removable
            Il me reponds :
            mount : vous devez indiquer le type de système de fichier


            Sinon j'utilise redHat pas fedora, je ne sais pas comment on dit.... :-)
            Je travail au bureau, mais je peut être root s'il le faut. Mais bon, ce n'est pas moi qui est tout installer. ( heureusement....:-) )

            PS:
            que ca aide les gens a ne pas se braquer contre linux/l'informatique/les administrateurs systemes.


            Trop tard je hais linux et windows aussi, c'est comme les ordinateurs de merde que mon admin réseaux à la con à installer, je les hais tous et l'informatique aussi....... AAAAAAaAaAaAaARGHH!!!!
            ca fais du bien de crier informatiquement :-)
            • [^] # Re: Facile !

              Posté par  . Évalué à 2.

              Ok, j'y vois un peu plus clair :)

              bon, si tu as les droits root, ca va etre plus facile déja :)

              Fait ce qui suis dans une console root

              Alors, tape :

              mount -t vfat /dev/sda /mnt/removable

              (au fait, la je suppose que le repertoire /mnt/removable existe, sinon crée le :
              mkdir /mnt/removable)

              Mais je devine deja qu'il va te repondre qu'il ne connait pas vfat.

              La ca risque de ce compliquer un peu... On va espérer que non ;)

              tape :
              modprobe vfat

              si tu as un message qui te dit que tout se passe bien, c'est cool. Si tu as un message qui te fit que le module est inconnu, c'est la merde.

              On va supposer que ca se passe bien...

              Re-essaie de monter ta clef avec "mount /dev/sda /mnt/removable"

              si ca marche, c'est cool, sinon, c'est beaucoup moins cool...

              Dans tous les cas, dis moi les eventuels messages d'erreur. Si ca marche, fait signe aussi, qu'on te dise comment automatiser tout ca.

              Donne moi aussi le résultat de la commande :
              "uname -a"

              Mais j'ai l'impression que le plus simple va peut-etre etre de demander a ton admin de faire une mise a jour du systeme vers un systeme plus récent... J'espere qu'il n'est pas trop relou ;)
              • [^] # Re: Facile !

                Posté par  . Évalué à 1.

                mount -t vfat /dev/sda /mnt/removable
                Il me renvoi dans un menu d'aide m'expliquant les -t -V a mettre après mount......... :'-(

                modprobe vfat
                il n'affiche rien...!

                uname -a
                ..... version 2.4 ..date ... i686 i686 I386 GNU/Linux

                Quelque chose comme ca...!

                J'ai réessayer de montezr la clef, et là il me met
                mount : /dev/sda n'est pas un périphérique de bloc valide


                Sa sent pas bon......
                J'espere qu'il n'est pas trop relou ;)

                Sa sent encore moins bon :-)
                • [^] # Re: Facile !

                  Posté par  . Évalué à 2.

                  En fait, que modprobe n'affiche rien est bon signe ;)

                  le module vfat est a priori chargé maintenant. C'est ca de gagné !

                  Ensuite que /dev/sda ne soit pas un peripherique valide, ca peut venir de plusieurs raisons...

                  essaie :
                  mount /dev/sda1 /mnt/removable

                  puis, si ca ne marche pas :
                  mount /dev/sdb1 /mnt/removable

                  si tu as toujours le meme type d'erreur, donne moi le resultat de la commande :

                  lsmod

                  N'oublie pas de faire tout ca en root, soit en te logant directement en root, ce qui est déconseillé, soit en faisant un "su -" ('noublie pas le "-") dans une console.

                  il va y avoir une grosse liste, copie-colle moi la liste entiere, je me debrouille avec pour retrouver les infos que je veux.

                  A priori tu es avec une "vieille" red hat 8. Avec un noyau 2.4, donc tu ne peux pas profiter de toutes les avancer des derniers noyaux 2.6, qui te permettent d'avoir les clefs qui se montent toute seule etc...
                  Et quitte a changer de noyau, autant réinstaller une distrib, c'est limite plus simple (je trouve)...

                  On va qd meme essayer de faire marcher tout ca, on devrait y arriver...
                  • [^] # Re: Facile !

                    Posté par  . Évalué à 1.

                    essaie :
                    mount /dev/sda1 /mnt/removable

                    Même réponse !

                    puis, si ca ne marche pas :
                    mount /dev/sdb1 /mnt/removable

                    Encore la même réponse ( .... n'est pas un périphérique de bloc valide )

                    lsmod
                    Effectivement, il y a une grosse liste qui est venue, mais comment faire un copier coller du mode console en mode graphique ???
                    • [^] # Re: Facile !

                      Posté par  . Évalué à 2.

                      le plus simple pour copier/coller :

                      tu ouvres un terminal dans une fenetre (sous red-hat, un clique droit->terminal je crois, ou bien tu cherches dans le menu->outil systeme ou qqchs comme ca). Tu fais un "su -", tu tapes lsmod, tu sélectionnes la liste avec la souri, et tu colles en cliquant avec le bouton du milieu la ou tu veux coller.

                      Fait le en plusieurs fois si necessaire.
      • [^] # Re: Facile !

        Posté par  . Évalué à 3.

        Le fait que l'icone apparaisse sur le bureau est lié a gnome/nautilus/gnome-volume-manager (qui dépendent de hotplug, hal etc...)

        Ca m'étonne que kde ne gere pas un truc comme ca. Ce type de montage automatique rend la vie vraiment plus simple : icone qui apparait pour les disques externent, pour le CD/DVD, les appareils photo etc... Avec la possibilité d'ouvir une application spécifique pour certains média. Ca semble incontournable pour rendre un ordinateur facile a utiliser.

        Et pour démonter, il suffit de faire un clic droit sur l'icone->démonter (ou éjecter pour les CD).

        Et un seul point d'interrogation est toujours suffisant ;)
        • [^] # Re: Facile !

          Posté par  . Évalué à 0.

          Kde peut certainement faire ce genre de choses, c'est moi qui ne doit pas savoir comment faire pour que ce soit le cas ! En plus un des défauts de debian c'est qu'il faut tout configurer, mais ça reste pas distrib préférée ;)

          Sinon, pour angsthase : en clair, pour utiliser une clé usb, il faut le module 'usb-storage', à charger en root avec la commande :
          'modprobe usb-storage'
          Ensuite, tu peux monter ladique clé avec
          'mount -t vfat /dev/sda1 /mnt/cleusb'
          Cela marche dans 90% des cas, mais si tu branches plusieurs clés, ce ne sera plus /dev/sda1, mais /dev/sdb1 pour la 2e, etc ...

          Dans l'idéal, tu peux rajouter une ligne :
          '/dev/sda1 /mnt/cleusb vfat default,user 0 0'
          dans le fichier /etc/fstab (en root ...), afin de pouvoir faire un
          'mount /mnt/cleusb' en user normal :)


          "Et un seul point d'interrogation est toujours suffisant ;)" -> Ah bon ?????
          ok, je sais par où c'est -----> [ ]

          ;-]

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.