Forum Linux.débutant Comment activer un noyau installé depuis de Gestionnaire de mises à jour ?

Posté par . Licence CC by-sa.
Tags :
0
9
déc.
2018

Bonjour à tous,

Le problème a déjà été abordé en août 2017, mais il n'a pas été totalement résolu et je ne peux pas y ajouter de réponse.

J'ai la même configuration (Linux Mint Mate 18.3) et un souci identique, mais pour lequel la réponse donnée ne convient pas. En effet, Mint (ou Grub) choisit par défaut le dernier noyau installé et il est possible, dans le menu de Grub, d'en choisir un autre, plus ancien, pour désactiver le ou les noyau(x) problématiques. Le Gestionnaire de mise à jours permet, de manière assez simple, de supprimer les noyaux installés.

En revanche, il ne semble plus permettre, comme autrefois, d'activer le noyau de son choix. Or, j'ai le problème inverse ici : j'ai un noyau 4.13 et les noyaux plus récents (4.15.x) s'installent mais ne s'activent pas. Comme j'ai un souci évident avec l'affichage (la disposition et la définition des écrans se réinitialisent tous les deux ou trois redémarrages), j'aurais voulu tester les nouveaux noyaux. Au cas où ça réglerait le problème. Au bureau, j'ai dû faire l'opération inverse (passer d'un noyau récent à un ancien) parce que l'affichage était notablement altéré. Donc, cet essai n'est pas totalement absurde.

Seulement, je ne sais pas comment indiquer au système quel noyau prendre. Et en ligne de commandes puisque le Gestionnaire de mises à jour s'y refuse. Ou via un autre utilitaire graphique (ce serait l'idéal, mais je doute sérieusement de son existence).

Quelqu'un saurait comment procéder ?

  • # les options de grub

    Posté par . Évalué à 3.

    Seulement, je ne sais pas comment indiquer au système quel noyau prendre. Et en ligne de commandes puisque le Gestionnaire de mises à jour s'y refuse. Ou via un autre utilitaire graphique (ce serait l'idéal, mais je doute sérieusement de son existence).

    Quelqu'un saurait comment procéder ?

    ben tu le choisis au demarrage de la machine, dans le menu de boot.

    apres si tu veux le figer, c'est l'option saved qui permet de sauvegarder la derniere selectionné dans grub, et de la reutiliser au demarrage suivant

    evidemment pour cela il faut "voir" le menu de grub qui est maintenant "masqué" par defaut,
    pour l'afficher il faut aller jouer du fichier /etc/default/grub dans lequel tu as les options de timeout, et de hidden pour permettre d'afficher et d'attendre ta reponse

    • [^] # Re: les options de grub

      Posté par . Évalué à 2.

      Regarder d'abord si le menu de grub affiche au premier coup d'oeil tous les noyaux installés. C'est plus simple pour moi. Si ce n'est pas le cas, activer dans /etc/default/grub

      GRUB_DISABLE_SUBMENU=y

      Ensuite, toujours dans /etc/default/grub activer le noyau qui démarre par défaut:

      GRUB_DEFAULT=0 #démarre le noyau de la 1° ligne

      ou
      GRUB_DEFAULT=1 #démarre le noyau de la 2° ligne

      ou
      GRUB_DEFAULT=2 #démarre le noyau de la 3° ligne

      etc….
      Ensuite, en root, lancer dans une console update-grub (ou grub-update?) pour rendre effective la nouvelle conf.

  • # Noyaux absents

    Posté par . Évalué à 1.

    Choisir au démarrage, c'est plus ou moins ce que j'espérais faire. Mais, bizarrement, la ligne Linux Mint ne précise pas quel noyau est lancé. Et la ligne des démarrages spéciaux affiche une longue liste de noyaux où le tout dernier (celui qui m'intéresse) est absent et où l'on retrouve tous les noyaux désinstallés (proprement) jusqu'à une vers 3.3 datant de la première installation !

    C'est clair qu'il y a un souci et que ce menu ne correspond pas à grand chose. Un petit nettoyage s'impose !

    Je vais suivre vos recommandations.

    Deux infos que j'aurais dû indiquer et qui peuvent être à l'origine du souci : j'ai un triple boot, avec Windows 7 et Lubuntu. Le second Linux a peut-être semé le désordre. Et j'ai aussi installé Grub Customizer, vu que je ne sais pratiquement rien faire en ligne de commande. Je n'y ai pensé que tout à l'heure. J'ai regardé le menu qu'il est censé enregistrer et il ne ressemble en rien à celui que la machine propose réellement.

    • [^] # Re: Noyaux absents

      Posté par . Évalué à 1. Dernière modification le 10/12/18 à 09:11.

      Ici, le menu de GRUB s'affiche pendant quelques secondes (c'est suffisant pour choisir le plus souvent). Mais le sous-menu contenant les noyaux ne semble pas à jour.

      Le début du fichier de configuration contient ceci :

          GRUB_DEFAULT="saved"
          #GRUB_HIDDEN_TIMEOUT="0"
          GRUB_HIDDEN_TIMEOUT_QUIET="true"
          GRUB_TIMEOUT="10"
          GRUB_DISTRIBUTOR="`lsb_release -i -s 2> /dev/null || echo Debian`"
          #GRUB_CMDLINE_LINUX_DEFAULT="quiet splash"
          GRUB_CMDLINE_LINUX=""

      J'hésite gravement à toucher à ce texte. En cas de pépin, je ne saurais pas rétablir le boot. :-(

      On va déjà essayer avec GRUB_DEFAULT=0.

      • [^] # Re: Noyaux absents

        Posté par . Évalué à 1. Dernière modification le 10/12/18 à 09:12.

        Une partie de conf qui devrait marcher chez toi

                GRUB_DEFAULT=0
                GRUB_TIMEOUT=30
                GRUB_CMDLINE_LINUX_DEFAULT=""
                GRUB_CMDLINE_LINUX=""
                GRUB_TERMINAL_INPUT=console
                GRUB_DISABLE_SUBMENU=y

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.