Forum Linux.débutant Problème <stdio.h>

Posté par . Licence CC by-sa.
1
16
déc.
2018

Bonjour je débute sous linux mint 19 et je rencontre un problème;
Je voudrait faire un codage en c avec la librairie , cependant lorsque j'inclue la commande dans emacs et je fais la compilation "gcc -o …", le terminal me dit qu'il ne trouve pas de fichiers correspondant à stdio.h. Bien sur j'ai téléchargé stdio.h mais je pense qu'il faut déplacer le fichier. Cependant je ne sais pas où et lorsque j'essaie il me dit "permission non accordée". Donc je suis perdu et j’espère trouver de l'aide ici.

Merci d'avance pour vos réponses.

  • # libc-dev

    Posté par . Évalué à 9 (+7/-0).

    En fonction de ta distribution Linux, ça va varier, mais il faut que tu installes un paquet qui va s'appeler quelque chose ressemblant à libc-dev. Ce paquet contient tous les fichiers d'en-têtes relatifs à la librairie standard du C. Normalement, ça va les installer à un endroit où ton gcc devrait pouvoir les trouver sans que tu aies besoin d'en faire plus.

    • [^] # Re: libc-dev

      Posté par . Évalué à 5 (+4/-0).

      Oui. Par exemple chez moi (Debian 8) c'est le paquet libc6-dev qui le fournit.

    • [^] # Re: libc-dev

      Posté par . Évalué à 9 (+7/-0).

      Sous Debian/Ubuntu tu peux installer le meta-paquet build-essential qui contiendra tout ce qu'il faut pour du développement de base : sudo apt-get install build-essential

  • # Bien sur j'ai téléchargé stdio.h

    Posté par . Évalué à 4 (+3/-0). Dernière modification le 17/12/18 à 12:31.

    Attention en faisant cela : si tu as téléchargé le fichier autrement que via les paquets de ta distribution tu t’exposes à plusieurs problèmes :

    • Une incompatibilité des fichiers avec les bibliothèques présentent dans ton système
    • D’autres fichiers manquants…
    • Des fichiers contenant des véroles

    Les autres commentaires suggères à raison de passer par les paquets de ta distribution. De manière générale, lorsqu’une distribution ne propose pas ce que tu cherches, télécharger un fichier « a poil » fait partie des solutions de dernier… dernier dernier recours.

    Comme tu es probablement sur une Debian/Ubuntu sache que tous les ".h" et consort sont dans des paquets nommés quelquechose-dev.

Envoyer un commentaire

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.