Forum Linux.redhat Samba membre d'un domaine NT

Posté par  .
Étiquettes : aucune
0
9
août
2006
Bonjour à tous.

Je fait un petit stage pendant les vacances et j'ai la tâche de "sécuriser" les partages de Samba au sein d'un domaine NT4.

Voici la situation :
-Distribution Redhat 8.0 avec samba 2.2.8a installé.
-Un réseau windows NT 4

Je voudrais authentifier les comptes d'utilisateurs NT sur samba.
ça fait maintenant 3 jours que je suis desssus et je commence à désespérer.
J'ai suivi ce lien : http://www.lea-linux.org/cached/index/Reseau-partfic-samba_n(...)


J'arrive à me joindre au domaine spécifié dans le smb.conf.
winbind a l'air de très bien fonctionner ( réponse au ping, retour de la liste des utilisateurs ou groupes, identification au CPD avec succès).
'getent' me retourner bien la liste des utilisateurs et des groupes.

Pourtant il m'est impossible d'accéder à la machine via un poste windows . J'ai droit à une jolie demande d'identifiant/mot de passe qui n'accepte malheureusement aucun compte; qu'il s'agisse d'un compte NT ou d'un compte samba créé sur la machine redhat.

J'ai trouvé très peu de liens indiquant les marches à suivre après le tutorial de léa-linux. Faudrait-il configurer quelque chose du coté du serveur NT?

Concernant mon smb.conf, il est identique à celui de léa. (à part bien sûr, l'adresse du WINS, et le nom du domaine)

Et je rajouterai juste une dernière chose: les identifiants NT sont de la forme : "NOM Prénom" je me demande si le fait d'avoir un identifiant en 2 partie, ne poserait pas un problème :s
  • # Et si tu essaies avec smbclient ?

    Posté par  . Évalué à 2.

    Tente de te connecter à ton partage avec smbclient :

    smbclient -U <user nt> -W <domaine nt> \\\\<serveur linux>\\<partage linux>

    Et rentre ton mot de passe NT. Qu'est-ce que ça dit ?
    • [^] # Re: Et si tu essaies avec smbclient ?

      Posté par  . Évalué à 1.

      J'ai réussi :)
      Il y avait un problème au niveau du réseau. Je ne sais pas trop comment le décrire car moi-même j'ai du mal à comprendre.
      Je testais plusieurs smb.conf, qui avaient chacun un nom netbios différent.
      Lors du parcours du réseau via un poste windows, même si samba avait était coupé et relancé avec une nouvelle version du smb.conf, l'ancienne était toujours présente sur le réseau :-s
      Et lorsque je tentais d'y accéder, un 2eme daemon de samba se lancé (avec l'ancienne configuration) . Bref, avec le temps et quelques reboots, ça a disparu et je n'ai plus aucun problème d'identification.

      Je me connecte donc à la machine linux, et voit mes partages samba:)
      Pour spécifier des accès aux partages, Il suffit de créer des droits aux utilisateurs NT (que l'on récupere avec la commande 'getent' ) sur des dossiers partagés.
      par exemple, changer le propriétaire d'un fichier en 'DOMAINE+loginNT' avec la commande chown

      Voilà, j'espère que ça servira aux futures personnes qui tomberont dans la même situation que moi :)
      • [^] # Re: Et si tu essaies avec smbclient ?

        Posté par  . Évalué à 2.

        J'espère juste qu'ils ne partiront pas d'une Redhat 8.0 avec samba 2.2.8a ... sachant le nombre de failles que cumulent ces deux produits en raison de leur très grand âge ...

        (il faudrait penser à faire quelques mises à jour quitte à y passer du temps).

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.