Forum général.général Comment trouver pourquoi ma batterie se vide si vite

Posté par (page perso) . Licence CC by-sa
Tags : aucun
1
14
mai
2013

J'ai des soucis avec la batterie de mon ordinateur portable. Il s'agit d'un Samsung 350V5C-S03FR avec une batterie 6 cellules. Quand je démarre sous Windows 7, j'ai 3 heures d'autonomie. Quand je démarre sous Ubuntu, j'ai 1 h 20.

Du coup, pour augmenter l'autonomie, j'ai coupé les trucs dont je ne me sert pas, comme le bluetooth. Ça a amené l'autonomie à 1 h 20.

Puis, pour avoir vraiment les meilleures performances, j'ai lancé powertop et appliqué ses conseils, ce qui me donne une autonomie incroyable de 1 h 20.

J'ai aussi tenté d'utiliser les pilotes non libres de ma carte graphique, en supposant un excès de consommation pouvais venir du pilote installé. Ça a poussé l'autonomie jusqu'à 1 h 20, mais en plus je n'avais plus d'accélération graphique (Gnome 3 se lançait en mode restreint).

J'ai ce problème depuis Ubuntu 12.04, je l'ai conservé avec 12.10 et ça se maintient avec 13.04. Sur mon eeepc avec la même distribution j'ai une autonomie de 3 h, ce qui me semble bien. Je pense donc que ça ne vient pas du paramétrages du système, mais plutôt de la gestion du matériel. Cependant je ne sais pas où chercher. Avez-vous des pistes pour moi ?

  • # quelques pistes...

    Posté par (page perso) . Évalué à -3.

    j'ai plein d'idées géniales qui pourraient te faire arriver à une autonomie de … 1h20 ? ca t'intéresse ? :-)

  • # vitesse processeur

    Posté par (page perso) . Évalué à 7.

    Je soupçonne que ton processeur marche toujours à fond, même quand cela ne sert à rien.

    test avec un cpufreq-info

    • [^] # Re: vitesse processeur

      Posté par (page perso) . Évalué à 2.

      j'ai laissé l'ordinateur en idle jusqu'à ce que la batterie soit vide (1 h 20 environ…). Il avait juste à afficher le bureau avec la luminosité au minimum. cpufreq-info me donne le message suivant à la fin, pour le cœur 0, et un truc similaire pour les autres cœurs :

      analyse du CPU 0 :
        pilote : acpi-cpufreq
        CPUs which run at the same hardware frequency: 0 1 2 3
        CPUs which need to have their frequency coordinated by software: 0
        maximum transition latency: 10.0 us.
        limitation matérielle : 1.20 GHz - 2.50 GHz
        plage de fréquence : 2.50 GHz, 2.50 GHz, 2.40 GHz, 2.30 GHz, 2.20 GHz, 2.10 GHz, 2.00 GHz, 1.90 GHz, 1.80 GHz, 1.70 GHz, 1.60 GHz, 1.50 GHz, 1.40 GHz, 1.30 GHz, 1.20 GHz
        régulateurs disponibles : conservative, ondemand, userspace, powersave, performance
        tactique actuelle : la fréquence doit être comprise entre 1.20 GHz et 2.50 GHz.
                        Le régulateur "ondemand" est libre de choisir la vitesse
                        dans cette plage de fréquences.
        la fréquence actuelle de ce CPU est 1.20 GHz.
        des statistique concernant cpufreq:2.50 GHz:0,99%, 2.50 GHz:0,00%, 2.40 GHz:0,01%, 2.30 GHz:0,01%, 2.20 GHz:0,00%, 2.10 GHz:0,01%, 2.00 GHz:0,01%, 1.90 GHz:0,00%, 1.80 GHz:0,00%, 1.70 GHz:0,01%, 1.60 GHz:0,00%, 1.50 GHz:0,01%, 1.40 GHz:0,01%, 1.30 GHz:0,00%, 1.20 GHz:98,94%  (479)
      
      

      Je dirais que ça ne vient pas du processeur du coup, vu qu'il est à 99% au minimum de sa fréquence. Par contre, est-ce qu'il ne devrait pas être en mode « powersave » plutôt que « ondemand » ?

  • # PCI_ASPM ?

    Posté par . Évalué à 3.

    lspci -vvv et regarde si l'ASPM est désactivé et pour quel composant.
    Ça a entraîné une nette baisse de l'autonomie des laptops récemment.

    Il y a moyen de le forcer en ajoutant sur la ligne de démarrage du noyau pcie_aspm=force dans GRUB, mais ça risque de le forcer pour des périphériques qui ne le supportent pas (en gros ça risque de planter, d'expérience si ça le fait c'est assez vite).

    Sinon essaye de mettre à jour le BIOS.

    • [^] # Re: PCI_ASPM ?

      Posté par (page perso) . Évalué à 2.

      lspci me dit plein de trucs que je ne sais pas interpréter, dont ce qui suit (je résume aux lignes pour lesquelles il parle d'ASPM) :

      00:01.0 PCI bridge: Intel Corporation Xeon E3-1200 v2/3rd Gen Core processor PCI Express Root Port (rev 09) (prog-if 00 [Normal decode])
              LnkCap: Port #2, Speed 8GT/s, Width x16, ASPM L0s L1, Latency L0 <256ns, L1 <8us
              LnkCtl: ASPM L0s L1 Enabled; RCB 64 bytes Disabled- Retrain- CommClk+
      00:1b.0 Audio device: Intel Corporation 7 Series/C210 Series Chipset Family High Definition Audio Controller (rev 04)
          LnkCap: Port #0, Speed unknown, Width x0, ASPM unknown, Latency L0 <64ns, L1 <1us
          LnkCtl: ASPM Disabled; Disabled- Retrain- CommClk-
      00:1c.0 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 1 (rev c4) (prog-if 00 [Normal decode])
          LnkCap: Port #1, Speed 5GT/s, Width x1, ASPM L0s L1, Latency L0 <512ns, L1 <16us
          LnkCtl: ASPM Disabled; RCB 64 bytes Disabled- Retrain- CommClk+
      00:1c.1 PCI bridge: Intel Corporation 7 Series/C210 Series Chipset Family PCI Express Root Port 2 (rev c4) (prog-if 00 [Normal decode])
          LnkCap: Port #2, Speed 5GT/s, Width x1, ASPM L0s L1, Latency L0 <512ns, L1 <16us
          LnkCtl: ASPM L0s L1 Enabled; RCB 64 bytes Disabled- Retrain- CommClk+
      01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI Thames XT [Radeon HD 7670M] (prog-if 00 [VGA controller])
          LnkCap: Port #0, Speed 5GT/s, Width x16, ASPM L0s L1, Latency L0 <64ns, L1 <1us
          LnkCtl: ASPM L0s L1 Enabled; RCB 64 bytes Disabled- Retrain- CommClk+
      02:00.0 Ethernet controller: Realtek Semiconductor Co., Ltd. RTL8111/8168 PCI Express Gigabit Ethernet controller (rev 09)
          LnkCap: Port #0, Speed 2.5GT/s, Width x1, ASPM L0s L1, Latency L0 unlimited, L1 <64us
          LnkCtl: ASPM Disabled; RCB 64 bytes Disabled- Retrain- CommClk+
      03:00.0 Network controller: Atheros Communications Inc. AR9485 Wireless Network Adapter (rev 01)
          LnkCap: Port #0, Speed 2.5GT/s, Width x1, ASPM L0s L1, Latency L0 <4us, L1 <64us
          LnkCtl: ASPM L0s L1 Enabled; RCB 64 bytes Disabled- Retrain- CommClk+
      
      

      C'est donc parfois activé, parfois pas. Je n'ai pas encore testé la ligne Grub

      Sinon essaye de mettre à jour le BIOS.

      L'autonomie étant correcte sous Windows, je doute que ça vienne du Bios.

      • [^] # Re: PCI_ASPM ?

        Posté par . Évalué à 3.

        Visiblement l'économie d'énergie est activée pour le lien PCI notamment pour la carte graphique (qui est ce qui bouffe le plus) et la carte réseau sans fil (qui consomme pas mal). Pas besoin, à mon avis, de le forcer.

        Tu utilises les pilotes libres pour la carte radeon ? Si oui, essaye ça (en root) :
        echo low > /sys/class/drm/card0/device/power_profile
        ce qui fixe la puissance (électrique) de la carte graphique au minimum (en mode autonomie tu ne devrais pas jouer beaucoup de toutes façons :-)

        Sinon, essaye les pilotes propriétaires, il paraît qu'ils gèrent un peu mieux la consommation électrique de la batterie.

        • [^] # Re: PCI_ASPM ?

          Posté par (page perso) . Évalué à 2.

          Tu utilises les pilotes libres pour la carte radeon ? Si oui, essaye ça (en root) :
          echo low > /sys/class/drm/card0/device/power_profile

          J'utilise effectivement les pilotes libres, mais le fichier power_profile n'existe pas et du coup la commande échoue. Une petite recherche sur le web révèle que d'autres ont le même résultat, mais je n'ai pas vu de contournement.

          Sinon, essaye les pilotes propriétaires, il paraît qu'ils gèrent un peu mieux la consommation électrique de la batterie.

          J'ai essayé mais c'est pire : je n'ai même plus d'accélération ! Je n'ai pas poussé ce test très loin cependant.

          • [^] # Re: PCI_ASPM ?

            Posté par . Évalué à 3.

            tu as essayé en recherchant par exemple drm/card1/ ou autres ? C'est étonnant quand même, mais c'est peut-être lié au fait que c'est une carte pour portable. Bizarre en tout cas.

            Tu as mesuré la consommation en étant simplement sur une console virtuelle (sans avoir démarré X) pour voir si ça ne venait pas des effet 3D activés par défaut ?

            Sinon je n'ai plus vraiment d'idées, navré pour toi, mis à part continuer à chercher du côté de la carte graphique.

            • [^] # Re: PCI_ASPM ?

              Posté par (page perso) . Évalué à 2.

              Tu as mesuré la consommation en étant simplement sur une console virtuelle (sans avoir démarré X) pour voir si ça ne venait pas des effet 3D activés par défaut ?

              Très bonne idée. J'ai démarré en mode console de secours et j'ai laissé la batterie se vider en ne faisant rien d'autre que l'affichage. Bilan : environ 1 h 40 d'autonomie. C'est pas beaucoup mieux, je pense que le problème est plus bas du coup.

              Sinon je n'ai plus vraiment d'idées, navré pour toi, mis à part continuer à chercher du côté de la carte graphique.

              Merci pour ton aide en tout cas.

  • # carte graphique intel utilisé sous windows ?

    Posté par . Évalué à 0.

    salut,

    à priori, il y a un core i5 ivy bridge sur ton portable.
    Donc une carte graphique intel qui consomme beaucoup moins que l'ati.
    Je pense que sous windows sans être branché sur le secteur, par défaut tu utilises la carte graphique intel => 3h d'autonomie

    Sur ubuntu, tu dois être sur l'ati, d'où l'autonomie minable.

    Je sais que pour nvidia, ca utilise la techno optimus (via bumble sous linux). Par contre pour ati , j'en sais trop rien =p

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.