Forum Linux.debian/ubuntu startx sans installation de xdm ou gdm

Posté par .
Tags : aucun
1
24
oct.
2008
Suite a une netinstall de Debian Lenny j ai installer les paquets "xserver-xorg" et "fluxbox".
Je n ai pas reussi a lancer l interface graphique via la commande "startx" sans avoir installer le paquet "gdm"

Comment est il possible de lancer l interface graphique sans l installation d'un Display Manager
  • # xinit

    Posté par . Évalué à 1.

    runlevel 3
    xinit -- :0

    un Xterm se lance seul sur Xorg, sans wm
    de là tu tapes ton startfluxbox

    tu peux te créer un tit fichier d' init adapté, avec autologin, si tu préfères de mode, pas de "dm", et X en rootless.

    Cdlt
  • # Hop

    Posté par (page perso) . Évalué à 0.

    Ca tombe bien la documentation de fluxbox montre comment faire cela ;)

    http://fluxbox.sourceforge.net/docbook/fr/html/app-setup.htm(...)

    Accesoirement j'ai appris pas mal de chose en lisant la doc fluxbox à l'époque :)
  • # Mingetty et update-alternatives --config x-session-manager

    Posté par . Évalué à 3.

    Salut,
    Voici une procédure que j'utilise avec Debian Lenny et Fluxbox sur un PII 128Mo de RAM qui tourne avec environ 40 Mo de mémoire vive (sans lancer d'applications).
    Installe mingetty, puis dans /etc/inittab, remplace la ligne de commande de la première console par :
    1:2345:respawn:/sbin/mingetty --autologin identifiant tty1

    Exemple, si /home/jules/ alors :
    1:2345:respawn:/sbin/mingetty --autologin jules tty1

    Pour avoir Fluxbox au démarrage :
    # update-alternatives --config x-session-manager
    et tu fais ton choix avec startfluxbox

    J'ai essayé les autres logiciels "getty" assortis d'une option d'identification automatique, ce n'est pas pratique, car ils demandent quand même d'appuyer sur la touche retour chariot pour démarrer la session X sous le login spécifié. Avec mingetty, la session démarre sans appuyer sur quoi que ce soit.
  • # xinitrc

    Posté par . Évalué à 2.

    tu peux te créer un fichier dans ton home nommé .xinitrc, et dedans tu mets les logiciels que tu veux démarrer, mais un
    /usr/bin/fluxbox pourra suffire.

    Tu peux également taper en console :

    xinit /usr/bin/fluxbox

    et tu arrives directement sur fluxbox (peut-etre que startfluxbox sera plus adapté, je ne connais pas la difference)

    Only wimps use tape backup: real men just upload their important stuff on megaupload, and let the rest of the world ~~mirror~~ link to it

    • [^] # Re: xinitrc

      Posté par . Évalué à 2.

      startfluxbox ne fait que vérifier la prescence de quelques dossiers et lance le script ~/.fluxbox/startup pour finir par lancer fluxbox.

      Fin cat /usr/bin/startfluxbox vous l'apprendre mieux que moi.
  • # apt-file

    Posté par . Évalué à 2.

    Soit j'ai mal compris ton problème soit les réponses d'au dessus sont a coté de la plaque ...
    Moi j'utiliserais apt-file (qui permet de trouver dans paquet est un fichier) pour déterminer ou est startx.
    Chez moi il me dit que c'est xinit ... il ne reste donc plus qu'a l'installer et ça devrait fonctionner.
  • # ca ne marche toujours pas

    Posté par . Évalué à 1.

    j ai essaye un peu tout ce qui a ete propose et il m est toujours impossible de demarrer fluxbox sans passer par xdm.

    J ai cree un fichier ".xinitrc" dans mon "/home/USER"
    avec comme permission d'acces "chmod a+rwx"

    j ai mis dedans "/usr/bin/fluxbox"

    et quand je demarre en mode console startx de marche pas
    si je tape la commande "X" j ai un ecran gris avec la croix comme pointeur
    si je tape la commande "fluxbox" ou "startfluxbox" j ai le message:
    impossible de se connecter au serveur X

    Avez vous d'autres propositions?

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.