Forum Linux.debian/ubuntu xmodmap et redémarrage

0
6
oct.
2017

Salut,

Pour pouvoir utiliser le point du pavé numérique (comme séparateur décimal aka virgule) dans LibreOffice, je dois taper la commande :
$ xmodmap -e 'keycode 91 = KP_Delete KP_Decimal'

Ça fonctionne bien (si je tape la commande dans un terminal et que je lance LibreOffice depuis le terminal), mais j'aimerai ajouter cette commande à ma configuration.
J'ai ajouté cette commande à mon fichier .profile … mais cela ne change rien.

Ou faudrait-il que j'ajoute cette commande pour qu'elle soit prise en compte au démarrage de mon ordinateur/session ?

Merci d'avance.

  • # dans $HOME ou généraliser au système ?

    Posté par . Évalué à 3 (+2/-0).

    1. $HOME: mettre la config dans $HOME/.Xmodmap  ?
    2. Général : essayer dans /etc/X11/Xmodmap

    Après cela peut aussi dépendre de la distribution …

    Si cela ne fonctionne pas, il faudra placer un appel à la commande xmodmap -e ... (ou xmodmap <nomfichier>) dans un script dans le répertoire /etc/X11/Xsession.d/ (pour Debian toujours) ou équivalent.

  • # Plusieurs pistes à vérifier...

    Posté par . Évalué à 2 (+1/-0).

    • est-ce que ton .profile est bien appelé car cela peut dépendre de ton shell
    • est-ce que tu utilises la commande setxkbmap dans le reste de ta config ? Si oui, celle-ci peut réinitialiser la config clavier

    Dans tout les cas, ta commande xmodmap n'a pas vraiment a être dans un fichier de config shell.
    Mets cette commande dans ton .xinitrc si tu passes par xinit ou utilises les outils de ton environnement de bureau (GnomeTweakTool par exemple)

  • # y a peut-etre plus simple non ?

    Posté par . Évalué à 3 (+1/-0).

    genre aller dans les preferences de libreoffice pour lui dire d'utiliser les separateurs francais/anglais selon ta preference (je ne sais jamais qui fait quoi)

    • [^] # Re: y a peut-etre plus simple non ?

      Posté par (page perso) . Évalué à 2 (+1/-0).

      Si tu peux donner la configuration qui va bien (les options à choisir) : je suis preneur … et apparemment pas le seul, puisque de mémoire, cette commande xmodmap, je l'avais trouvé sur un forum LibreOffice.

      • [^] # Re: y a peut-etre plus simple non ?

        Posté par . Évalué à 2 (+0/-0).

        J'ai pas de clavier avec pavé numerique pour verifier mais le premier truc qui me vient à l'esprit c'est cette page

        Titre de l'image

        Texte du lien

        ou tu peux dire à libreoffice d'ignorer le reglage systeme, lui preciser le separateur, etc

    • [^] # Re: y a peut-etre plus simple non ?

      Posté par (page perso) . Évalué à 2 (+0/-0). Dernière modification le 09/10/17 à 23:38.

      dans Options, Paramètres linguistiques, touche séparateur de décimales : cocher "identique au paramètre de la locale ( , )"…
      …sauf que ça marche pas chez moi !

      LibreOffice Version: 5.4.1.2.0+ Build ID: 1:5.4.1-1
      Debian GNU/Linux 64 bits Sid avec GNOME-Wayland

      NB : jadis, cela marchait.

Envoyer un commentaire

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.