Forum Linux.noyau [RESOLU] Boot qui s'arrête très vite

Posté par (page perso) . Licence CC by-sa
0
30
déc.
2016

J'essaye d'installer un Linux sur une portable d'un copain, qui a oublié le mot de passe du BIOS. C'est assez vieux (2008) avec un Intel T4200 et une Nvidia 9300.

Le démarrage en clé USB s'arrête après quelques secondes à peine, sans même arriver à l'initrd. J'ai à l'écran le CPU détecté, et quelques lignes qui s'arrêtent sur le support de BTRFS.

Est-ce que ça pourrait être un BIOS qui interdit autre chose que le Windows 7 qui tourne dessus?

Quelle piste pour débogguer ce qui bloque?

  • # peu probable

    Posté par (page perso) . Évalué à 4.

    Une fois que le boot loader a chargé le noyau

    Essayer de passer des paramètres de boot du noyau en desactivant certains modules video et/ou usb.

    ex: nomodeset de mémoire

    Système - Réseau - Sécurité Open Source

    • [^] # Re: peu probable

      Posté par (page perso) . Évalué à 2.

      Déjà essayé, ainsi que nouveau.modeset=0 .

      ⚓ À g'Auch TOUTE! http://afdgauch.online.fr

  • # Pas le BIOS

    Posté par (page perso) . Évalué à 2.

    Vérifier si le BIOS UEFI est bien désactivé et les disques durs bien reconnus.

    • [^] # Re: Pas le BIOS

      Posté par (page perso) . Évalué à 2.

      Merci, mais comme indiqué pas d'accès au BIOS possible. Ceci étant, si j'y mets un autre disque dur ça boote aussi, et bloque. J'ai essayé avec des noyaux 4.4 et 4.10… je vais essayer avec de plus vieux noyaux!

      ⚓ À g'Auch TOUTE! http://afdgauch.online.fr

  • # effacer le mot de passe BIOS

    Posté par (page perso) . Évalué à 2.

    Tu peux essayer d'effacer le mot de passe BIOS, peut-être avec The UBCD.

    • [^] # Re: effacer le mot de passe BIOS

      Posté par . Évalué à 1.

      ou plus simplement en ouvrant lisant le mode d'emploi du constructeur

      c'est portable, il est probable que la deconnexion du cable d'alim, la deconnexion de la batterie, puis une manipulation comme "appuyer 30sec sur le bouton ON/OFF" suffise à vider le bios et à le remettre à zero

      • [^] # Re: effacer le mot de passe BIOS

        Posté par (page perso) . Évalué à 2.

        Non : les BIOS récents écrivent le mot de passe dans une EEPROM. Même enlever la pile s'il y en a ne serivrait à rien.

        ⚓ À g'Auch TOUTE! http://afdgauch.online.fr

  • # PCIE HOTPLUG

    Posté par (page perso) . Évalué à 2.

    Merci pour vos pistes j'ai enfin trouvé ce qui coince : il faut désactiver le branchement à chaud des cartes PCIE dans le BIOS pour que ça passe bien.

    Comme je n'ai pas accès au BIOS, j'ai dû recompiler le noyau en désactivant PCIE_HOTPLUG !

    ⚓ À g'Auch TOUTE! http://afdgauch.online.fr

    • [^] # Re: PCIE HOTPLUG

      Posté par . Évalué à 2.

      Comme je n'ai pas accès au BIOS, j'ai dû recompiler le noyau en désactivant PCIE_HOTPLUG !

      carrement recompiler le noyau ?

      y avait pas plutot une option à mettre au demarrage ?

      y a 34 occurences de PCIE dans les options au boot
      http://redsymbol.net/linux-kernel-boot-parameters/

      • [^] # Re: PCIE HOTPLUG

        Posté par (page perso) . Évalué à 2.

        Merci pour le lien, mais il n'indique pas d'option pour désactiver le PCIEHP. Juste d'utiliser les interruptions MSI.

        ⚓ À g'Auch TOUTE! http://afdgauch.online.fr

  • # reset du password bios admin avec un peripherique

    Posté par . Évalué à 2.

    apparemment avec une carte electronique externe (KMX ?)
    https://www.youtube.com/watch?v=xeTCq8ws9_Q

    la 2e semble plus efficace (pas besoin d'electronique)
    mais demande un peu de patience car il faut trouver la puce sur le chassis, et juste faire court-circuit
    https://www.youtube.com/watch?v=FW-RLkzjAS8

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.