Forum Linux.redhat CentOS 6.5 - Downgrade PHP 5.3.3 vers 5.3.2

Posté par . Licence CC by-sa
0
12
juin
2014

Bonjour,

Dans le cadre de mon boulot, j'ai installé un Nagios sur une CentOS 6.5. Je voudrais compléter cela par Centreon pour avoir une interface plus conviviale et une configuration plus aisée de Nagios.

Problème: dans les pré-requis Centreon, il faut un PHP 5.1, 5.2, 5.3 (5.3.1 ok, 5.3.2 non supporté).
Or sur mon CentOS, j'ai un php 5.3.3. J'aimerais donc repasser à une version 5.3.1 maximum de PHP.

J'ai googlé rapidement et on proposait d'utiliser "yum downgrade …", cela a pas été concluant car les répos ne contiennent pas de version de PHP antérieures à 5.3.3. J'ai également tenté ceci également mais je n'ai pu testé car la page http://repo.webtatic.com/yum/centos/6/latest.rpm n'existe pas (ou plus). En regardant, cela n'a pas l'air simple comme problème.

Bref je suis un peu perdu. Si vous avez une solution simple, je se suis preneur.

Je verrai vos réponses demain à partir de 9h30 (je n'ai pas internet chez moi pour cause d’emménagement récent).

Merci à vous

tOHTor

Question Bonus: que conseillait vous comme solution de supervision libre d'un système informatique ? Le besoin étant de surveiller ~10 machines physiques, ~50 VMs, et pouvoir surveiller sur chaque système les services qui tournent (typiquement du Apache et du TomCat) avec remontée d'alerte, et enfin pouvoir mesurer/faire des rapports sur les services.
Je suis partie sur le fameux couple Nagios/Centreon mais ça a pas l'air évident au premier abord.

  • # BIzarre

    Posté par (page perso) . Évalué à 3.

    5.3.1 ok, 5.3.2 non supporté

    Normalement, les API ne sont pas cassé avec le numéro 3 donc cela devrait marcher sans aucun problème.

    Après, s'il faut ceinture et bretelle, il est préférable de basculer sur RHEL ;-)

    • [^] # Re: BIzarre

      Posté par . Évalué à 1.

      Merci de ta réponse rapide. C'est vrai que les API ne sont pas cassés alors je vais essayer avec ma version actuelle de php.

      Cela m'intéresse tout de même de savoir comment downgrade ma version de PHP.

  • # Comment downgrader

    Posté par (page perso) . Évalué à 2.

    La version 5.3.3 à l'avantage d'être la version supporté par RedHat tout au long de la vie de RHEL6/Centos6.

    Tu ne peux pas downgrader ta version de php car aucune version plus ancienne n'est présente dans tes repos.

    Pour avoir des versions de php différentes de celles proposés par défaut dans RHEL/Centos, je te conseille d'utiliser le repo de Rémi Collet http://rpms.famillecollet.com/. Toutefois je doute que tu y trouves des versions plus anciennes.

    Par ailleurs, centreon propose un repo http://documentation.centreon.com/docs/centreon/en/latest/installation/from_packages.html ce qui permet de me pas avoir de problèmes de dépendances.

    • [^] # Re: Comment downgrader

      Posté par . Évalué à 1.

      Merci de ta réponse.

      C'est bien ce que j'avais cru comprendre sur PHP, les versions antérieures à 5.3.3 ne sont plus supportées.

      Pour l'installation de Centreon par les repos, j'ai déjà essayé mais cela n'avait pas marché. (Je vais quand même réessayer aujourd'hui ou la semaine prochaine).

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.