Sortie de Dotclear 2.7

Posté par (page perso) . Édité par M5oul, palm123, BAud, Florent Zara et Nÿco. Modéré par Nÿco. Licence CC by-sa
24
14
déc.
2014
Internet

Dotclear le moteur de blog libre, distribué sous licence GNU GPL v2, sort en version 2.7 sous le nom de code Currywurst.

logo dotclear

La version 2.6 est sortie il y a maintenant 13 mois. Voici la suite ! La version 2.7 est moins spectaculaire que la version 2.6 mais elle apporte tout de même des changements significatifs côté administration et côté public.

Un nouvel éditeur WYSIWYG et du HTML5 côté administration mais aussi côté visiteur.

Administration

Un nouvel éditeur (basé sur CKEditor) a été intégré. Il devrait réglé des petits problèmes liés à l'intégration de vidéos externes notamment. L'ancien éditeur est toujours présent. Comme il existe plusieurs éditeurs, les préférences utilisateurs permettent de choisir l'éditeur pour chaque syntaxe supportée (HTML, Wiki, Markdown…)

D'autre part, la partie administration est passée à HTML5. Côté accessibilité, les rôles ARIA principaux ont été intégrés.

Côté public

Côté public, les modèles de pages (templates) sont aussi passés en HTML5. Le moteur de templates a été modifié et permet le choix d'un jeu de templates et l'héritage de templates. Du coup deux jeux de templates sont livrés avec cette nouvelle version de Dotclear :

  • un nommé mustek, semblable au jeu de template des versions précédentes. Il est utilisé par défaut ;
  • un nommé currywrust, utilisant l'héritage des templates. Il est utilisé par le nouveau thème par défaut : Berlin.

Comme pour la partie administration, les principaux rôles ARIA ont été ajoutés.

Divers

  • protection activable contre le clickjacking ;
  • les sons et les vidéos utilisent désormais les tags HTML 5 ;
  • drag'n'drop sur écran tactile ;
  • de nombreuses corrections de bugs.

Si votre hébergeur le permet, vous devriez voir apparaître la proposition de mise à jour vers cette version depuis votre interface d'administration.

Le paquet Debian de Dotclear, pour la version 2.7 ne devrait pas tarder à rejoindre les dépôts officiels.

  • # Partant !

    Posté par . Évalué à 2.

    Je vais l'essayer pour un site pro (un artisan). Je comptais utiliser WP (l'habitude), mais je vais donner sa chance à Dotclear ! 

    :)

  • # Installation chez Free ?

    Posté par . Évalué à 1.

    J'imagine qu'il ne sera plus possible de l'installer chez Free, même en bidouillant quelques fichiers comme pour la 2.6 ?

    • [^] # Re: Installation chez Free ?

      Posté par (page perso) . Évalué à 2.

      Si si mais ça va devenir de plus en plus compliqué ! :-)

    • [^] # Re: Installation chez Free ?

      Posté par . Évalué à 2.

      Pourquoi ?

      BeOS le faisait il y a 15 ans !

      • [^] # Re: Installation chez Free ?

        Posté par (page perso) . Évalué à 2.

        Pour faire simple, pour le moment dotclear devrait fonctionner à partir de php 5.2. Il n'y a pas ou très peu de code spécifiques aux versions ultérieures. La version 2.0 est sortie il y a plus de 6 ans et venait avec beaucoup de code permettant de pallier aux manques des différents hébergeurs.

        L'équipe derrière dotclear ne va pas volontairement écrire du code qui empêcherait le cms de fonctionner sur d'anciennes versions de php mais cela a de très forte chance d'arriver.

      • [^] # Re: Installation chez Free ?

        Posté par (page perso) . Évalué à 2.

        La version de PHP chez free est toujours la 5.1.3RC4

  • # 403 pas cool

    Posté par (page perso) . Évalué à 3.

    Bonjour,

    Quand je vois une annonce pour un moteur de blog, c'est plus fort que moi, je ne peux pas résister, je le soumets au Markup Validation Service ; ou mieux Unicorn. Mais là, pour le site "http://dotclear.org/", je me prends un "403 Forbidden". Idem pour les feuilles de style. C'est la première fois que je vois ce genre de réponse venant des vérificateurs du w3 ! Pas cool.

    J'ai quand même fait vérifier la validité du HTML de la page d'accueil par téléchargement de fichier. Et là, je vois que le doctype est XHTML 1.0 Strict (et c'est évident aussi si l'on regarde le source !).

    Là, je m'interroge : où est le HTML5 dont on parle dans la dépêche ? En tout cas, rendu fin 2014, publier en XHTML 1.0 Strict ça fait un peu désordre pour un site faisant la promotion d'un logiciel Web.

    Bon, sachant que la critique est aisée alors que l'art est difficile, je souhaite bon succès aux auteurs.

    • [^] # Re: 403 pas cool

      Posté par (page perso) . Évalué à 4.

      Le site http://dotclear.org/ utilise lui aussi dotclear mais il n'a pas encore été mis à jour. La sortie de cette nouvelle version étant encore très récente, ce n'est à mon sens pas encore trop choquant.

      Je ne connaissais pas Unicorn. Merci.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.