Sortie de Modoboa 0.9.4

Posté par (page perso) . Édité par Florent Zara. Modéré par Christophe Guilloux. Licence CC by-sa
20
5
fév.
2013
Internet

Une nouvelle version du logiciel libre (licence MIT) Modoboa est disponible. Modoboa est un outil visant à simplifier l’administration et l’utilisation d’une plate‐forme d’hébergement de courriel. Il est disponible dans cinq langues (anglais, français, allemand, espagnol et portugais). Il est majoritairement écrit en Python/Django (avec un peu de JavaScript quand même pour la partie « dynamique »).

Cette version apporte quelques nouvelles fonctionnalités comme :

  • Une page de listing des identités plus facile à utiliser et plus performante ;
  • Des statistiques graphiques mieux présentés ;
  • Des informations complémentaires disponibles depuis la console d'administration.

En complément, un certain nombres de bogues ont été corrigés. La liste détaillée des changements est visible sur la forge.

Cette version permet de stabiliser les bases du logiciel dans le but de préparer l'arrivée (plus ou moins prochaine) de la future 1.0 dans les meilleures conditions. D'autre part, une feuille de route à moyen terme a été pensée afin de donner un peu de visibilité aux utilisateurs de Modoboa (ou ceux souhaitant le devenir).

  • # Ça a l'air sympa mais....

    Posté par . Évalué à 5.

    En allant fouiner un peu sur le site, impossible de trouver quelles sont les dépendances de la chose.

    Rien dans la documentation de très explicite. On voit que ça peut fonctionner avec postfix et dovecot, mais est-ce que ça peut fonctionner avec sendmail et courier ?

    Est-ce qu'il faut clamd en plus d'amavis pour le traitement des spams ?

    Quelles versions minimales doivent être dispos sur la machine pour le bon fonctionnement…

    Du coup, je reste un peu sur ma faim…

    cd /pub && more beer

    • [^] # Re: Ça a l'air sympa mais....

      Posté par (page perso) . Évalué à 4.

      Qu'entends tu par dépendances ?

      Les dépendances logicielles (niveau python) sont indiquées dans la documentation et gérées automatiquement par l'installation via pip ou easy_install.

      Niveau compatibilité avec des logiciels externes, les possibilités sont larges. Modoboa fonctionne parfaitement avec Postfix (qq soit la version), dovecot 1 ou 2 et amavis (>= 2.7 comme indiqué ici).

      Il doit pouvoir fonctionner avec sendmail, exim, courier, cyrus et autres modulo quelques tests et adaptations. Je n'ai juste jamais eu aucun retour à ce sujet et ne suis pas utilisateur de ces produits.

      Concernant amavis, tu es libre de le coupler à clamd si tu le souhaites, cela n'impacte en rien Modoboa qui se concentre sur les aspects quarantaine et paramétrage (basique).

      As tu d'autres questions ?

      • [^] # Re: Ça a l'air sympa mais....

        Posté par . Évalué à 3.

        Qu'entends tu par dépendances ?

        Les briques minimales et nécessaires pour l'utilisation et l'installation d'un produit, quel qu'il soit.

        Il doit pouvoir fonctionner avec sendmail, exim, courier, cyrus et autres modulo quelques tests et adaptations.

        Je pense que ceci devrait être stipulé dans la documentation. Avec un truc du genre : « Actuellement, seuls postfix et dovecot sont les services officiellement supportés. Cela devrait pouvoir fonctionner avec d'autres mta et mda mais cela n'a pas été testé. Tous les retours sont les bienvenus »

        Cela permettrait d'éviter de se poser la question et de chercher désespérément dans la documentation si ces points sont abordés.

        Pour l'instant, je n'ai pas d'autres questions et si j'en avais, je passerai par la ML ou le chan IRC :)

        En tout cas, merci pour le boulot.

        cd /pub && more beer

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.