Journal SSD, Tibook et Ubuntu 9.04

Posté par .
Tags : aucun
21
24
juin
2009
Salut à tous,

un petit journal pour dire mon plaisir d'avoir ressuscité mon bon vieux Tibook 400Mhz de 2001... En fait ressuscité est un peu exagéré, il faudrait plutôt dire rajeuni de 7 ou 8 ans. Comment réaliser un tel miracle ? Cela m'a demandé un peu d'argent (env. 300 € quand même) et de temps :

le constat :

- je voulais depuis un moment tester ces fameux SSD
- le pauvre DD de 30 Go du tibook était plein à ras-bord, et une partition entière de 10 Go irrecupérable
- ce matériel n'est plus supporté à partir de mac OS X 1.4, et donc les dernières mises à jour s'arrêtent avec Panther 10.3.9. De plus je n'avait pas les CD de cet os dans cette version.

La solution : un SSD et le libre, Ubuntu en l'occurrence.

J'ai donc fait l'acquisition d'un "disque dur" SSD Soliware SOLIWARES10P64GB (ici http://www.ssdshop.ch/cat142.htm). Soit 64Go, en PATA (ide), pour un peu moins de 300 €. Cher, très cher, mais j'avais envie :°)

L'installation matérielle est triviale, enlever les 7 vis, sortir le disque, mettre le nouveau et voilà.

L'installation de Jaunty a été plus délicate, pour des raisons liées à la carte graphique (une ATI Rage Mobility M3 en 1152 x 768). Par défaut, le disque d'installation plante après un avoir annoncé "Invalid ROM content". Lors du démarrage, il est conseillé en cas de problème d'essayer

live video=ofonly

En effet, ça ne plante plus, mais on est en mode "low graphics". Quasiment illisible, mais le processus d'installation de Jaunty est tellement simple (et puis je le connais un peu par coeur) que je m'en suis accommodé (suivant / suivant / suivant sauf pour le nom d'utilisateur...).

L'installation s'est déroulée sans autre problème. La machine a redémarré.

Cependant, une fois installé, pas moyen d'obtenir autre chose que le mode "low graphics". Mes différentes tentatives, basées sur des recherches Google, échouaient : ni le driver fbdev, ni l'option usefbdev = true ou false du driver ati n'y faisaient.
Heureusement un vieux souvenir d'une installation de Debian sur cette machine il y a plusieurs années m'a sauvé : la magie, c'est vga=771. J'ai donc enlevé le video=ofonly de /etc/yaboot.conf pour le remplacer par

vga=771

, sudo ybin -v et hop reboot... Miracle, un bel écran Jaunty flambant neuf. Je n'ai pas réinstallé le système pour voir si cette option dès l'installation permet d'avoir une jolie installation graphique. En fait je suppose que oui.

Encore quelques réglages : le clavier en particulier, choisir clavier portable apple (de mémoire, le nom doit ressembler) dans les préférences clavier de gnome, pour obtenir en particulier le @ sur la touche en haut à gauche, réinstaller b43 fw_cutter pour qu'il ailles chercher le firmware sur le net (j'ai une carte wifi pcmcia qui utilise cette puce), un petit thème Humanoid OSX, une édition de gconf-editor pour mettre les boutons de metacity à la mac, bref, des détails.

Le résultat est spectaculaire. Firefox se lance en moins de 10 secondes, le goulet d'étranglement étant le processeur. La plupart des petites applications se lancent instantanément. Les plus grosses sollicitent le G4/400, qui ne suit pas si mal pour un cpu vieux de près de 10 ans. En moyenne, la machine réagit très bien, même f-spot (mono :-( ) est utilisable et répond plutôt vite une fois les miniatures calculées une première fois, malgré mes quelques 7000 photos de famille !

Concernant Flash, j'étais un peu inquiet... personnellement je m'en passe fort bien, mais ma chère et tendre n'aurait pas compris pourquoi elle ne pouvait plus accéder à certains sites... Et bien sûr Adobe ne fournit pas de version linux/powerpc de son lecteur... J'ai donc installé gnash, et je suis très heureusement surpris. Ça marche plutôt bien, et les progrès depuis un ou deux ans sont très spectaculaires.

Bref, merci Ubuntu, merci Debian, merci la communauté !
  • # SSD

    Posté par . Évalué à 3.

    Je me posais la question de la pertinence d'un SSD pour un eeepc (1000HE). Par exemple, le Vertex 2 d'OCZ en 30Go qui coute 130€.

    J'avoue que j'ai de plus en plus envie d'essayer :)

    "La première sécurité est la liberté"

    • [^] # Re: SSD

      Posté par (page perso) . Évalué à 3.

      J'ai un Vertex 30Go (payé un peu plus cher à son lancement...) et ça défonce tout !

      C'est sur un machine Windows Seven 64b, mais je ne m'excuserais pas ;-)
      (c'est pour bosser, avec la suite Adobe toussa...)

      Si t'as le budget, les OCZ/Vertex sont vraiment bon.

      PS :rien à voir avec le SSD d'origine de mon EEPC900A qui ressemble à une fourmis asthmatique...
      • [^] # Re: SSD

        Posté par . Évalué à 2.

        Tu utilises une suite adobe sur un netbook ?

        J'estimais qu'un Atom était bien peu puissant pour utiliser la vitesse d'un SSD correct. Le problème des vertex est qu'il existe en 2 versions.

        L'une 'marketing' avec des gros chiffres max et une deuxième dont les gros chiffres sont plus petit mais les chiffres pire cas sont beaucoup plus intéressant (ios random en 512B).

        "La première sécurité est la liberté"

        • [^] # Re: SSD

          Posté par (page perso) . Évalué à 2.

          Rectification.

          J'utilise la suite Adobe sur une machine de bureau (Athlon X2 6000 / 4Go DDR / Vertex 30Go / WinSeven 64b).

          La comparaison avec l'EEEPC900A :
          Il possède un SSD 8Go de merde :-\ à la moindre écriture qui ne rentre pas dans le minuscule cache ça te fige l'OS (c'est normal, mais le cache est vraiment trop petit).
          C'est inutilisable sous Windows (en même temps il est pas vendu pour ça) et pas super agréable sous un linux "classique" (comprendre toute distribution hors Xandros d'origine ou Mobilin Intel)



          Sur le Vertex 30g, il y a un cache de 64mo, c'est vraiment bien (c'est du au contrôleur spécifique qui permet de câbler une puce de RAM externe).
          • [^] # Re: SSD

            Posté par . Évalué à 1.

            J'ai un 900A dont je suis très content. J'y ai installé Debian Lenny, et le SSD ne me pose aucun problème. Il en posait, justement, avec le Xandros d'origine. Quant à XP, les utilisateurs s'en plaignent mais je n'ai pas essayé. "Curieusement", leur réaction classique est de pester contre le SSD et non contre XP…
            • [^] # Re: SSD

              Posté par (page perso) . Évalué à 2.

              Que XP ait envi d'écrire qqchose à chaque fois qu'on bouge le petit doigt est en effet un défaut.. d'XP.

              Mais, si on peste contre le SSD, c'est que ce comportement d'XP n'est pas gênant sur un disque dure classique vieux de quelques années.
              Alors que sur un SSD tout neuf, même si on accepte les performances limitées d'un matériel pas cher, on peut se plaindre de l'aberration au niveau du cache.

              Surtout vu le prix d'une puce RAM de nos jours...
              Tirer les prix c'est nécessaire pour sortir un 900A à 300€ TTC.
              Mais c'est con d'économiser sur ce genre de chose. Ca tue le confort d'utilisation pour un détail...
    • [^] # Re: SSD

      Posté par . Évalué à 4.

      Hey,

      je viens d'investir (enfin ma boîte) dans un OCZ Vertex Series 60 pour mon portable DELL, je tourne actuellement sur une Jaunty en ext4, je confirme, c'est juste hallucinant!

      Boot en quelques secondes, Eclipse qui se lance en 3 secondes, les applications traditionnelles se lancent instantanément...

      Bref, un très très bon investissement pour les impatients ;)
      • [^] # Re: SSD

        Posté par . Évalué à 4.

        Je confirme que c'est vraiment le pied. Pour ma part j'ai mis 2 Vertex 30Gb en Raid0 et ext4 sur une Ubuntu 9.04.

        Le boot de grub à KDE fonctionnel prends 22 secondes, OOo ce lance en moins de 2 secondes (premier lancement), Firefox instantanément etc ... C'est vraiment du bonheur.

        Reste à espérer que c'est in investissement sur le long terme.
  • # Pour ceux comme moi...

    Posté par (page perso) . Évalué à 6.

    qui se sont dit "mais je croyais qu'Ubuntu ne supportait plus l'architecture powerpc ?", c'est toujours d'actualité. Le support est communautaire, et effectivement, on trouve une Ubuntu 9.04 : http://wiki.ubuntu.com/PowerPCDownloads
    • [^] # Re: Pour ceux comme moi...

      Posté par . Évalué à 4.

      Qui dit plus de support ne dit pas plus de développement.

      Y'a encore des gens qui développement Ubuntu/PowerPC. Par contre, en cas de problème, Canonical se contentera d'un "c'est plus supporte".
    • [^] # Re: Pour ceux comme moi...

      Posté par (page perso) . Évalué à 2.

      Sinon il suffit de remonter à la source. Debian supporte plusieurs architectures. Ma station sun sparc en sait quelque chose.

      "It was a bright cold day in April, and the clocks were striking thirteen" - Georges Orwell

  • # ssd pour /

    Posté par (page perso) . Évalué à 4.

    J'ai achetté un SSD OCZ "solid", il parait qu'ils sont très mauvais en écriture (il se figerait quelques secondes parfois, ce serait du a leur contrôleur commun à beaucoup de SSD anciens/bas de gamme). Mais peu importe, la vitesse en lecture/temps d'accès est très bonne. J'ai donc acheté ce modèle bien moins chère que les autres, uniquement pour la partition racine (/home et /var sont sur un vrai disque). Le résultat est vraiment très bon, boot et lancement d'applis très rapide. Ça rend l'utilisation de la machine bien plus véloce dans son utilisation quotidienne.
  • # Questions

    Posté par (page perso) . Évalué à 2.

    Comme tu le dis dans ton cas, le goulot d'étranglement est le Processeur. Mais quel quantité de mémoire as-tu? Et quel Bureau utilises-tu? (Gnome)? As-tu beaucoup de swap utilisé?
    C'est ce qui m'inquiète le plus dans la résurrection d'ordinosaure : un processeur un peu lent, un manque de mémoire...

    Sinon, merci pour ce retour d'expérience détaillé, c'est très intéressant et ça fait effectivement envie de changer, même si ça reste encore un peu cher.
    • [^] # Re: Questions

      Posté par . Évalué à 1.

      Côté mémoire, la machine dispose de 768 Mo. Du coup, jusqu'à présent, j'ai évité le swap... J'ai même hésité à ne pas créer de partition de swap...

      J'ai aussi rajouté dans sysctl.conf les lignes suivantes :

      vm.swappiness=1
      vm.vfs_cache_pressure=50

      Elles sont censées réduire la propension du système à swapper.

      Par ailleurs, je suis resté sur gnome pour l'instant, mais je pense que j'essaierai xfce pour voir. De la même façon, il faut que je teste epiphany-browser.
      Mais globalement, je confirme, même avec gnome / firefox / etc., c'est plutôt réactif.
    • [^] # Re: Questions

      Posté par . Évalué à 1.

      Voici quelques petits réglages supplémentaires que j'ai effectués pour améliorer encore un peu les choses :

      - j'ai essayé xfce, mais je ne suis pas spécialement convaincu... j'en reste à gnome. Néanmoins, la tentative m'a fait découvrir gpicview... donc :

      - remplacer eye-of-gnome par gpicview : même fonctionnalité, mais beaucoup plus rapide (3 secondes au lieu de 7 pour afficher un jpeg)

      - installer abiword et gnumeric. Quand même beaucoup moins lourds qu' Ooo.

      - enlever compiz et compagnie (de toute façon, les effets 3D ne sont pas possibles)

      - remplacer totem par vlc : totem est trop gourmand en ressources, il est incapable de jouer une video sur cette machine. Vlc le fait. Ne pas oublier le plugin vlc mozilla, au cas où.
      Par la même occasion, j'ai pu constater une différence entre les drivers vidéo fbdev et ati : avec fbdev, vlc prend des couleurs étranges (smurf effect). Avec le driver ati, tout rentre dans l'ordre.

      - enlever gnome-power-manager : il empêche le système d'entrer en veille quand on rabat l'écran. Si on l'enlève, tout marche (grâce à pbbuttons, qui est installé par défaut).

      - désactiver les services inutiles, ceux liés au bluetooth par exemple...

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.