Journal QGtkStyle désormais inclue dans Qt-4.5 !

Posté par (page perso) .
Tags : aucun
19
9
sept.
2008
Suite d'un précédent journal : http://linuxfr.org/~tanguy_k/26635.html
QGtkStyle permet à n'importe qu'elle application Qt de "ressembler" parfaitement à une application GTK+

Ce n'est pas nouveau (mon journal précédent datait du 16 mai 2008).
En revanche ce qui est nouveau, c'est que QGtkStyle fera partie de Qt-4.5 cf http://labs.trolltech.com/blogs/2008/09/05/qgtkstyle-now-par(...)

Bref une très bonne nouvelle pour tout ceux qui n'aiment pas utiliser une appli Qt/KDE depuis leur bureau GNOME car inconsistant graphiquement.

A mon avis Nokia et la plateforme Maemo (GTK+) ne sont pas étrangers à cette décision.

Page du projet : http://code.google.com/p/qgtkstyle/
  • # Re: QGtkStyle désormais inclue dans Qt-4.5 !

    Posté par (page perso) . Évalué à 2.

    En fait Nokia et la plateforme Maemo sont étrangers à la décision.
    Le style en question existais déjà avant l'aquisition (puisque celle-ci a eu lieu le 17 juin). Et quand le style a été publié, le but était déjà de l'inclure dans Qt 4.5.
    • [^] # Re: QGtkStyle désormais inclue dans Qt-4.5 !

      Posté par (page perso) . Évalué à 2.

      Les discussions entre Trolltech et Nokia ont commencé bien avant le 17 juin, et la décision de rachat aussi (il a fallut contacter tous les petits porteurs pour racheter leur action).

      Maintenant, est-ce vraiment ça qui ait motivé la création de QGtkStyle... reste à savoir.
      • [^] # Re: QGtkStyle désormais inclue dans Qt-4.5 !

        Posté par (page perso) . Évalué à 2.

        Et puis meme si ca a commence avant, ca change peut etre les priorites.

        genre le big boss : "bon les gars, Nokia voudrait avoir Qt sur Maemo mais il faut que ca s'integre joliment. Y'a deja un projet en cours mais desormais je veux qu'il y ai un dev a plein temps dessus au lieu de 2h par jour et que le truc marche pour le mois de septembre"
  • # Bug avec VirtualBox

    Posté par . Évalué à 1.

    J'ai un bug avec VirtualBox et ce style :


    Qt WARNING:

    This process is currently running setuid or getgid.
    GTK+ does not allow this therefore Qt cannot use the GTK+ integration.
    Try launching your app using 'gksudo',
    'kdesude' or a similar tool.

    See http://www.gtk.org/setuid.html for more information.


    Par contre, il marche bien en root.
    • [^] # Re: Bug avec VirtualBox

      Posté par . Évalué à 2.

      Ce n'est pas un bogue, lit le lien fourni ...
      Lancer des applications graphiques en root ou avec des outils genre gksudo c'est très mal.
      • [^] # Re: Bug avec VirtualBox

        Posté par . Évalué à 1.

        Quel lien ?

        Je sais très bien que c'est mal, c'est pourquoi je n'utilise pas encore ce thème.
      • [^] # Re: Bug avec VirtualBox

        Posté par (page perso) . Évalué à 8.

        [Hors sujet, parce que vbox est effectivement suid root]

        Soit l'explication donnée sur le lien est peu claire, soit c'est vraiment une décision complètement stupide. Si j'en crois ce que j'ai lu, GTK+ refuse d'exécuter tout programme suid ou sgid. Comme si ce mécanisme n'était utilisé qu'avec des binaires qui appartiennent à root.

        Et si je suid un binaire qui appartient à toto, GTK va refuser de le lancer aussi ? Désolé, mais le suid sert aussi à améliorer la sécurité, pas seulement à lancer tout et n'importe quoi en tant que root. Suid/sgid n'impliquent pas forcément élévation de privilèges, ils peuvent aussi participer à les réduire.

        Toutes mes excuses pour le hors-sujet, mais ce genre de choix dans le design de GTK m'énerve. Je suis d'accord avec ce qu'ils proposent à la fin : un backend suid root qui "fait gaffe" et qui cause au frontend graphique par un pipe. Mais ce n'est pas une raison pour décider que « suid root est tellement dangereux qu'on interdit n'importe quel suid".
        • [^] # Re: Bug avec VirtualBox

          Posté par (page perso) . Évalué à 4.

          Après avoir testé, je confirme, même pour un binaire qui n'appartient pas à root (toto:toto), l'utilisation de suid bloque son exécution.

          (process:7234): Gtk-WARNING **: This process is currently running setuid or setgid.
          This is not a supported use of GTK+. You must create a helper
          program instead. For further details, see:

          http://www.gtk.org/setuid.html

          Refusing to initialize GTK+.


          Ils suggèrent de créer un "helper program", qui, je présume, est lui-même suid. Sachant que ce bit n'est pas pris en compte pour les scripts, ça ne simplifie pas vraiment la vie...

          Ah, petite info croustillante, j'étais root quand j'ai tenté de lancer le programme. L'utilisation de suid aurait donc permis de réduire les privilèges...
  • # parfaitement

    Posté par . Évalué à -1.

    C'est toujours une bonne nouvelle pour la cohérence des applis bureau dans Linux (un peu comme dans Aqua : peu importe la biblio, c'est pareil). Cependant, ce qui fait un logiciel gnome n'est pas pango, mais plutôt le GNOME HIG ... et pour ça, KDE 4 est loin du compte.

    Cordialement,
    Étienne.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.