Forum Astuces.divers Ssd NVME et benchmark

Posté par (page perso) . Licence CC by-sa.
Tags : aucun
1
18
juil.
2019

Bonjour,

J'ai fais l’acquisition d'un ssd nvme M.2 (intel 760p 1to), une super affaire sur ebay.
Bref je clone mon système avec clonezilla et monte le ssd M.2 sur ma carte mère une Asus 320M-K qui a un port M.2 PCI-E 3.0 4x.

Je lance quelques benchmarks:

    dd if=/dev/zero of=/home/garfi/test.data bs=1M count=100 conv=fdatasync                                                                                       
    104857600 octets (105 MB, 100 MiB) copiés, 0,180896 s, 580 MB/s

    dd if=/dev/zero of=/home/garfi/test.data bs=1M count=1000 conv=fdatasync                                                                                      
    1048576000 octets (1,0 GB, 1000 MiB) copiés, 1,45612 s, 720 MB/s

    dd if=/dev/zero of=/home/garfi/test.data bs=1M count=10000 conv=fdatasync                                                                                     
    10485760000 octets (10 GB, 9,8 GiB) copiés, 13,4457 s, 780 MB/s

    dd if=/dev/zero of=/home/garfi/test.data bs=1M count=100000 conv=fdatasync                                                                    
    104857600000 octets (105 GB, 98 GiB) copiés, 144,601 s, 725 MB/s

En copiant 100go le processeur peut monter à 90% d'utilisation. Mais 1m44 pour la copie!
C'est des performances très très bonne mais ça n'exploite pas toute la capacité de ce ssd qui peut monter à 1625 Mo/s suivant les spécifications.

Comme dit un peu plus haut ma carte mère à un port M.2 PCI-E 3.0 4x donc de dernière génération si je ne me trompe pas.
Le bios date de juin 2019 et je n'ai pas vu d'option dedans concernant le NVME.

Avez vous un idée pour l'utilisation de toute ses capacités?

  • # Plusieurs choses

    Posté par (page perso) . Évalué à 9 (+7/-0).

    1. N'oublie pas que le débit communiqué est le débit "théorique", atteint sous certaines conditions uniquement. Dans la réalité, il est rare d'atteindre ce débit.

    2. Ton test introduit déjà des biais: tu écris via dd un fichier sur un filesystem. Tu amènes donc déjà un facteur limitant dans ton test: les performances de ton filesystem.

    3. Tu as choisis de travailler avec une taille de bloc de 1Mo pour ton dd: es tu sûr que cette taille de bloc est optimale ?

    4. Si ton CPU monte à 90% d'utilisation, le goulot d'étranglement est peut être plus du côté de ce dernier que du côté du SSD (et la gestion du FS n'y est probablement pas étrangère).

    Au final, après une recherche google rapide, les débits que tu annonces semblent similaire à ceux constatés lors d'un benchmark effectué par un site spécialisé.

    Si tu veux réellement faire un test de performance pure, je te conseille de:

    • Travailler directement sur une partition ou sur le disque entier, sans filesystem entre deux: dd if=/dev/zero of=/dev/sdX

    • Faire varier les tailles de bloc (bs=XX).

    Si tu as l'occasion de faire ces tests, je serai curieux d'avoir tes résultats !

    • [^] # Re: Plusieurs choses

      Posté par (page perso) . Évalué à 0 (+0/-1).

      J'ai refais différents test avec des tailles de block différents et j’obtiens sensiblement les mêmes résultat.
      Et, je ne pourrais pas travailler sur le disque sans fs, j'ai mon système installé dessus.
      Merci pour ton message qui m'a guidé.

      • [^] # Re: Plusieurs choses

        Posté par (page perso) . Évalué à 3 (+1/-0).

        je ne pourrais pas travailler sur le disque sans fs, j'ai mon système installé dessus.

        Tu peux faire un test en lecture vers /dev/null
        Comme en plus la lecture est censée être plus rapide que l'écriture, tu auras une meilleure idée de se qui se passe.

        • [^] # Re: Plusieurs choses

          Posté par . Évalué à 5 (+3/-0).

          Et pour que le test soit vraiment significatif, il faut démarre sur un système live, pour que le SSD ne doit pas sollicité par le système pendant le test.

  • # vider le tampons E/S

    Posté par . Évalué à 2 (+2/-1).

    Bonjour

    Il reste peut-être encore des données dans les tampons E/S,
    qui sont en attente de transfert vers le disque.

    Essaye avec :

    dd if=/dev/zero of=/home/garfi/test.data bs=1M count=100000 conv=fdatasync && sync
  • # Config NVMe de la CM ?

    Posté par . Évalué à 6 (+4/-0).

    J'ai monté un SSD NVMe également et dans la doc de la CM il y avait un tableau sur les lignes PCI-E et leur utilisation : j'ai dû déseactiver des ports SATA pour avoir un NVMe "full speed".

    Sur un Samsung 970 Pro :

    $ dd if=/dev/zero of=~/test.data bs=1M count=5120 conv=fdatasync     
    5120+0 enregistrements lus
    5120+0 enregistrements écrits
    5368709120 octets (5,4 GB, 5,0 GiB) copiés, 4,60092 s, 1,2 GB/s
    

    => Il est donné pour le double en écriture.

    En théorie, la théorie et la pratique c'est pareil. En pratique c'est pas vrai.

  • # mise à jour bios

    Posté par (page perso) . Évalué à 1 (+0/-0).

    Pour info après une sortie d'un nouveau bios de ma carte mère asus 320M-k, les débit son meilleurs..!
    dd if=/dev/zero of=/home/garfi/test.data bs=1M count=10000 conv=fdatasync

    10485760000 octets (10 GB, 9,8 GiB) copiés, 9,62528 s, 1,1 GB/s

Envoyer un commentaire

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.