Forum général.général azureus - java

Posté par  .
Étiquettes : aucune
0
26
nov.
2005
Bonjour je suis sous Debian, et j'essais d'installer azureus.
Lors de son installation tout semble bien ce passer jusqu'au lancement ou là ... :
/usr/bin/azureus: line 5: /usr/share/java-config/libswt2.1-java: Aucun fichier ou répertoire de ce type
puis, dans l'espoir de réparé ca, je suis allé dans le répertoire : /usr/share/java-config/ j'y est trouvé un fichier:libswt2.1-gtk2-java que j'ai copié et renomé en libswt2.1-java et le message :
Exception in thread "main" java.lang.NoClassDefFoundError: java/nio/charset/Charset
at org.gudy.azureus2.core3.internat.LocaleUtil.(Unknown Source)
at org.gudy.azureus2.ui.swt.MainWindow.main(Unknown Source)
donc voila je ne sais pas trop quoi faire... s'il y a une idée...
merci
totoro
  • # version JAVA

    Posté par  . Évalué à 2.

    verifie qu'azureus ne necessite pas une certaine version de ta plateforme JAVA

    en allant sur le site ils indiquent qu'il faut JAVA JRE 1.5 ( je crois que c'est la version 5 en fait) de sun
    http://java.com/getjava
    • [^] # Re: version JAVA

      Posté par  . Évalué à 1.

      en fait il semble être installé correctement, quand je fait le teste d'installation sur le site de sun, il est reconnut et fonctionne...
      • [^] # Re: version JAVA

        Posté par  (site Web personnel) . Évalué à 1.

        essaye ca
        java -version
        Ca te donne quoi ?
        • [^] # Re: version JAVA

          Posté par  . Évalué à 1.

          java version "1.3.1"
          Java(TM) 2 Runtime Environment, Standard Edition (build Blackdown-1.3.1-FCS)
          Java HotSpot(TM) Client VM (build Blackdown-1.3.1-FCS, mixed mode)

          bon oki ... je dit plus rien je vais essayer une install plus manuel...
          • [^] # Re: version JAVA

            Posté par  . Évalué à 1.

            sous Debian il y a java-package qui permet de generer des .deb à partir des archives telechargables sur le site de SUN, IBM et blackdown.

            http://www.debian-administration.org/articles/142
            • [^] # Re: version JAVA

              Posté par  . Évalué à 1.

              Je viens d'essayer... et snif voila la réponce :
              cabane:/home/totoro# fakeroot make-jpkg jre-1_5_0_05-linux-i586.bin
              Creating temporary directory: /tmp/make-jpkg.XXXXgx6llh
              Loading plugins: blackdown-j2re.sh blackdown-j2sdk.sh common.sh j2re.sh j2sdk.sh j2se.sh sun-j2re.sh sun-j2sdk.sh

              No matching plugin was found.
              Removing temporary directory: done

              donc snif
              merci quand même totoro
              • [^] # Re: version JAVA

                Posté par  . Évalué à 1.

                tu dois avoir une ancienne version de java-package, si tu te le sens tu peux modifier le fichier /usr/share/java-package/sun-j2re.sh
                et y ajouter la section:

                "jre-1_5_0_"[0-9][0-9]"-linux-i586.bin") # SUPPORTED
                j2se_version=1.5.0+update${archive_name:10:2}
                j2se_expected_min_size=16 # 16542512 bytes
                found=true
                ;;


                ou encore, installer la version de testing/unstable, ca devrait passer vu le peu de dépendances:
                http://packages.debian.org/unstable/misc/java-package
                • [^] # Re: version JAVA

                  Posté par  . Évalué à 1.

                  en unstable il me fait la même chose... snif
                  • [^] # Re: version JAVA

                    Posté par  . Évalué à 1.

                    Bon ben... j'ai déinstallé tous les Java que j'avais et reinstallé, puis j'ai installé azureus avec le fichier que j'ai trouver sur le site officiel (et non avec atp-get) et ca marche
                    donc voila, merci pour tout
                    totoro

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.