Forum général.général Flatpak - Signal : impossible de lancer l'application

Posté par (page perso) . Licence CC by-sa.
0
8
juil.
2019

Bonjour,

J'utilise Signal pour échanger avec mes proches et je cherche maintenant à l'utiliser sur mon PC. Malheureusement, côté OS libre, l'éditeur ne prend en charge qu'Ubuntu/Debian alors que j'utilise Fedora. Cependant j'ai trouvé qu'il existait une version Flatpak de l'application disponible sur Flathub.

Après avoir installé normalement l'application :

flatpak install signal
Je la lance via l'icône mais rien se passe…

Je relance via le terminal cette fois :

flatpak run org.signal.Signal
Et voilà le message d'erreur que j'obtiens :

    Gtk-Message: 07:52:11.421: Failed to load module "canberra-gtk-module"
    Gtk-Message: 07:52:11.422: Failed to load module "pk-gtk-module"
    Gtk-Message: 07:52:11.424: Failed to load module "canberra-gtk-module"
    Gtk-Message: 07:52:11.424: Failed to load module "pk-gtk-module"
    Set Windows Application User Model ID (AUMID) { appUserModelId: 'org.whispersystems.signal-desktop' }
    NODE_ENV production
    NODE_CONFIG_DIR /app/Signal/resources/app.asar/config
    NODE_CONFIG {}
    ALLOW_CONFIG_MUTATIONS undefined
    HOSTNAME undefined
    NODE_APP_INSTANCE undefined
    SUPPRESS_NO_CONFIG_WARNING undefined
    userData: /home/user/.var/app/org.signal.Signal/config/Signal
    config/get: Did not find user config file, cache is now empty object
    config/get: Did not find ephemeral config file, cache is now empty object
    Unhandled Error: Error: /home/user/.var/app/org.signal.Signal/cache/.org.chromium.Chromium.ATF8wi: échec d'adressage (mapping) du segment de l'objet partagé
        at process.module.(anonymous function) [as dlopen] (ELECTRON_ASAR.js:160:31)
        at Object.Module._extensions..node (internal/modules/cjs/loader.js:722:18)
        at Object.module.(anonymous function) [as .node] (ELECTRON_ASAR.js:169:18)
        at Module.load (internal/modules/cjs/loader.js:602:32)
        at tryModuleLoad (internal/modules/cjs/loader.js:541:12)
        at Function.Module._load (internal/modules/cjs/loader.js:533:3)
        at Module.require (internal/modules/cjs/loader.js:640:17)
        at require (internal/modules/cjs/helpers.js:20:18)
        at Object.<anonymous> (/app/Signal/resources/app.asar/node_modules/@journeyapps/sqlcipher/lib/sqlite3.js:4:15)
        at Object.<anonymous> (/app/Signal/resources/app.asar/node_modules/@journeyapps/sqlcipher/lib/sqlite3.js:190:3)
    Unhandled Error
    Error: /home/user/.var/app/org.signal.Signal/cache/.org.chromium.Chromium.ATF8wi: échec d'adressage (mapping) du segment de l'objet partagé
        at process.module.(anonymous function) [as dlopen] (ELECTRON_ASAR.js:160:31)
        at Object.Module._extensions..node (internal/modules/cjs/loader.js:722:18)
        at Object.module.(anonymous function) [as .node] (ELECTRON_ASAR.js:169:18)
        at Module.load (internal/modules/cjs/loader.js:602:32)
        at tryModuleLoad (internal/modules/cjs/loader.js:541:12)
        at Function.Module._load (internal/modules/cjs/loader.js:533:3)
        at Module.require (internal/modules/cjs/loader.js:640:17)
        at require (internal/modules/cjs/helpers.js:20:18)
        at Object.<anonymous> (/app/Signal/resources/app.asar/node_modules/@journeyapps/sqlcipher/lib/sqlite3.js:4:15)
        at Object.<anonymous> (/app/Signal/resources/app.asar/node_modules/@journeyapps/sqlcipher/lib/sqlite3.js:190:3)

Je ne comprends pas ce qui ne va pas…
Une dépendance manquante ? Il y a un truc avec Chromium mais je ne sais pas quoi…

Avez-vous une idée sur comment réparer la chose ?
Merci d'avance.

  • # A tout hasard

    Posté par . Évalué à 3.

    As tu essayé de déplacer ou supprimer le fichier listé dans le log ( /home/user/.var/app/org.signal.Signal/cache/.org.chromium.Chromium.ATF8wi) ?

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.