Forum général.général Problème gestion énergie MSI WIND U100 avec GNOME.

Posté par  .
Étiquettes : aucune
0
26
nov.
2010
Bonjour à tous,
Depuis quelques jours je m’arrache les cheveux à résoudre un problème d’arrêt intempestif du disque dur sur un netbook MSI WIND U100 sous Archlinux.
Le problème : Lorsque l’interface graphique démarre, le disque dur s’arrête toutes les dix seconde d’inactivité, ce qui risque à terme de réduire sa duré de vie et ralenti considérablement les accès. La seule solution que j’ai trouvé pour l’instant est de faire un hdparm –B254 /dev/sda en console après que l’interface graphique soit lancée.
J’ai essayé de procéder par élimination pour tenter de comprendre à quel endroit lors du démarrage de GDM une demande du changement de mode de mise en veille du disque dur intervient.
Premier test, je désactive le lancement de gdm dans le rc.conf. A ce stade en console tout se passe bien, le disque dur ne se met pas en veille.
2. Pensant que l’initialisation de GDM était en cause je lance directement GNOME via la commande startx à partir d’un compte utilisateur non privilégié, le problème revient.
3. Vérification faite dans les paramètres via gconf-editor pour confirmer que la configuration de gnome-power-manager, les options « shutdown har disk » sont bien désactivée.
4. Puisqu’il en est ainsi, je désinstalle complètement gnome-power-manager mais le problème revient toujours.
5. Je désinstalle la commande hdparm pour voir, miracle cette-fois-ci, le disque du laptop ne se met plus en veille lorsque GDM se lance.
OK, donc à un moment ou un autre un appel à la commande hdparm doit être fait lors du chargement de GNOME mais à quel endroit. J’ai fait un grep brutal dans /etc et /var avec en motif de recherche « hdparm » rien trouvé dans les scripts d’initialisation de GNOME au passage bien compliqué.
En dernier ressors j’ai tenté de désactiver les daemons acpid, cpufreq, hal, mais le problème persiste.
Une recherche sur Google n’a rien donnée non plus, c’est à n’y rien comprendre.
Et vous, chers utilisateurs, avez-vous déjà rencontré ce type de problème ? Si quelqu’un à une idée ou du moins quelques pistes de recherche je suis preneur.
Merci de m’avoir lu.
  • # econmie d'energie

    Posté par  . Évalué à 3.

    tu es allé voir simplement dans le gnome control center
    voir quelles etaient les options d'economie d'energie ?

    de memoire sur un portable, tu as deux possibilité
    - avec alimentation secteur
    - sans alimentation secteur

    et donc derriere tu as quelques reglages differents.

    tu as aussi cherché hdparm dans /etc et /var
    seulement la config gnome de ton utilisateur se trouve dans /home/tonuser/.gconf
    /home/tonuser/.gconf2
    ou bien encore
    /home/tonuser/.gnome
    ...
    • [^] # Re: econmie d'energie

      Posté par  . Évalué à 2.

      Merci pour ta réponse, je pensais que le fait d’avoir viré temporairement gnome-power-manager permettait d’éliminer une fois pour toute se service comme étant à l’origine du problème.
      Dans gnome-control-center, en mode secteur ou batterie, la case à cocher « arrêt des disques durs dès que possible » est bien désactivée.
      Quant au répertoire personnel dans .gconf, rien trouvé non plus.
      • [^] # Re: econmie d'energie

        Posté par  . Évalué à 2.

        as-tu essayé avec un livecd, de la meme distrib et/ou d'une autre...

        si ca se trouve ca vient soit d'un souci ACPI, soit de la configuration d'un autre paquet
        • [^] # Re: econmie d'energie

          Posté par  . Évalué à 2.

          Sur cette même machine je n’avais pas ce souci avec une Ubuntu 10.04. En fait, en procédant toujours par élimination, si je renomme le daemon upower empêchant ainsi son chargement alors le problème disparait.
          Pourquoi ce foutu upower se permet de paramétrer le disque ainsi lors du chargement, là est la question. D’autre part, je crois que le HDD dans ce laptop est merdique, il s’arrête toujours très rapidement avec un hdparm –B1 par exemple.
          • [^] # Re: econmie d'energie

            Posté par  . Évalué à 2.

            … il s’arrête toujours très rapidement avec un hdparm –B1 par exemple.
            Ça me semble plutôt normal, non ?
            Tu peux également regarder du côté de l'option -S de hdparm.
  • # gnome ?

    Posté par  (site Web personnel) . Évalué à 3.

    1) est-ce que gnome respecte ce qui est dans /etc/hdparm.conf ?
    /dev/sda {
    apm = 254
    spindown_time = 20
    }

    dans ce fichier permet de mettre les valeurs que je veux au démarrage.

    2) Je ne pense pas que ça ait un rapport avec "shutdown hard disk" dans gnome-power-manager. Ce serait plus sur le spindown que ça se passe.

    3) laptop-mode-tools est installé ? Configuré ?
    • [^] # Re: gnome ?

      Posté par  . Évalué à 2.

      Merci pour ces quelques pistes, je réponds tardivement à ta réponse. Pour l’instant j’ai fait un touch de /etc/pm/sleep.d/harddrive pour empêcher l’exécution de ce script lors du lancement de GNOME et le disque ne se met plus en veille donc le problème est pour l’instant réglé. Je persiste à penser que la gestion de l’énergie sous Linux est loin d’être évidente entre le laptop-mode, les scripts pm-utils, les daemons upower et udisk.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.