Forum général.général Sata, boot et OpenSUSE 10.2: y aurait-il un os ?

Posté par  .
Étiquettes : aucune
0
25
mar.
2007
Je viens de me construire une nouvelle bécane, sans être une bête de compétition, c'est toutefois une machine avec des performances honorables. C'est parce que j'ai rencontré un petit problème que je donne le détail de la configuration, espérant trouver une réponse à ce problème:

Boitier: Cooler Master, Très bonne conception et silencieux.

Carte mère: ASUS M2N-SLI Deluxe (nForce 570 SLI - Socket AM2 - FSB 2000)

Processeur: AMD Athlon 64 X2 Dual Core 4400+

Mémoire: DDR2 1GB (512MBx2) DDR800 KINGSTON

Vidéo: ASUS Extrem N7600GS Silent/HTD PCIe (GeForce)

Disques durs:
1: SATA150 80GB - 7200 Western. Monté dans un rack amovible, connecté sur SATA1.
Partitions:
/dev/sda1: 54,9 Mo, Reiserfs, monté comme /boot.
/dev/sda2: 517,7 Mo, Swap.
/dev/sda3: 517,7 Mo, Swap.
/dev/sda4: 73,4 Go, Reiserfs, monté comme /.

2: SATA300 400GB - 7200 Western. Monté en fixe, connecté sur SATA2.
Partitions:
/dev/sdb1: 517,7 Mo, Swap.
/dev/sdb2: 517,7 Mo, Swap.
/dev/sdb3: Partition étendue.
/dev/sdb5: 8,4 Go, Reiserfs, monté comme /home.
/dev/sdb6: 1 Go, Reiserfs, monté comme /u, divers utilitaires personnels.
/dev/sdb7: 8,4 Go, Reiserfs, monté comme /photos, comme son nom l'indique, des photos.
/dev/sdb8: 8,4 Go, Reiserfs, monté comme /telecharge, divers logiciels libres non installés.
/dev/sdb9: 8,4 Go, ext2, monté comme /lfs, Linux from scratch en cours de modification.
/dev/sdb10: 337 Go, Reiserfs, Réserve, non monté.

Lecteur DVD: DVD-ROM SAMSUNG, connecté sur IDE0 en Master.

Graveur DVD: NEC AD-5170A, connecté sur IDE0 en Slave.

Écran: Philips 109 S4, récupéré de l'ancien PC.

Imprimante,
Scaneur: HP, PSC 2410, également récupérée de l'ancien PC.


Hier, je vais chercher le matériel, je débarrasse le bord* sur ma table de travail et je commence le montage.
Celui-ci terminé, je mets sous tension, pas de fumée suspecte, pas d'odeur encore plus suspecte, le processeur est tiède, sans plus, la carte vidéo ne commence pas par cramer, bref, tout me semble OK
J'introduis le DVD d'installation de l'OpenSUSE 10.2, le boot est OK, Je paramétrise les partitions et choisis les packages à installer, j'ai pas mal d'exigences à ce sujet et le choix me prend du temps.
Je lance l'installation, je vais prendre un café en attendant que les choses se passent et je reviens pour la phase de configuration du réseau et du matériel. Tout se passe comme dans un rêve, tout, mais absolument tout mon matériel est reconnu automatiquement, mes seules interventions consistent à donner nom du FAI et paramètres de connexion, à faire imprimer une page de test et à scanner une page pour contrôler.
Tout baigne, en moins de 6 heures, d'un tas de composants sur une table, je suis passé à un système parfaitement opérationnel.

Je commence à faire joujou avec, je compile un assez gros projet que j'ai en cours de développement et je m'aperçois que cela me prends environ deux fois moins de temps qu'auparavant, bref que du bonheur ! Je fais un shutdown, j'arrête la machine et je vais me coucher.

Le lendemain, je mets la machine sous tension, le POST se déroule sans aucun problème, mais après, refus absolu de booter, l'écran reste obstinément noir. Je vais vois dans le BIOS l'ordre des périphériques de boot, normal: DVD, HD. J'utilise GRUB pour booter, dans la paramétrisation de GRUB tout me paraît correct également, mais le système s'obstine à ne pas booter. Je mets le DVD d'installation, puis RESET: le système boot sur le DVD. Je choisis alors l'option "booter le système installé" et là, oh miracle, le système boot sans aucun problème et j'ai de nouveau une machine parfaitement utilisable.

Bien sûr, je peux utiliser mon PC et bootant à partir du DVD d'installation, cela prends un peu plus de temps, mais, surtout, cela n'est pas très propre. J'aimerais que le boot se passe normalement. Alors si quelqu'un a une idée, je suis preneur.

Merci d'avance.
  • # Editer le menu de grub ?

    Posté par  . Évalué à 1.

    Avez-vous essayer de changer la description du disque où est sensé se trouver le noyau ?
    root (hd1,*) : plutôt que root (hd0,*) ?

    (Le bios ne voit pas forcément les disques dans le même ordre que le noyau linux qui est utilisé par votre système ou le dvd de secours)
    • [^] # Re: Editer le menu de grub ?

      Posté par  . Évalué à 1.

      Tout d'abord, je dois dire que l'administration d'un système n'est pas mon point fort (moi, c'est plutôt la programmation industrielle et l'art d'économiser des micros-secondes). . Bien sûr, je sais administrer des choses simples, mais dès qu'il y a un problème, je flotte un peu.

      Au niveau du BIOS, j'ai mis l'ordre de priorité de boot suivant: "CDROM, Hard Disk, Removable". Je pars du principe que Hard Disk représente SATA1 (c'est vrai que si l'on commence à avoir des principes en informatique, où va-t-on ? lol).

      En principe, dans grub, c'est la partition correcte qui est donnée (sda4) comme contenant le noyau.

      Merci de votre réponse.
      • [^] # Re: Editer le menu de grub ?

        Posté par  . Évalué à 2.

        Attention root= /dev/sda4 est la chaîne de caractères que grub passe en argument au noyau qu'il charge.

        Mais avant, si vous voyez le menu grub, c'est que ce petit programme est installé sur le masterblock du disque sur lequel le bios boote (Votre SATA1).

        Mais il faut indiquer au brave grub sur quel disque/partition se trouve le noyau qu'il va lancer. C'est l'objet de la première ligne qui s'affiche après avoir appuyé sur "e" . Elle contient une ligne de genre:
        boot hd(0,1) ( ou hd(0,2) ). Dans le système de dénomination de grub, c'est toujours hd que le disque soit scsi, sata ou pata.

        A la ligne suivante vous trouvez le nom (dans le système de fichier qui se trouve sur la partition indiquée plus haut) du fichier qui contient le noyau à charger.
        On y trouve aussi les options de boot, dont l'indication de la racine "root=/dev/sda4 " partition ici décrite dans le "langage" du noyau linux.

        A savoir. Quand vous aurez choisi d'éditer la ligne boot, effacez ce qui est écrit et appuyez sur TAB, grub va vous proposer des choix
        et vous verrez quel est le bon disque d'après le nombre de ses partitions . Vous cherchez le disque avec 4 partition et vous en voulez la première.

        voilà
        • [^] # RÉSOLU ! Editer le menu de grub ?

          Posté par  . Évalué à 1.

          Le problème est résolu.

          C'est ma faute, c'est ma très grande faute !

          J'avais mis, comme paramètre de boot dans le BIOS la séquence: CD-ROM, HARD DISK, ... sans chercher plus loin, persuadé que l'option HARD DISK se référait automatiquement à SATA1.

          Ce matin, en allant relire pour la Xième fois les paramètres du BIOS, je sélectionne HARD DISK, et, pratiquement par inadvertance, je tape RETURN, oh miracle, un sous-menu apparait, me donnant le choix entre SATA1 et SATA2. Bien entendu, loi de Murphy oblige, la sélection est sur SATA2 ! Je change cette sélection et tout rentre dans l'ordre.
          Phig, navré de vous avoir fait perdre du temps par ma stupidité et encore merci.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.