Forum général.général Sony ericsson w300i

Posté par  .
Étiquettes : aucune
0
11
juil.
2007
Mon charmant petit portable (voir modéle en entête) est complétement ignoré par linux ..lorsque je le connecte en USB .
Usbview ne le voit même pas ....
Quelqu un a t il une idée pour le faire communiquer avec mon pc ?
PS:j ai bien un cdrom pour Windows mais qui ne tourne qu' à partir de Windows2000 et je n' ai qu un vieux Windows ME sur lequel le progiciel ne s' installe pas .
  • # au départ

    Posté par  . Évalué à 1.

    le kernel parle a l'usb de ton portable, cela m'étonnerait qu'il soit aussi dédaigneusement ignoré par ton pc.

    Tu peut faire un lsusb -vv ou un dmesg apres la connexion de ton portable pour voir ce que le kernel en dit.
    Il est fort probable qu'il faille un drivers specifique pour dialoguer avec ton portable...
    • [^] # Re: au départ

      Posté par  (site Web personnel) . Évalué à 2.

      Si les w300i sont très récent et ton kernel un peu vieux, ou plutôt ta table d'identification HAL un peu vieille, le noyau voit ton périphérique mais ne sait pas quoi en faire : est ce un DD externe ? Une caméra ?
      • [^] # Re: au départ

        Posté par  . Évalué à 1.

        Le w300i est un téléphone portable "sponsorisé" par Orange .
        ses fonctions sont intéressantes mais c' est un enfer pour la connction usb sur PC: un cdrom d' installation de logiciels est fourni mais ne fonctionne qu' à partir de windows 2000 (mac linux on connait pas) ...mon windows étant un millenium, pas de possibilité pour moi .
        j' ai essayé sur un windows XP au boulot ce matin : tout s' installe parfaitement .....mais le sony ericsson n' est pas pour autant détecté!!!! une vraie plaie : périphérique mal configuré ...
        A un moment donné j 'ai eu un espoir: le portable semblait être vu avec même une petite fenêtre me proposant plusieurs possibilités mais tout a redisparu illico aprés un clic de souris ....
        Pourtant à la base rien de compliqué : une carte sim , une carte mmc, une broche et l' usb .
        lorsqu'il est ainsi connecté mon portable me propose la fonction transfert de fichiers mais c' est inopérant ...

        Sous Linux:
        les messages "dmesg" :
        usb 4-1: new full speed USB device using uhci_hcd and address 2
        usb 4-1: unable to read config index 0 descriptor/all
        usb 4-1: can't read configurations, error -84

        puis au bout ' un moment :

        usb 4-1: new full speed USB device using uhci_hcd and address 2
        usb 4-1: unable to read config index 0 descriptor/all
        usb 4-1: can't read configurations, error -71
        • [^] # Re: au départ

          Posté par  . Évalué à 1.

          faut peut-etre voir quel est le soft qui tourne sur ce telephone.
          windows mobile ?

          et mettre à jour la table HAL de ton linux.
          • [^] # Re: au départ

            Posté par  . Évalué à 1.

            le soft qui tourne sur ce téléphone ? Aucune idée .
            Mettre à jour la table Hal ? comment fait on ?
            • [^] # Re: au départ

              Posté par  . Évalué à 1.

              le soft sur lequel tourne le telephone : ca doit se trouver dans le manuel, ou sur internet chez le fabricant.

              mettre à jour la HAL de ton linux, ben ca depend de ton linux.

              chez moi (ubuntu), mais aussi sur debian, il suffit de faire
              sudo update-pciids
  • # kmobiletools

    Posté par  (site Web personnel) . Évalué à 2.

    Mon W810i est utilisable avec kmobiletools en USB ou Bluetooth. Peut-être cela marchera-t-il pour le tien ?

    Et on peut aussi le monter en USB Mass Storage. Il suffit de sélectionner le mode sur le téléphone.

    L'association LinuxFr ne saurait être tenue responsable des propos légalement repréhensibles ou faisant allusion à l'évêque de Rome, au chef de l'Église catholique romaine ou au chef temporel de l'État du Vatican et se trouvant dans ce commentaire

    • [^] # Re: kmobiletools

      Posté par  . Évalué à 1.

      Tu as mis quoi comme device en configuration de kmobiletools?
      Moi j ai essayé /dev/ttyS0 ... depuis le programme ne démarre plus !!!!
  • # J'en ai un

    Posté par  (site Web personnel) . Évalué à 1.

    J'ai le même modèle, et je l'utilise sans problème en mass storage.

    Je te recommande une mise à jour de ton système (kernel, hal...) et voir ce qui se passe...

    Personnellement, aucun problème avec mon ubuntu feisty. : il voit la mémoire intégrée au portable tout comme la carte d'extension.
    • [^] # Re: J'en ai un

      Posté par  . Évalué à 1.

      [J'ai le même modèle, et je l'utilise sans problème en mass storage.]

      Tu as un 300i ?

      [Je te recommande une mise à jour de ton système (kernel, hal...) et voir ce qui se passe...]

      Mon systéme est à jour :
      kernel 2.6.18-4
      hal: 0.5.9-2

      Il me manque peut être un module ?

      ou je dois updater le kernel en 2.6.21 ?
      • [^] # Re: J'en ai un

        Posté par  (site Web personnel) . Évalué à 1.

        Ma version de HAL est la 0.5.8.1, et mon noyau est un 2.6.20.

        Mais ça marchait déjà avec un noyau plus ancien, et avec edgy...

        Je n'ai rien fait de particulier pour que ça marche, j'avais directement branché et 2 icônes sont apparues et j'ai pu naviguer dans le contenu.
        • [^] # Re: J'en ai un

          Posté par  . Évalué à 1.

          Si tu as bien un w300i, j' aimerais bien ta liste lsmod .....
        • [^] # Re: J'en ai un

          Posté par  . Évalué à 1.

          J ai un peu progressé : l appareil est détecté à pleine charge et initialisé mais ....seulement par usbview (qui affiche tous les détails fabricant) .
          dmesg donne alors :
          new full speed USB device using uhci_hcd and address 54
          usb 1-2: configuration #1 chosen from 1 choice
          cdc_acm 1-2:1.1: ttyACM0: USB ACM device
          cdc_acm 1-2:1.3: ttyACM1: USB ACM device

          par contre échecs répétés lorsque je tente de me connecter avec wammu en indiquant /dev/ttyamc0 ou amc1 et en tentant les divers modes proposés ..

          kmobiletools n apparait pas lorsque je le lance !!! (un drôle de lacheur celui la!) : l' icone clignote puis dispaait ...le soft est présent dans les processus lancés ..encore un mystére .
          suis toujours bloqué à cette heure .
          • [^] # Re: J'en ai un

            Posté par  . Évalué à 1.

            personne pour au moins me donner son dmesg et lsmod lorsque la connection réussit ?
            personellement , ce que je parviens à faire de mieux aprés avoir reformaté la memory stick (systéme de fichier inconnu) et effectuer qqs update-pciids ;,c 'est en connectant le w300i par l' usb 1 (usb de base de ma carte mére) , d ' obtenir :
            en dmesg :

            usb 3-2: new full speed USB device using uhci_hcd and address 17
            usb 3-2: configuration #1 chosen from 1 choice
            scsi6 : SCSI emulation for USB Mass Storage devices
            usb-storage: device found at 17
            usb-storage: waiting for device to settle before scanning
            scsi7 : SCSI emulation for USB Mass Storage devices
            usb-storage: device found at 17
            usb-storage: waiting for device to settle before scanning
            Vendor: SEMC Model: Int.Memory Rev: 0000
            Type: Direct-Access ANSI SCSI revision: 00
            Vendor: SEMC Model: Mem-Stick Rev: 0000
            Type: Direct-Access ANSI SCSI revision: 00
            sd 6:0:0:0: Attached scsi removable disk sdb
            sd 7:0:0:0: Attached scsi removable disk sdc
            usb-storage: device scan complete
            usb-storage: device scan complete
            SCSI device sdc: 487261 512-byte hdwr sectors (249 MB)
            sdc: Write Protect is off
            sdc: Mode Sense: 00 6a 00 00
            sdc: assuming drive cache: write through
            SCSI device sdc: 487261 512-byte hdwr sectors (249 MB)
            sdc: Write Protect is off
            sdc: Mode Sense: 00 6a 00 00
            sdc: assuming drive cache: write through
            sdc:<6>usb 3-2: reset full speed USB device using uhci_hcd and address 17
            usb 3-2: reset full speed USB device using uhci_hcd and address 17
            usb 3-2: reset full speed USB device using uhci_hcd and address 17
            end_request: I/O error, dev sdc, sector 0
            printk: 17 messages suppressed.
            Buffer I/O error on device sdc, logical block 0
            Buffer I/O error on device sdc, logical block 1
            Buffer I/O error on device sdc, logical block 2
            Buffer I/O error on device sdc, logical block 3
            Buffer I/O error on device sdc, logical block 4
            Buffer I/O error on device sdc, logical block 5
            Buffer I/O error on device sdc, logical block 6
            Buffer I/O error on device sdc, logical block 7
            Buffer I/O error on device sdc, logical block 0
            Buffer I/O error on device sdc, logical block 1
            unable to read partition table
            SCSI device sdb: 48000 512-byte hdwr sectors (25 MB)
            sdb: Write Protect is off
            sdb: Mode Sense: 00 6a 00 00
            sdb: assuming drive cache: write through
            SCSI device sdb: 48000 512-byte hdwr sectors (25 MB)
            sdb: Write Protect is off
            sdb: Mode Sense: 00 6a 00 00
            sdb: assuming drive cache: write through
            sdb:<6>usb 3-2: reset full speed USB device using uhci_hcd and address 17
            sd 6:0:0:0: Device not ready: <6>: Current: sense key: Not Ready
            Additional sense: Medium not present
            end_request: I/O error, dev sdb, sector 0
            sd 6:0:0:0: Device not ready: <6>: Current: sense key: Not Ready
            Additional sense: Medium not present
            end_request: I/O error, dev sdb, sector 0
            unable to read partition table
            SCSI device sdc: 487261 512-byte hdwr sectors (249 MB)
            sdc: Write Protect is off
            sdc: Mode Sense: 00 6a 00 00
            sdc: assuming drive cache: write through
            SCSI device sdc: 487261 512-byte hdwr sectors (249 MB)
            sdc: Write Protect is off
            sdc: Mode Sense: 00 6a 00 00
            sdc: assuming drive cache: write through
            sdc:<6>usb 3-2: reset full speed USB device using uhci_hcd and address 17
            usb 3-2: reset full speed USB device using uhci_hcd and address 17
            sd 7:0:0:0: Device not ready: <6>: Current: sense key: Not Ready
            Additional sense: Medium not present
            end_request: I/O error, dev sdc, sector 0
            sd 7:0:0:0: Device not ready: <6>: Current: sense key: Not Ready
            Additional sense: Medium not present
            end_request: I/O error, dev sdc, sector 0
            unable to read partition table

            Apparemment à travers les modules uhci , usb storage repére les deux supports sdc = ma memory stick de 248 Mo et sdb = carte SIM de 25 mo mais il y a des i/o error ,not ready ou unable to read partition table ....
            Peut - être un module supplémentaire est nécessaire ....éventuellement sur le systéme de fichiers utilisés par ce portable ( j' ai installé le module NTFS sans plus de résultat) .

            A vous lire

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n’en sommes pas responsables.