Forum Linux.debian/ubuntu ALSA avec Debian 3.0 (Woody)

Posté par .
Tags : aucun
0
5
août
2004
Bonjour à tous,

Je suis nouveau sous Debian (je reviens d'une période Slackware) et j'ai un petit problème concernant le son.

Je n'ai qu'une connexion Internet RTC donc je me contente des CD de la version 3.0r2.

Pour l'installation, j'ai suivi scrupuleusement le tutoriel http://people.via.ecp.fr/~alexis/formation-linux/(...) et j'ai compilé un noyau 2.6.7 avec le driver de ma carte son en Module (ensoniq1371 pci)

J'installe alsa-base et alsa-utils, je donne la config alsa, j'upgrade-modules et là, /etc/init.d/alsa start me dit "no device".
Pas de panique, j'avais tellement suivi à la lettre le tuto, que j'avais oublié de charger mon module, donc modprobe.
Toujours comme précisé dans le tuto, j'installe et utilise aumix. Puis un test avec mpg123 fonctionne bien.

Sauf qu'il me vient à l'idée d'utiliser alsamixer... Et là, message d'erreur:
No /usr/bin/alsamixer for ALSA 1.0 found
Idem pour alsactl...
(Le script de démarrage me renvoie une version 1.0.4)

Ce que je ne comprend pas, c'est que les packages pour 3.0r2 ont pour version 0.9!
Je ne vois pas d'où vient ce 1.0. Du noyau 2.6?

J'ai trouvé un fil concernant le même problème mais hélas sans solution ici:
http://lists.debian.org/debian-user-french/2004/05/msg01876.html(...)

Si quelqu'un peut m'éclairer...
Merci.
  • # probleme de version?

    Posté par (page perso) . Évalué à 2.

    La version d'Alsa dans le 2.6.7 est la 1.x (je sais pas lequel exactement) La version de la woody est la 0.9x. Tu devrais essayer, soit d'installer les paquets sources alsa pour la version 1.x, soit essayer de trouver des backport des paquets alsa de la sid vers la woody (cherche sur apt-get .org, il semblerait que
     deb http://prometheus.psico.unimib.it/debian(...) ./ 
    soit bon. Comment peut-ton virer proprement le (...) dans les liens??
    • [^] # Re: probleme de version?

      Posté par . Évalué à 1.

      Ah, merci. Je ne connaissais pas www.apt-get.org ni ces histoires de backport...

      Mais si j'explore le lien que vous me donnez, je vois un alsa-utils_0.9.0beta12-1_i386.deb or si je comprend bien, il me faudrait plutôt un alsa-utils_1.0xxx genre celui d'ici: http://www-users.cs.umn.edu/~sdier/debian/updates/wup/(...) non?
      • [^] # Re: probleme de version?

        Posté par (page perso) . Évalué à 2.

        il me faudrait plutôt un alsa-utils_1.0xxx
        Je pense. Mais je n'ai pas trop regardé les lien donné par apt-get.org. Je suis en Sid et ne peut donc tester les backport. De plus, certains sites de backport existent depuis longtemps mais n'ont pas été mis à jour depuis presque aussi longtemps, d'où des paquets anciens et inutilisables....

        Quoiqu'il en soit, en faisant une recherche sur alsa-utils sur apt-get.org (que tu as déjà du lire si j'en crois ton message) http://www1.apt-get.org/search.php?query=alsa-utils&submit=&(...)
        tu as l'embarras du choix. Essaie de regarder lequel pourrait convenir, celui que tu donne pourrait faire l'affaire.

        PS désolé pour le retard, entre les panne de serveur et les courses à faire, je n'ai pas pu le faire plus tôt
        PPS: j'ai aussi une connexion RTC et je suis en SID, mon abonnement étant illimité, je peux faire les mises à jour de nuit sans problème.
        • [^] # Re: probleme de version?

          Posté par . Évalué à 1.

          OK, je vais essayer ça se soir... J'ai trouvé une version 1.0.3 mais pas encore une 1.0.4, mais ça devrait passer...
          Bon, sinon, dans le pire des cas, je peux toujours utiliser aumix qui fonctionne par je ne sais quel miracle. Mais j'aime autant résoudre ces étranges problèmes.

          Pas de problème pour le retard, j'avais moi aussi du boulot cet après-midi.
          • [^] # Re: probleme de version?

            Posté par . Évalué à 1.

            Ca fonctionne avec le lien donné plus haut!
            Merci pour votre aide.

            Maintenant je vais essayer de trouver des backport pour la gravure...
  • # sarge

    Posté par (page perso) . Évalué à 2.

    dommage que tu n'ais que une liaison RTC ..
    la woody stable est vraiment stable ... mais pour une utilisation multimédia/bureau etc., c'est un poil dépassé ...

    je te conseille de te procurer les cds de sarge (ou même une knoppix ... ca repose sur une debian) ...

    A+
    • [^] # Re: sarge

      Posté par . Évalué à 1.

      Sarge semble en effet être la distribution providentielle. Et puis elle devrait bientôt passer en stable...
      Donc j'attendrai un peu les retours puis j'essairai de dégôter les CD.

Suivre le flux des commentaires

Note : les commentaires appartiennent à ceux qui les ont postés. Nous n'en sommes pas responsables.